summaryrefslogtreecommitdiff
path: root/TAO/tao/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/tao/Makefile.am')
-rw-r--r--TAO/tao/Makefile.am35
1 files changed, 21 insertions, 14 deletions
diff --git a/TAO/tao/Makefile.am b/TAO/tao/Makefile.am
index 822e480ea7b..1a8f7017d00 100644
--- a/TAO/tao/Makefile.am
+++ b/TAO/tao/Makefile.am
@@ -47,19 +47,19 @@ PLUGGABLE_PROTOCOLS_FILES = \
IORManipulation.cpp
PLUGGABLE_MESSAGING_FILES = \
-Pluggable_Messaging \
-Pluggable_Messaging_Utils \
-GIOP_Message_Base \
-GIOP_Message_Connectors \
-GIOP_Message_Acceptors \
-GIOP_Message_Accept_State \
-GIOP_Utils \
-GIOP_Message_Headers \
-target_specification \
-GIOP_Server_Request \
-GIOP_Message_Lite \
-GIOP_Message_State \
-Tagged_Profile
+ Pluggable_Messaging \
+ Pluggable_Messaging_Utils \
+ GIOP_Message_Base \
+ GIOP_Message_Connectors \
+ GIOP_Message_Acceptors \
+ GIOP_Message_Accept_State \
+ GIOP_Utils \
+ GIOP_Message_Headers \
+ target_specification \
+ GIOP_Server_Request \
+ GIOP_Message_Lite \
+ GIOP_Message_State \
+ Tagged_Profile
DEFAULT_RESOURCES_FILES = \
default_client.cpp \
@@ -163,7 +163,9 @@ ORB_CORE_FILES = \
Direct_Priority_Mapping.cpp \
RT_Current.cpp \
Pool_Per_Endpoint.cpp \
- GIOPC.cpp
+ GIOPC.cpp \
+ TAO_Singleton_Manager.cpp \
+ DLL_ORB.cpp
DYNAMIC_ANY_FILES = \
DynAnyC.cpp \
@@ -240,6 +242,7 @@ TEMPLATE_FILES = \
Sequence_T.cpp \
TAOS_T.cpp \
TimeBaseS_T.cpp \
+ TAO_Singleton.cpp
else
TEMPLATE_FILES =
endif
@@ -266,6 +269,7 @@ HEADER_FILES = \
Connector_Registry.h \
Context.h \
CurrentC.h \
+ DLL_ORB.h
Direct_Priority_Mapping.h \
DomainC.h \
DomainS_T.h \
@@ -355,6 +359,7 @@ HEADER_FILES = \
TAOS.h \
TAOS_T.h \
TAO_Internal.h \
+ TAO_Singleton.h \
Tagged_Components.h \
TimeBaseC.h \
TimeBaseS.h \
@@ -414,6 +419,7 @@ INLINE_FILES = \
Connector_Registry.i \
Context.i \
CurrentC.i \
+ DLL_ORB.inl \
Direct_Priority_Mapping.i \
DomainC.i \
DomainS_T.i \
@@ -482,6 +488,7 @@ INLINE_FILES = \
Single_Reactor.i \
Stub.i \
Sync_Strategies.i \
+ TAO_Singleton.inl \
TAOC.i \
TAOS.i \
TAOS_T.i \