summaryrefslogtreecommitdiff
path: root/TAO/tests/Bug_2222_Regression/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/tests/Bug_2222_Regression/Makefile.am')
-rw-r--r--TAO/tests/Bug_2222_Regression/Makefile.am101
1 files changed, 101 insertions, 0 deletions
diff --git a/TAO/tests/Bug_2222_Regression/Makefile.am b/TAO/tests/Bug_2222_Regression/Makefile.am
new file mode 100644
index 00000000000..f0f01af2578
--- /dev/null
+++ b/TAO/tests/Bug_2222_Regression/Makefile.am
@@ -0,0 +1,101 @@
+## Process this file with automake to create Makefile.in
+##
+## $Id$
+##
+## This file was generated by MPC. Any changes made directly to
+## this file will be lost the next time it is generated.
+##
+## MPC Command:
+## ../bin/mwc.pl -type automake -noreldefs TAO.mwc
+
+ACE_BUILDDIR = $(top_builddir)/..
+ACE_ROOT = $(top_srcdir)/..
+TAO_BUILDDIR = $(top_builddir)
+TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
+TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
+TAO_IDLFLAGS = -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
+TAO_ROOT = $(top_srcdir)
+
+CLEANFILES =
+BUILT_SOURCES =
+
+## Makefile.Bug_2222_Regression_Test.am
+
+if BUILD_EXCEPTIONS
+
+BUILT_SOURCES += \
+ TestCaseC.cpp \
+ TestCaseC.h \
+ TestCaseC.inl \
+ TestCaseS.h \
+ TestCaseS.inl
+
+CLEANFILES += \
+ TestCase-stamp \
+ TestCaseC.cpp \
+ TestCaseC.h \
+ TestCaseC.inl \
+ TestCaseS.h \
+ TestCaseS.inl
+
+TestCaseC.cpp TestCaseC.h TestCaseC.inl TestCaseS.h TestCaseS.inl: TestCase-stamp
+
+TestCase-stamp: $(srcdir)/TestCase.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -Sa -St $(srcdir)/TestCase.idl
+ @touch $@
+
+BUILT_SOURCES += \
+ TestTypeC.cpp \
+ TestTypeC.h \
+ TestTypeC.inl \
+ TestTypeS.h \
+ TestTypeS.inl
+
+CLEANFILES += \
+ TestType-stamp \
+ TestTypeC.cpp \
+ TestTypeC.h \
+ TestTypeC.inl \
+ TestTypeS.h \
+ TestTypeS.inl
+
+TestTypeC.cpp TestTypeC.h TestTypeC.inl TestTypeS.h TestTypeS.inl: TestType-stamp
+
+TestType-stamp: $(srcdir)/TestType.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -Sa -St $(srcdir)/TestType.idl
+ @touch $@
+
+noinst_PROGRAMS = client
+
+client_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR)
+
+client_SOURCES = \
+ TestCaseC.cpp \
+ TestTypeC.cpp \
+ test.cpp \
+ TestCaseC.h \
+ TestCaseC.inl \
+ TestCaseS.h \
+ TestCaseS.inl \
+ TestTypeC.h \
+ TestTypeC.inl \
+ TestTypeS.h \
+ TestTypeS.inl
+
+client_LDADD = \
+ $(TAO_BUILDDIR)/tao/libTAO.la \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+endif BUILD_EXCEPTIONS
+
+## Clean up template repositories, etc.
+clean-local:
+ -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
+ -rm -f gcctemp.c gcctemp so_locations *.ics
+ -rm -rf cxx_repository ptrepository ti_files
+ -rm -rf templateregistry ir.out
+ -rm -rf ptrepository SunWS_cache Templates.DB