summaryrefslogtreecommitdiff
path: root/TAO/tests/CSD_Strategy_Tests/TP_Foo_C/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/tests/CSD_Strategy_Tests/TP_Foo_C/Makefile.am')
-rw-r--r--TAO/tests/CSD_Strategy_Tests/TP_Foo_C/Makefile.am102
1 files changed, 102 insertions, 0 deletions
diff --git a/TAO/tests/CSD_Strategy_Tests/TP_Foo_C/Makefile.am b/TAO/tests/CSD_Strategy_Tests/TP_Foo_C/Makefile.am
new file mode 100644
index 00000000000..4b967142bcc
--- /dev/null
+++ b/TAO/tests/CSD_Strategy_Tests/TP_Foo_C/Makefile.am
@@ -0,0 +1,102 @@
+## Process this file with automake to create Makefile.in
+##
+## $Id$
+##
+## This file was generated by MPC. Any changes made directly to
+## this file will be lost the next time it is generated.
+##
+## MPC Command:
+## ../bin/mwc.pl -type automake -noreldefs TAO.mwc
+
+ACE_BUILDDIR = $(top_builddir)/..
+ACE_ROOT = $(top_srcdir)/..
+TAO_BUILDDIR = $(top_builddir)
+TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
+TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
+TAO_IDLFLAGS = -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
+TAO_ROOT = $(top_srcdir)
+
+
+## Makefile.csd_tp_foo_c_lib.am
+
+if BUILD_EXCEPTIONS
+if BUILD_THREADS
+
+BUILT_SOURCES = \
+ Foo_CC.cpp \
+ Foo_CC.h \
+ Foo_CC.inl \
+ Foo_CS.cpp \
+ Foo_CS.h \
+ Foo_CS.inl
+
+CLEANFILES = \
+ Foo_C-stamp \
+ Foo_CC.cpp \
+ Foo_CC.h \
+ Foo_CC.inl \
+ Foo_CS.cpp \
+ Foo_CS.h \
+ Foo_CS.inl
+
+Foo_CC.cpp Foo_CC.h Foo_CC.inl Foo_CS.cpp Foo_CS.h Foo_CS.inl: Foo_C-stamp
+
+Foo_C-stamp: $(srcdir)/Foo_C.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -I$(TAO_ROOT)/tests/CSD_Strategy_Tests/TP_Common -b -Wb,export_macro=CSD_TP_Foo_C_Export -Wb,export_include=CSD_TP_Foo_C_Export.h $(srcdir)/Foo_C.idl
+ @touch $@
+
+noinst_LTLIBRARIES = libCSD_TP_Foo_C.la
+
+libCSD_TP_Foo_C_la_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR) \
+ -I$(TAO_ROOT)/tests/CSD_Strategy_Tests/TP_Common \
+ -I$(TAO_ROOT)/tao \
+ -DCSD_TP_FOO_C_BUILD_DLL
+
+libCSD_TP_Foo_C_la_SOURCES = \
+ Foo_CC.cpp \
+ Foo_CS.cpp \
+ Foo_C_ClientEngine.cpp \
+ Foo_C_Custom_ClientEngine.cpp \
+ Foo_C_Custom_Proxy.cpp \
+ Foo_C_Statistics.cpp \
+ Foo_C_cust_op1.cpp \
+ Foo_C_cust_op2.cpp \
+ Foo_C_cust_op3.cpp \
+ Foo_C_cust_op4.cpp \
+ Foo_C_cust_op5.cpp \
+ Foo_C_i.cpp
+
+libCSD_TP_Foo_C_la_LDFLAGS = \
+ -L$(TAO_ROOT)/tests/CSD_Strategy_Tests/TP_Common
+
+noinst_HEADERS = \
+ Foo_C.idl \
+ Foo_CC.h \
+ Foo_CC.inl \
+ Foo_CS.h \
+ Foo_CS.inl \
+ Foo_C_ClientEngine.h \
+ Foo_C_Custom_ClientEngine.h \
+ Foo_C_Custom_Proxy.h \
+ Foo_C_Statistics.h \
+ Foo_C_cust_op1.h \
+ Foo_C_cust_op2.h \
+ Foo_C_cust_op3.h \
+ Foo_C_cust_op4.h \
+ Foo_C_cust_op5.h \
+ Foo_C_i.h
+
+endif BUILD_THREADS
+endif BUILD_EXCEPTIONS
+
+## Clean up template repositories, etc.
+clean-local:
+ -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
+ -rm -f gcctemp.c gcctemp so_locations *.ics
+ -rm -rf cxx_repository ptrepository ti_files
+ -rm -rf templateregistry ir.out
+ -rm -rf ptrepository SunWS_cache Templates.DB