summaryrefslogtreecommitdiff
path: root/TAO/tests/CSD_Strategy_Tests/TP_Test_1/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/tests/CSD_Strategy_Tests/TP_Test_1/Makefile.am')
-rw-r--r--TAO/tests/CSD_Strategy_Tests/TP_Test_1/Makefile.am100
1 files changed, 100 insertions, 0 deletions
diff --git a/TAO/tests/CSD_Strategy_Tests/TP_Test_1/Makefile.am b/TAO/tests/CSD_Strategy_Tests/TP_Test_1/Makefile.am
new file mode 100644
index 00000000000..4c5b0c144ab
--- /dev/null
+++ b/TAO/tests/CSD_Strategy_Tests/TP_Test_1/Makefile.am
@@ -0,0 +1,100 @@
+## Process this file with automake to create Makefile.in
+##
+## $Id$
+##
+## This file was generated by MPC. Any changes made directly to
+## this file will be lost the next time it is generated.
+##
+## MPC Command:
+## ../bin/mwc.pl -type automake -noreldefs TAO.mwc
+
+ACE_BUILDDIR = $(top_builddir)/..
+ACE_ROOT = $(top_srcdir)/..
+TAO_BUILDDIR = $(top_builddir)
+TAO_ROOT = $(top_srcdir)
+
+noinst_PROGRAMS =
+
+## Makefile.CSD_TP_Test_1_Client.am
+
+if BUILD_EXCEPTIONS
+if BUILD_THREADS
+
+noinst_PROGRAMS += client_main
+
+client_main_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR) \
+ -I$(TAO_ROOT)/tests/CSD_Strategy_Tests/TP_Common \
+ -I$(TAO_ROOT)/tests/CSD_Strategy_Tests/TP_Foo_A
+
+client_main_SOURCES = \
+ ClientApp.cpp \
+ client_main.cpp \
+ ClientApp.h
+
+client_main_LDFLAGS = \
+ -L$(TAO_ROOT)/tests/CSD_Strategy_Tests/TP_Common -L$(TAO_ROOT)/tests/CSD_Strategy_Tests/TP_Foo_A
+
+client_main_LDADD = \
+ $(top_builddir)/tests/CSD_Strategy_Tests/TP_Foo_A/libCSD_TP_Foo_A.la \
+ $(top_builddir)/tests/CSD_Strategy_Tests/TP_Common/libCSD_TP_Test.la \
+ $(TAO_BUILDDIR)/tao/libTAO_CSD_ThreadPool.la \
+ $(TAO_BUILDDIR)/tao/libTAO_CSD_Framework.la \
+ $(TAO_BUILDDIR)/tao/libTAO_PI.la \
+ $(TAO_BUILDDIR)/tao/libTAO_CodecFactory.la \
+ $(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
+ $(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
+ $(TAO_BUILDDIR)/tao/libTAO.la \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+endif BUILD_THREADS
+endif BUILD_EXCEPTIONS
+
+## Makefile.CSD_TP_Test_1_Server.am
+
+if BUILD_EXCEPTIONS
+if BUILD_THREADS
+
+noinst_PROGRAMS += server_main
+
+server_main_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR) \
+ -I$(TAO_ROOT)/tests/CSD_Strategy_Tests/TP_Common \
+ -I$(TAO_ROOT)/tests/CSD_Strategy_Tests/TP_Foo_A
+
+server_main_SOURCES = \
+ ServerApp.cpp \
+ server_main.cpp \
+ ServerApp.h
+
+server_main_LDFLAGS = \
+ -L$(TAO_ROOT)/tests/CSD_Strategy_Tests/TP_Common -L$(TAO_ROOT)/tests/CSD_Strategy_Tests/TP_Foo_A
+
+server_main_LDADD = \
+ $(top_builddir)/tests/CSD_Strategy_Tests/TP_Foo_A/libCSD_TP_Foo_A.la \
+ $(top_builddir)/tests/CSD_Strategy_Tests/TP_Common/libCSD_TP_Test.la \
+ $(TAO_BUILDDIR)/tao/libTAO_CSD_ThreadPool.la \
+ $(TAO_BUILDDIR)/tao/libTAO_CSD_Framework.la \
+ $(TAO_BUILDDIR)/tao/libTAO_PI.la \
+ $(TAO_BUILDDIR)/tao/libTAO_CodecFactory.la \
+ $(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
+ $(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
+ $(TAO_BUILDDIR)/tao/libTAO.la \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+endif BUILD_THREADS
+endif BUILD_EXCEPTIONS
+
+## Clean up template repositories, etc.
+clean-local:
+ -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
+ -rm -f gcctemp.c gcctemp so_locations *.ics
+ -rm -rf cxx_repository ptrepository ti_files
+ -rm -rf templateregistry ir.out
+ -rm -rf ptrepository SunWS_cache Templates.DB