summaryrefslogtreecommitdiff
path: root/TAO/tests/CodeSets/libs/UCS4_UTF16/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/tests/CodeSets/libs/UCS4_UTF16/Makefile.am')
-rw-r--r--TAO/tests/CodeSets/libs/UCS4_UTF16/Makefile.am47
1 files changed, 47 insertions, 0 deletions
diff --git a/TAO/tests/CodeSets/libs/UCS4_UTF16/Makefile.am b/TAO/tests/CodeSets/libs/UCS4_UTF16/Makefile.am
new file mode 100644
index 00000000000..5875d3dd899
--- /dev/null
+++ b/TAO/tests/CodeSets/libs/UCS4_UTF16/Makefile.am
@@ -0,0 +1,47 @@
+## Process this file with automake to create Makefile.in
+##
+## $Id$
+##
+## This file was generated by MPC. Any changes made directly to
+## this file will be lost the next time it is generated.
+##
+## MPC Command:
+## ../bin/mwc.pl -type automake -noreldefs TAO.mwc
+
+ACE_BUILDDIR = $(top_builddir)/..
+ACE_ROOT = $(top_srcdir)/..
+TAO_BUILDDIR = $(top_builddir)
+TAO_ROOT = $(top_srcdir)
+
+
+## Makefile.CodeSets_Libs_UCS4_UTF16.am
+
+if BUILD_EXCEPTIONS
+
+noinst_LTLIBRARIES = libUCS4_UTF16.la
+
+libUCS4_UTF16_la_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR) \
+ -DUCS4_UTF16_BUILD_DLL
+
+libUCS4_UTF16_la_SOURCES = \
+ WUCS4_UTF16.cpp \
+ WUCS4_UTF16_Factory.cpp
+
+noinst_HEADERS = \
+ WUCS4_UTF16.h \
+ WUCS4_UTF16_Factory.h \
+ WUCS4_UTF16_export.h
+
+endif BUILD_EXCEPTIONS
+
+## Clean up template repositories, etc.
+clean-local:
+ -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
+ -rm -f gcctemp.c gcctemp so_locations *.ics
+ -rm -rf cxx_repository ptrepository ti_files
+ -rm -rf templateregistry ir.out
+ -rm -rf ptrepository SunWS_cache Templates.DB