summaryrefslogtreecommitdiff
path: root/TAO/tests/IDL_Test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/tests/IDL_Test/Makefile.am')
-rw-r--r--TAO/tests/IDL_Test/Makefile.am1171
1 files changed, 1171 insertions, 0 deletions
diff --git a/TAO/tests/IDL_Test/Makefile.am b/TAO/tests/IDL_Test/Makefile.am
new file mode 100644
index 00000000000..b84c3c4cd5f
--- /dev/null
+++ b/TAO/tests/IDL_Test/Makefile.am
@@ -0,0 +1,1171 @@
+## Process this file with automake to create Makefile.in
+##
+## $Id$
+##
+## This file was generated by MPC. Any changes made directly to
+## this file will be lost the next time it is generated.
+##
+## MPC Command:
+## ../bin/mwc.pl -type automake -noreldefs TAO.mwc
+
+ACE_BUILDDIR = $(top_builddir)/..
+ACE_ROOT = $(top_srcdir)/..
+TAO_BUILDDIR = $(top_builddir)
+TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
+TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
+TAO_IDLFLAGS = -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
+TAO_ROOT = $(top_srcdir)
+
+CLEANFILES =
+BUILT_SOURCES =
+
+## Makefile.IDL_Test_Main.am
+
+if BUILD_CORBA_MESSAGING
+if BUILD_EXCEPTIONS
+
+BUILT_SOURCES += \
+ arrayC.cpp \
+ arrayC.h \
+ arrayC.inl \
+ arrayS.cpp \
+ arrayS.h \
+ arrayS.inl \
+ arrayS_T.cpp \
+ arrayS_T.h
+
+CLEANFILES += \
+ array-stamp \
+ arrayC.cpp \
+ arrayC.h \
+ arrayC.inl \
+ arrayS.cpp \
+ arrayS.h \
+ arrayS.inl \
+ arrayS_T.cpp \
+ arrayS_T.h
+
+arrayC.cpp arrayC.h arrayC.inl arrayS.cpp arrayS.h arrayS.inl arrayS_T.cpp arrayS_T.h: array-stamp
+
+array-stamp: $(srcdir)/array.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -GC -GH -Gd -GT $(srcdir)/array.idl
+ @touch $@
+
+BUILT_SOURCES += \
+ Bug_2577_RegressionC.cpp \
+ Bug_2577_RegressionC.h \
+ Bug_2577_RegressionC.inl \
+ Bug_2577_RegressionS.cpp \
+ Bug_2577_RegressionS.h \
+ Bug_2577_RegressionS.inl \
+ Bug_2577_RegressionS_T.cpp \
+ Bug_2577_RegressionS_T.h
+
+CLEANFILES += \
+ Bug_2577_Regression-stamp \
+ Bug_2577_RegressionC.cpp \
+ Bug_2577_RegressionC.h \
+ Bug_2577_RegressionC.inl \
+ Bug_2577_RegressionS.cpp \
+ Bug_2577_RegressionS.h \
+ Bug_2577_RegressionS.inl \
+ Bug_2577_RegressionS_T.cpp \
+ Bug_2577_RegressionS_T.h
+
+Bug_2577_RegressionC.cpp Bug_2577_RegressionC.h Bug_2577_RegressionC.inl Bug_2577_RegressionS.cpp Bug_2577_RegressionS.h Bug_2577_RegressionS.inl Bug_2577_RegressionS_T.cpp Bug_2577_RegressionS_T.h: Bug_2577_Regression-stamp
+
+Bug_2577_Regression-stamp: $(srcdir)/Bug_2577_Regression.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -GC -GH -Gd -GT $(srcdir)/Bug_2577_Regression.idl
+ @touch $@
+
+BUILT_SOURCES += \
+ Bug_2582_RegressionC.cpp \
+ Bug_2582_RegressionC.h \
+ Bug_2582_RegressionC.inl \
+ Bug_2582_RegressionS.cpp \
+ Bug_2582_RegressionS.h \
+ Bug_2582_RegressionS.inl \
+ Bug_2582_RegressionS_T.cpp \
+ Bug_2582_RegressionS_T.h
+
+CLEANFILES += \
+ Bug_2582_Regression-stamp \
+ Bug_2582_RegressionC.cpp \
+ Bug_2582_RegressionC.h \
+ Bug_2582_RegressionC.inl \
+ Bug_2582_RegressionS.cpp \
+ Bug_2582_RegressionS.h \
+ Bug_2582_RegressionS.inl \
+ Bug_2582_RegressionS_T.cpp \
+ Bug_2582_RegressionS_T.h
+
+Bug_2582_RegressionC.cpp Bug_2582_RegressionC.h Bug_2582_RegressionC.inl Bug_2582_RegressionS.cpp Bug_2582_RegressionS.h Bug_2582_RegressionS.inl Bug_2582_RegressionS_T.cpp Bug_2582_RegressionS_T.h: Bug_2582_Regression-stamp
+
+Bug_2582_Regression-stamp: $(srcdir)/Bug_2582_Regression.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -GC -GH -Gd -GT $(srcdir)/Bug_2582_Regression.idl
+ @touch $@
+
+BUILT_SOURCES += \
+ Bug_2583_RegressionC.cpp \
+ Bug_2583_RegressionC.h \
+ Bug_2583_RegressionC.inl \
+ Bug_2583_RegressionS.cpp \
+ Bug_2583_RegressionS.h \
+ Bug_2583_RegressionS.inl \
+ Bug_2583_RegressionS_T.cpp \
+ Bug_2583_RegressionS_T.h
+
+CLEANFILES += \
+ Bug_2583_Regression-stamp \
+ Bug_2583_RegressionC.cpp \
+ Bug_2583_RegressionC.h \
+ Bug_2583_RegressionC.inl \
+ Bug_2583_RegressionS.cpp \
+ Bug_2583_RegressionS.h \
+ Bug_2583_RegressionS.inl \
+ Bug_2583_RegressionS_T.cpp \
+ Bug_2583_RegressionS_T.h
+
+Bug_2583_RegressionC.cpp Bug_2583_RegressionC.h Bug_2583_RegressionC.inl Bug_2583_RegressionS.cpp Bug_2583_RegressionS.h Bug_2583_RegressionS.inl Bug_2583_RegressionS_T.cpp Bug_2583_RegressionS_T.h: Bug_2583_Regression-stamp
+
+Bug_2583_Regression-stamp: $(srcdir)/Bug_2583_Regression.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -GC -GH -Gd -GT $(srcdir)/Bug_2583_Regression.idl
+ @touch $@
+
+BUILT_SOURCES += \
+ Bug_2616_RegressionC.cpp \
+ Bug_2616_RegressionC.h \
+ Bug_2616_RegressionC.inl \
+ Bug_2616_RegressionS.cpp \
+ Bug_2616_RegressionS.h \
+ Bug_2616_RegressionS.inl \
+ Bug_2616_RegressionS_T.cpp \
+ Bug_2616_RegressionS_T.h
+
+CLEANFILES += \
+ Bug_2616_Regression-stamp \
+ Bug_2616_RegressionC.cpp \
+ Bug_2616_RegressionC.h \
+ Bug_2616_RegressionC.inl \
+ Bug_2616_RegressionS.cpp \
+ Bug_2616_RegressionS.h \
+ Bug_2616_RegressionS.inl \
+ Bug_2616_RegressionS_T.cpp \
+ Bug_2616_RegressionS_T.h
+
+Bug_2616_RegressionC.cpp Bug_2616_RegressionC.h Bug_2616_RegressionC.inl Bug_2616_RegressionS.cpp Bug_2616_RegressionS.h Bug_2616_RegressionS.inl Bug_2616_RegressionS_T.cpp Bug_2616_RegressionS_T.h: Bug_2616_Regression-stamp
+
+Bug_2616_Regression-stamp: $(srcdir)/Bug_2616_Regression.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -GC -GH -Gd -GT $(srcdir)/Bug_2616_Regression.idl
+ @touch $@
+
+BUILT_SOURCES += \
+ Bug_2619_RegressionC.cpp \
+ Bug_2619_RegressionC.h \
+ Bug_2619_RegressionC.inl \
+ Bug_2619_RegressionS.cpp \
+ Bug_2619_RegressionS.h \
+ Bug_2619_RegressionS.inl \
+ Bug_2619_RegressionS_T.cpp \
+ Bug_2619_RegressionS_T.h
+
+CLEANFILES += \
+ Bug_2619_Regression-stamp \
+ Bug_2619_RegressionC.cpp \
+ Bug_2619_RegressionC.h \
+ Bug_2619_RegressionC.inl \
+ Bug_2619_RegressionS.cpp \
+ Bug_2619_RegressionS.h \
+ Bug_2619_RegressionS.inl \
+ Bug_2619_RegressionS_T.cpp \
+ Bug_2619_RegressionS_T.h
+
+Bug_2619_RegressionC.cpp Bug_2619_RegressionC.h Bug_2619_RegressionC.inl Bug_2619_RegressionS.cpp Bug_2619_RegressionS.h Bug_2619_RegressionS.inl Bug_2619_RegressionS_T.cpp Bug_2619_RegressionS_T.h: Bug_2619_Regression-stamp
+
+Bug_2619_Regression-stamp: $(srcdir)/Bug_2619_Regression.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -GC -GH -Gd -GT $(srcdir)/Bug_2619_Regression.idl
+ @touch $@
+
+BUILT_SOURCES += \
+ enum_in_structC.cpp \
+ enum_in_structC.h \
+ enum_in_structC.inl \
+ enum_in_structS.cpp \
+ enum_in_structS.h \
+ enum_in_structS.inl \
+ enum_in_structS_T.cpp \
+ enum_in_structS_T.h
+
+CLEANFILES += \
+ enum_in_struct-stamp \
+ enum_in_structC.cpp \
+ enum_in_structC.h \
+ enum_in_structC.inl \
+ enum_in_structS.cpp \
+ enum_in_structS.h \
+ enum_in_structS.inl \
+ enum_in_structS_T.cpp \
+ enum_in_structS_T.h
+
+enum_in_structC.cpp enum_in_structC.h enum_in_structC.inl enum_in_structS.cpp enum_in_structS.h enum_in_structS.inl enum_in_structS_T.cpp enum_in_structS_T.h: enum_in_struct-stamp
+
+enum_in_struct-stamp: $(srcdir)/enum_in_struct.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -GC -GH -Gd -GT $(srcdir)/enum_in_struct.idl
+ @touch $@
+
+BUILT_SOURCES += \
+ fullC.cpp \
+ fullC.h \
+ fullC.inl \
+ fullS.cpp \
+ fullS.h \
+ fullS.inl \
+ fullS_T.cpp \
+ fullS_T.h
+
+CLEANFILES += \
+ full-stamp \
+ fullC.cpp \
+ fullC.h \
+ fullC.inl \
+ fullS.cpp \
+ fullS.h \
+ fullS.inl \
+ fullS_T.cpp \
+ fullS_T.h
+
+fullC.cpp fullC.h fullC.inl fullS.cpp fullS.h fullS.inl fullS_T.cpp fullS_T.h: full-stamp
+
+full-stamp: $(srcdir)/full.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -GC -GH -Gd -GT $(srcdir)/full.idl
+ @touch $@
+
+BUILT_SOURCES += \
+ fwdC.cpp \
+ fwdC.h \
+ fwdC.inl \
+ fwdS.cpp \
+ fwdS.h \
+ fwdS.inl \
+ fwdS_T.cpp \
+ fwdS_T.h
+
+CLEANFILES += \
+ fwd-stamp \
+ fwdC.cpp \
+ fwdC.h \
+ fwdC.inl \
+ fwdS.cpp \
+ fwdS.h \
+ fwdS.inl \
+ fwdS_T.cpp \
+ fwdS_T.h
+
+fwdC.cpp fwdC.h fwdC.inl fwdS.cpp fwdS.h fwdS.inl fwdS_T.cpp fwdS_T.h: fwd-stamp
+
+fwd-stamp: $(srcdir)/fwd.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -GC -GH -Gd -GT $(srcdir)/fwd.idl
+ @touch $@
+
+BUILT_SOURCES += \
+ gperfC.cpp \
+ gperfC.h \
+ gperfC.inl \
+ gperfS.cpp \
+ gperfS.h \
+ gperfS.inl \
+ gperfS_T.cpp \
+ gperfS_T.h
+
+CLEANFILES += \
+ gperf-stamp \
+ gperfC.cpp \
+ gperfC.h \
+ gperfC.inl \
+ gperfS.cpp \
+ gperfS.h \
+ gperfS.inl \
+ gperfS_T.cpp \
+ gperfS_T.h
+
+gperfC.cpp gperfC.h gperfC.inl gperfS.cpp gperfS.h gperfS.inl gperfS_T.cpp gperfS_T.h: gperf-stamp
+
+gperf-stamp: $(srcdir)/gperf.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -GC -GH -Gd -GT $(srcdir)/gperf.idl
+ @touch $@
+
+BUILT_SOURCES += \
+ includingC.cpp \
+ includingC.h \
+ includingC.inl \
+ includingS.cpp \
+ includingS.h \
+ includingS.inl \
+ includingS_T.cpp \
+ includingS_T.h
+
+CLEANFILES += \
+ including-stamp \
+ includingC.cpp \
+ includingC.h \
+ includingC.inl \
+ includingS.cpp \
+ includingS.h \
+ includingS.inl \
+ includingS_T.cpp \
+ includingS_T.h
+
+includingC.cpp includingC.h includingC.inl includingS.cpp includingS.h includingS.inl includingS_T.cpp includingS_T.h: including-stamp
+
+including-stamp: $(srcdir)/including.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -GC -GH -Gd -GT $(srcdir)/including.idl
+ @touch $@
+
+BUILT_SOURCES += \
+ interfaceC.cpp \
+ interfaceC.h \
+ interfaceC.inl \
+ interfaceS.cpp \
+ interfaceS.h \
+ interfaceS.inl \
+ interfaceS_T.cpp \
+ interfaceS_T.h
+
+CLEANFILES += \
+ interface-stamp \
+ interfaceC.cpp \
+ interfaceC.h \
+ interfaceC.inl \
+ interfaceS.cpp \
+ interfaceS.h \
+ interfaceS.inl \
+ interfaceS_T.cpp \
+ interfaceS_T.h
+
+interfaceC.cpp interfaceC.h interfaceC.inl interfaceS.cpp interfaceS.h interfaceS.inl interfaceS_T.cpp interfaceS_T.h: interface-stamp
+
+interface-stamp: $(srcdir)/interface.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -GC -GH -Gd -GT $(srcdir)/interface.idl
+ @touch $@
+
+BUILT_SOURCES += \
+ includedC.cpp \
+ includedC.h \
+ includedC.inl \
+ includedS.cpp \
+ includedS.h \
+ includedS.inl \
+ includedS_T.cpp \
+ includedS_T.h
+
+CLEANFILES += \
+ included-stamp \
+ includedC.cpp \
+ includedC.h \
+ includedC.inl \
+ includedS.cpp \
+ includedS.h \
+ includedS.inl \
+ includedS_T.cpp \
+ includedS_T.h
+
+includedC.cpp includedC.h includedC.inl includedS.cpp includedS.h includedS.inl includedS_T.cpp includedS_T.h: included-stamp
+
+included-stamp: $(srcdir)/included.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -GC -GH -Gd -GT $(srcdir)/included.idl
+ @touch $@
+
+BUILT_SOURCES += \
+ unionC.cpp \
+ unionC.h \
+ unionC.inl \
+ unionS.cpp \
+ unionS.h \
+ unionS.inl \
+ unionS_T.cpp \
+ unionS_T.h
+
+CLEANFILES += \
+ union-stamp \
+ unionC.cpp \
+ unionC.h \
+ unionC.inl \
+ unionS.cpp \
+ unionS.h \
+ unionS.inl \
+ unionS_T.cpp \
+ unionS_T.h
+
+unionC.cpp unionC.h unionC.inl unionS.cpp unionS.h unionS.inl unionS_T.cpp unionS_T.h: union-stamp
+
+union-stamp: $(srcdir)/union.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -GC -GH -Gd -GT $(srcdir)/union.idl
+ @touch $@
+
+BUILT_SOURCES += \
+ nested_scopeC.cpp \
+ nested_scopeC.h \
+ nested_scopeC.inl \
+ nested_scopeS.cpp \
+ nested_scopeS.h \
+ nested_scopeS.inl \
+ nested_scopeS_T.cpp \
+ nested_scopeS_T.h
+
+CLEANFILES += \
+ nested_scope-stamp \
+ nested_scopeC.cpp \
+ nested_scopeC.h \
+ nested_scopeC.inl \
+ nested_scopeS.cpp \
+ nested_scopeS.h \
+ nested_scopeS.inl \
+ nested_scopeS_T.cpp \
+ nested_scopeS_T.h
+
+nested_scopeC.cpp nested_scopeC.h nested_scopeC.inl nested_scopeS.cpp nested_scopeS.h nested_scopeS.inl nested_scopeS_T.cpp nested_scopeS_T.h: nested_scope-stamp
+
+nested_scope-stamp: $(srcdir)/nested_scope.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -GC -GH -Gd -GT $(srcdir)/nested_scope.idl
+ @touch $@
+
+BUILT_SOURCES += \
+ paramsC.cpp \
+ paramsC.h \
+ paramsC.inl \
+ paramsS.cpp \
+ paramsS.h \
+ paramsS.inl \
+ paramsS_T.cpp \
+ paramsS_T.h
+
+CLEANFILES += \
+ params-stamp \
+ paramsC.cpp \
+ paramsC.h \
+ paramsC.inl \
+ paramsS.cpp \
+ paramsS.h \
+ paramsS.inl \
+ paramsS_T.cpp \
+ paramsS_T.h
+
+paramsC.cpp paramsC.h paramsC.inl paramsS.cpp paramsS.h paramsS.inl paramsS_T.cpp paramsS_T.h: params-stamp
+
+params-stamp: $(srcdir)/params.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -GC -GH -Gd -GT $(srcdir)/params.idl
+ @touch $@
+
+BUILT_SOURCES += \
+ reopened_modulesC.cpp \
+ reopened_modulesC.h \
+ reopened_modulesC.inl \
+ reopened_modulesS.cpp \
+ reopened_modulesS.h \
+ reopened_modulesS.inl \
+ reopened_modulesS_T.cpp \
+ reopened_modulesS_T.h
+
+CLEANFILES += \
+ reopened_modules-stamp \
+ reopened_modulesC.cpp \
+ reopened_modulesC.h \
+ reopened_modulesC.inl \
+ reopened_modulesS.cpp \
+ reopened_modulesS.h \
+ reopened_modulesS.inl \
+ reopened_modulesS_T.cpp \
+ reopened_modulesS_T.h
+
+reopened_modulesC.cpp reopened_modulesC.h reopened_modulesC.inl reopened_modulesS.cpp reopened_modulesS.h reopened_modulesS.inl reopened_modulesS_T.cpp reopened_modulesS_T.h: reopened_modules-stamp
+
+reopened_modules-stamp: $(srcdir)/reopened_modules.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -GC -GH -Gd -GT $(srcdir)/reopened_modules.idl
+ @touch $@
+
+BUILT_SOURCES += \
+ sequenceC.cpp \
+ sequenceC.h \
+ sequenceC.inl \
+ sequenceS.cpp \
+ sequenceS.h \
+ sequenceS.inl \
+ sequenceS_T.cpp \
+ sequenceS_T.h
+
+CLEANFILES += \
+ sequence-stamp \
+ sequenceC.cpp \
+ sequenceC.h \
+ sequenceC.inl \
+ sequenceS.cpp \
+ sequenceS.h \
+ sequenceS.inl \
+ sequenceS_T.cpp \
+ sequenceS_T.h
+
+sequenceC.cpp sequenceC.h sequenceC.inl sequenceS.cpp sequenceS.h sequenceS.inl sequenceS_T.cpp sequenceS_T.h: sequence-stamp
+
+sequence-stamp: $(srcdir)/sequence.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -GC -GH -Gd -GT $(srcdir)/sequence.idl
+ @touch $@
+
+BUILT_SOURCES += \
+ reopen_include1C.cpp \
+ reopen_include1C.h \
+ reopen_include1C.inl \
+ reopen_include1S.cpp \
+ reopen_include1S.h \
+ reopen_include1S.inl \
+ reopen_include1S_T.cpp \
+ reopen_include1S_T.h
+
+CLEANFILES += \
+ reopen_include1-stamp \
+ reopen_include1C.cpp \
+ reopen_include1C.h \
+ reopen_include1C.inl \
+ reopen_include1S.cpp \
+ reopen_include1S.h \
+ reopen_include1S.inl \
+ reopen_include1S_T.cpp \
+ reopen_include1S_T.h
+
+reopen_include1C.cpp reopen_include1C.h reopen_include1C.inl reopen_include1S.cpp reopen_include1S.h reopen_include1S.inl reopen_include1S_T.cpp reopen_include1S_T.h: reopen_include1-stamp
+
+reopen_include1-stamp: $(srcdir)/reopen_include1.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -GC -GH -Gd -GT $(srcdir)/reopen_include1.idl
+ @touch $@
+
+BUILT_SOURCES += \
+ reopen_include2C.cpp \
+ reopen_include2C.h \
+ reopen_include2C.inl \
+ reopen_include2S.cpp \
+ reopen_include2S.h \
+ reopen_include2S.inl \
+ reopen_include2S_T.cpp \
+ reopen_include2S_T.h
+
+CLEANFILES += \
+ reopen_include2-stamp \
+ reopen_include2C.cpp \
+ reopen_include2C.h \
+ reopen_include2C.inl \
+ reopen_include2S.cpp \
+ reopen_include2S.h \
+ reopen_include2S.inl \
+ reopen_include2S_T.cpp \
+ reopen_include2S_T.h
+
+reopen_include2C.cpp reopen_include2C.h reopen_include2C.inl reopen_include2S.cpp reopen_include2S.h reopen_include2S.inl reopen_include2S_T.cpp reopen_include2S_T.h: reopen_include2-stamp
+
+reopen_include2-stamp: $(srcdir)/reopen_include2.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -GC -GH -Gd -GT $(srcdir)/reopen_include2.idl
+ @touch $@
+
+BUILT_SOURCES += \
+ typeprefixC.cpp \
+ typeprefixC.h \
+ typeprefixC.inl \
+ typeprefixS.cpp \
+ typeprefixS.h \
+ typeprefixS.inl \
+ typeprefixS_T.cpp \
+ typeprefixS_T.h
+
+CLEANFILES += \
+ typeprefix-stamp \
+ typeprefixC.cpp \
+ typeprefixC.h \
+ typeprefixC.inl \
+ typeprefixS.cpp \
+ typeprefixS.h \
+ typeprefixS.inl \
+ typeprefixS_T.cpp \
+ typeprefixS_T.h
+
+typeprefixC.cpp typeprefixC.h typeprefixC.inl typeprefixS.cpp typeprefixS.h typeprefixS.inl typeprefixS_T.cpp typeprefixS_T.h: typeprefix-stamp
+
+typeprefix-stamp: $(srcdir)/typeprefix.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -GC -GH -Gd -GT $(srcdir)/typeprefix.idl
+ @touch $@
+
+BUILT_SOURCES += \
+ anonymousA.cpp \
+ anonymousA.h \
+ anonymousC.cpp \
+ anonymousC.h \
+ anonymousC.inl \
+ anonymousS.cpp \
+ anonymousS.h \
+ anonymousS.inl \
+ anonymousS_T.cpp \
+ anonymousS_T.h
+
+CLEANFILES += \
+ anonymous-stamp \
+ anonymousA.cpp \
+ anonymousA.h \
+ anonymousC.cpp \
+ anonymousC.h \
+ anonymousC.inl \
+ anonymousS.cpp \
+ anonymousS.h \
+ anonymousS.inl \
+ anonymousS_T.cpp \
+ anonymousS_T.h
+
+anonymousA.cpp anonymousA.h anonymousC.cpp anonymousC.h anonymousC.inl anonymousS.cpp anonymousS.h anonymousS.inl anonymousS_T.cpp anonymousS_T.h: anonymous-stamp
+
+anonymous-stamp: $(srcdir)/anonymous.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -GC -GH -Gd -GA -GT $(srcdir)/anonymous.idl
+ @touch $@
+
+BUILT_SOURCES += \
+ constantsA.cpp \
+ constantsA.h \
+ constantsC.cpp \
+ constantsC.h \
+ constantsC.inl \
+ constantsS.cpp \
+ constantsS.h \
+ constantsS.inl \
+ constantsS_T.cpp \
+ constantsS_T.h
+
+CLEANFILES += \
+ constants-stamp \
+ constantsA.cpp \
+ constantsA.h \
+ constantsC.cpp \
+ constantsC.h \
+ constantsC.inl \
+ constantsS.cpp \
+ constantsS.h \
+ constantsS.inl \
+ constantsS_T.cpp \
+ constantsS_T.h
+
+constantsA.cpp constantsA.h constantsC.cpp constantsC.h constantsC.inl constantsS.cpp constantsS.h constantsS.inl constantsS_T.cpp constantsS_T.h: constants-stamp
+
+constants-stamp: $(srcdir)/constants.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -GC -GH -Gd -GA -GT $(srcdir)/constants.idl
+ @touch $@
+
+BUILT_SOURCES += \
+ generic_objectA.cpp \
+ generic_objectA.h \
+ generic_objectC.cpp \
+ generic_objectC.h \
+ generic_objectC.inl \
+ generic_objectS.cpp \
+ generic_objectS.h \
+ generic_objectS.inl \
+ generic_objectS_T.cpp \
+ generic_objectS_T.h
+
+CLEANFILES += \
+ generic_object-stamp \
+ generic_objectA.cpp \
+ generic_objectA.h \
+ generic_objectC.cpp \
+ generic_objectC.h \
+ generic_objectC.inl \
+ generic_objectS.cpp \
+ generic_objectS.h \
+ generic_objectS.inl \
+ generic_objectS_T.cpp \
+ generic_objectS_T.h
+
+generic_objectA.cpp generic_objectA.h generic_objectC.cpp generic_objectC.h generic_objectC.inl generic_objectS.cpp generic_objectS.h generic_objectS.inl generic_objectS_T.cpp generic_objectS_T.h: generic_object-stamp
+
+generic_object-stamp: $(srcdir)/generic_object.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -GC -GH -Gd -GA -GT $(srcdir)/generic_object.idl
+ @touch $@
+
+BUILT_SOURCES += \
+ keywordsA.cpp \
+ keywordsA.h \
+ keywordsC.cpp \
+ keywordsC.h \
+ keywordsC.inl \
+ keywordsS.cpp \
+ keywordsS.h \
+ keywordsS.inl \
+ keywordsS_T.cpp \
+ keywordsS_T.h
+
+CLEANFILES += \
+ keywords-stamp \
+ keywordsA.cpp \
+ keywordsA.h \
+ keywordsC.cpp \
+ keywordsC.h \
+ keywordsC.inl \
+ keywordsS.cpp \
+ keywordsS.h \
+ keywordsS.inl \
+ keywordsS_T.cpp \
+ keywordsS_T.h
+
+keywordsA.cpp keywordsA.h keywordsC.cpp keywordsC.h keywordsC.inl keywordsS.cpp keywordsS.h keywordsS.inl keywordsS_T.cpp keywordsS_T.h: keywords-stamp
+
+keywords-stamp: $(srcdir)/keywords.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -GC -GH -Gd -GA -GT $(srcdir)/keywords.idl
+ @touch $@
+
+BUILT_SOURCES += \
+ pragmaA.cpp \
+ pragmaA.h \
+ pragmaC.cpp \
+ pragmaC.h \
+ pragmaC.inl \
+ pragmaS.cpp \
+ pragmaS.h \
+ pragmaS.inl \
+ pragmaS_T.cpp \
+ pragmaS_T.h
+
+CLEANFILES += \
+ pragma-stamp \
+ pragmaA.cpp \
+ pragmaA.h \
+ pragmaC.cpp \
+ pragmaC.h \
+ pragmaC.inl \
+ pragmaS.cpp \
+ pragmaS.h \
+ pragmaS.inl \
+ pragmaS_T.cpp \
+ pragmaS_T.h
+
+pragmaA.cpp pragmaA.h pragmaC.cpp pragmaC.h pragmaC.inl pragmaS.cpp pragmaS.h pragmaS.inl pragmaS_T.cpp pragmaS_T.h: pragma-stamp
+
+pragma-stamp: $(srcdir)/pragma.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -GC -GH -Gd -GA -GT $(srcdir)/pragma.idl
+ @touch $@
+
+BUILT_SOURCES += \
+ repo_id_modA.cpp \
+ repo_id_modA.h \
+ repo_id_modC.cpp \
+ repo_id_modC.h \
+ repo_id_modC.inl \
+ repo_id_modS.cpp \
+ repo_id_modS.h \
+ repo_id_modS.inl \
+ repo_id_modS_T.cpp \
+ repo_id_modS_T.h
+
+CLEANFILES += \
+ repo_id_mod-stamp \
+ repo_id_modA.cpp \
+ repo_id_modA.h \
+ repo_id_modC.cpp \
+ repo_id_modC.h \
+ repo_id_modC.inl \
+ repo_id_modS.cpp \
+ repo_id_modS.h \
+ repo_id_modS.inl \
+ repo_id_modS_T.cpp \
+ repo_id_modS_T.h
+
+repo_id_modA.cpp repo_id_modA.h repo_id_modC.cpp repo_id_modC.h repo_id_modC.inl repo_id_modS.cpp repo_id_modS.h repo_id_modS.inl repo_id_modS_T.cpp repo_id_modS_T.h: repo_id_mod-stamp
+
+repo_id_mod-stamp: $(srcdir)/repo_id_mod.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -GC -GH -Gd -GA -GT $(srcdir)/repo_id_mod.idl
+ @touch $@
+
+BUILT_SOURCES += \
+ typedefA.cpp \
+ typedefA.h \
+ typedefC.cpp \
+ typedefC.h \
+ typedefC.inl \
+ typedefS.cpp \
+ typedefS.h \
+ typedefS.inl \
+ typedefS_T.cpp \
+ typedefS_T.h
+
+CLEANFILES += \
+ typedef-stamp \
+ typedefA.cpp \
+ typedefA.h \
+ typedefC.cpp \
+ typedefC.h \
+ typedefC.inl \
+ typedefS.cpp \
+ typedefS.h \
+ typedefS.inl \
+ typedefS_T.cpp \
+ typedefS_T.h
+
+typedefA.cpp typedefA.h typedefC.cpp typedefC.h typedefC.inl typedefS.cpp typedefS.h typedefS.inl typedefS_T.cpp typedefS_T.h: typedef-stamp
+
+typedef-stamp: $(srcdir)/typedef.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -GC -GH -Gd -GA -GT $(srcdir)/typedef.idl
+ @touch $@
+
+BUILT_SOURCES += \
+ valuetypeA.cpp \
+ valuetypeA.h \
+ valuetypeC.cpp \
+ valuetypeC.h \
+ valuetypeC.inl \
+ valuetypeS.cpp \
+ valuetypeS.h \
+ valuetypeS.inl \
+ valuetypeS_T.cpp \
+ valuetypeS_T.h
+
+CLEANFILES += \
+ valuetype-stamp \
+ valuetypeA.cpp \
+ valuetypeA.h \
+ valuetypeC.cpp \
+ valuetypeC.h \
+ valuetypeC.inl \
+ valuetypeS.cpp \
+ valuetypeS.h \
+ valuetypeS.inl \
+ valuetypeS_T.cpp \
+ valuetypeS_T.h
+
+valuetypeA.cpp valuetypeA.h valuetypeC.cpp valuetypeC.h valuetypeC.inl valuetypeS.cpp valuetypeS.h valuetypeS.inl valuetypeS_T.cpp valuetypeS_T.h: valuetype-stamp
+
+valuetype-stamp: $(srcdir)/valuetype.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -GC -GH -Gd -GA -GT $(srcdir)/valuetype.idl
+ @touch $@
+
+BUILT_SOURCES += \
+ array_onlyA.cpp \
+ array_onlyA.h \
+ array_onlyC.cpp \
+ array_onlyC.h \
+ array_onlyC.inl \
+ array_onlyS.cpp \
+ array_onlyS.h \
+ array_onlyS.inl \
+ array_onlyS_T.cpp \
+ array_onlyS_T.h
+
+CLEANFILES += \
+ array_only-stamp \
+ array_onlyA.cpp \
+ array_onlyA.h \
+ array_onlyC.cpp \
+ array_onlyC.h \
+ array_onlyC.inl \
+ array_onlyS.cpp \
+ array_onlyS.h \
+ array_onlyS.inl \
+ array_onlyS_T.cpp \
+ array_onlyS_T.h
+
+array_onlyA.cpp array_onlyA.h array_onlyC.cpp array_onlyC.h array_onlyC.inl array_onlyS.cpp array_onlyS.h array_onlyS.inl array_onlyS_T.cpp array_onlyS_T.h: array_only-stamp
+
+array_only-stamp: $(srcdir)/array_only.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -GC -GH -Gd -GA -GT $(srcdir)/array_only.idl
+ @touch $@
+
+BUILT_SOURCES += \
+ typecodeA.cpp \
+ typecodeA.h \
+ typecodeC.cpp \
+ typecodeC.h \
+ typecodeC.inl \
+ typecodeS.cpp \
+ typecodeS.h \
+ typecodeS.inl \
+ typecodeS_T.cpp \
+ typecodeS_T.h
+
+CLEANFILES += \
+ typecode-stamp \
+ typecodeA.cpp \
+ typecodeA.h \
+ typecodeC.cpp \
+ typecodeC.h \
+ typecodeC.inl \
+ typecodeS.cpp \
+ typecodeS.h \
+ typecodeS.inl \
+ typecodeS_T.cpp \
+ typecodeS_T.h
+
+typecodeA.cpp typecodeA.h typecodeC.cpp typecodeC.h typecodeC.inl typecodeS.cpp typecodeS.h typecodeS.inl typecodeS_T.cpp typecodeS_T.h: typecode-stamp
+
+typecode-stamp: $(srcdir)/typecode.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -GC -GH -Gd -GA -GT $(srcdir)/typecode.idl
+ @touch $@
+
+noinst_PROGRAMS = main
+
+main_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR)
+
+main_SOURCES = \
+ Bug_2577_RegressionC.cpp \
+ Bug_2577_RegressionS.cpp \
+ Bug_2582_RegressionC.cpp \
+ Bug_2582_RegressionS.cpp \
+ Bug_2583_RegressionC.cpp \
+ Bug_2583_RegressionS.cpp \
+ Bug_2616_RegressionC.cpp \
+ Bug_2616_RegressionS.cpp \
+ Bug_2619_RegressionC.cpp \
+ Bug_2619_RegressionS.cpp \
+ anonymousA.cpp \
+ anonymousC.cpp \
+ anonymousS.cpp \
+ arrayC.cpp \
+ arrayS.cpp \
+ array_onlyA.cpp \
+ array_onlyC.cpp \
+ array_onlyS.cpp \
+ constantsA.cpp \
+ constantsC.cpp \
+ constantsS.cpp \
+ enum_in_structC.cpp \
+ enum_in_structS.cpp \
+ fullC.cpp \
+ fullS.cpp \
+ fwdC.cpp \
+ fwdS.cpp \
+ generic_objectA.cpp \
+ generic_objectC.cpp \
+ generic_objectS.cpp \
+ gperfC.cpp \
+ gperfS.cpp \
+ includedC.cpp \
+ includedS.cpp \
+ includingC.cpp \
+ includingS.cpp \
+ interfaceC.cpp \
+ interfaceS.cpp \
+ keywordsA.cpp \
+ keywordsC.cpp \
+ keywordsS.cpp \
+ main.cpp \
+ nested_scopeC.cpp \
+ nested_scopeS.cpp \
+ paramsC.cpp \
+ paramsS.cpp \
+ pragmaA.cpp \
+ pragmaC.cpp \
+ pragmaS.cpp \
+ reopen_include1C.cpp \
+ reopen_include1S.cpp \
+ reopen_include2C.cpp \
+ reopen_include2S.cpp \
+ reopened_modulesC.cpp \
+ reopened_modulesS.cpp \
+ repo_id_modA.cpp \
+ repo_id_modC.cpp \
+ repo_id_modS.cpp \
+ sequenceC.cpp \
+ sequenceS.cpp \
+ typecodeA.cpp \
+ typecodeC.cpp \
+ typecodeS.cpp \
+ typedefA.cpp \
+ typedefC.cpp \
+ typedefS.cpp \
+ typeprefixC.cpp \
+ typeprefixS.cpp \
+ unionC.cpp \
+ unionS.cpp \
+ valuetypeA.cpp \
+ valuetypeC.cpp \
+ valuetypeS.cpp \
+ Bug_2577_RegressionC.h \
+ Bug_2577_RegressionC.inl \
+ Bug_2577_RegressionS.h \
+ Bug_2577_RegressionS.inl \
+ Bug_2577_RegressionS_T.h \
+ Bug_2582_RegressionC.h \
+ Bug_2582_RegressionC.inl \
+ Bug_2582_RegressionS.h \
+ Bug_2582_RegressionS.inl \
+ Bug_2582_RegressionS_T.h \
+ Bug_2583_RegressionC.h \
+ Bug_2583_RegressionC.inl \
+ Bug_2583_RegressionS.h \
+ Bug_2583_RegressionS.inl \
+ Bug_2583_RegressionS_T.h \
+ Bug_2616_RegressionC.h \
+ Bug_2616_RegressionC.inl \
+ Bug_2616_RegressionS.h \
+ Bug_2616_RegressionS.inl \
+ Bug_2616_RegressionS_T.h \
+ Bug_2619_RegressionC.h \
+ Bug_2619_RegressionC.inl \
+ Bug_2619_RegressionS.h \
+ Bug_2619_RegressionS.inl \
+ Bug_2619_RegressionS_T.h \
+ anonymousA.h \
+ anonymousC.h \
+ anonymousC.inl \
+ anonymousS.h \
+ anonymousS.inl \
+ anonymousS_T.h \
+ arrayC.h \
+ arrayC.inl \
+ arrayS.h \
+ arrayS.inl \
+ arrayS_T.h \
+ array_onlyA.h \
+ array_onlyC.h \
+ array_onlyC.inl \
+ array_onlyS.h \
+ array_onlyS.inl \
+ array_onlyS_T.h \
+ constantsA.h \
+ constantsC.h \
+ constantsC.inl \
+ constantsS.h \
+ constantsS.inl \
+ constantsS_T.h \
+ enum_in_structC.h \
+ enum_in_structC.inl \
+ enum_in_structS.h \
+ enum_in_structS.inl \
+ enum_in_structS_T.h \
+ fullC.h \
+ fullC.inl \
+ fullS.h \
+ fullS.inl \
+ fullS_T.h \
+ fwdC.h \
+ fwdC.inl \
+ fwdS.h \
+ fwdS.inl \
+ fwdS_T.h \
+ generic_objectA.h \
+ generic_objectC.h \
+ generic_objectC.inl \
+ generic_objectS.h \
+ generic_objectS.inl \
+ generic_objectS_T.h \
+ gperfC.h \
+ gperfC.inl \
+ gperfS.h \
+ gperfS.inl \
+ gperfS_T.h \
+ includedC.h \
+ includedC.inl \
+ includedS.h \
+ includedS.inl \
+ includedS_T.h \
+ includingC.h \
+ includingC.inl \
+ includingS.h \
+ includingS.inl \
+ includingS_T.h \
+ interfaceC.h \
+ interfaceC.inl \
+ interfaceS.h \
+ interfaceS.inl \
+ interfaceS_T.h \
+ keywordsA.h \
+ keywordsC.h \
+ keywordsC.inl \
+ keywordsS.h \
+ keywordsS.inl \
+ keywordsS_T.h \
+ nested_scopeC.h \
+ nested_scopeC.inl \
+ nested_scopeS.h \
+ nested_scopeS.inl \
+ nested_scopeS_T.h \
+ paramsC.h \
+ paramsC.inl \
+ paramsS.h \
+ paramsS.inl \
+ paramsS_T.h \
+ pragmaA.h \
+ pragmaC.h \
+ pragmaC.inl \
+ pragmaS.h \
+ pragmaS.inl \
+ pragmaS_T.h \
+ reopen_include1C.h \
+ reopen_include1C.inl \
+ reopen_include1S.h \
+ reopen_include1S.inl \
+ reopen_include1S_T.h \
+ reopen_include2C.h \
+ reopen_include2C.inl \
+ reopen_include2S.h \
+ reopen_include2S.inl \
+ reopen_include2S_T.h \
+ reopened_modulesC.h \
+ reopened_modulesC.inl \
+ reopened_modulesS.h \
+ reopened_modulesS.inl \
+ reopened_modulesS_T.h \
+ repo_id_modA.h \
+ repo_id_modC.h \
+ repo_id_modC.inl \
+ repo_id_modS.h \
+ repo_id_modS.inl \
+ repo_id_modS_T.h \
+ sequenceC.h \
+ sequenceC.inl \
+ sequenceS.h \
+ sequenceS.inl \
+ sequenceS_T.h \
+ typecodeA.h \
+ typecodeC.h \
+ typecodeC.inl \
+ typecodeS.h \
+ typecodeS.inl \
+ typecodeS_T.h \
+ typedefA.h \
+ typedefC.h \
+ typedefC.inl \
+ typedefS.h \
+ typedefS.inl \
+ typedefS_T.h \
+ typeprefixC.h \
+ typeprefixC.inl \
+ typeprefixS.h \
+ typeprefixS.inl \
+ typeprefixS_T.h \
+ unionC.h \
+ unionC.inl \
+ unionS.h \
+ unionS.inl \
+ unionS_T.h \
+ valuetypeA.h \
+ valuetypeC.h \
+ valuetypeC.inl \
+ valuetypeS.h \
+ valuetypeS.inl \
+ valuetypeS_T.h
+
+main_LDADD = \
+ $(TAO_BUILDDIR)/tao/libTAO_Messaging.la \
+ $(TAO_BUILDDIR)/tao/libTAO_PI.la \
+ $(TAO_BUILDDIR)/tao/libTAO_CodecFactory.la \
+ $(TAO_BUILDDIR)/tao/libTAO_Valuetype.la \
+ $(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
+ $(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
+ $(TAO_BUILDDIR)/tao/libTAO.la \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+endif BUILD_EXCEPTIONS
+endif BUILD_CORBA_MESSAGING
+
+## Clean up template repositories, etc.
+clean-local:
+ -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
+ -rm -f gcctemp.c gcctemp so_locations *.ics
+ -rm -rf cxx_repository ptrepository ti_files
+ -rm -rf templateregistry ir.out
+ -rm -rf ptrepository SunWS_cache Templates.DB