summaryrefslogtreecommitdiff
path: root/TAO/tests/NestedUpcall/Triangle_Test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/tests/NestedUpcall/Triangle_Test/Makefile.am')
-rw-r--r--TAO/tests/NestedUpcall/Triangle_Test/Makefile.am148
1 files changed, 0 insertions, 148 deletions
diff --git a/TAO/tests/NestedUpcall/Triangle_Test/Makefile.am b/TAO/tests/NestedUpcall/Triangle_Test/Makefile.am
deleted file mode 100644
index 34901f48553..00000000000
--- a/TAO/tests/NestedUpcall/Triangle_Test/Makefile.am
+++ /dev/null
@@ -1,148 +0,0 @@
-## Process this file with automake to create Makefile.in
-##
-## $Id$
-##
-## This file was generated by MPC. Any changes made directly to
-## this file will be lost the next time it is generated.
-##
-## MPC Command:
-## ../bin/mwc.pl -type automake -noreldefs TAO.mwc
-
-ACE_BUILDDIR = $(top_builddir)/..
-ACE_ROOT = $(top_srcdir)/..
-TAO_BUILDDIR = $(top_builddir)
-TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
-TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
-TAO_IDLFLAGS = -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
-TAO_ROOT = $(top_srcdir)
-
-noinst_PROGRAMS =
-
-## Makefile.TT_Nested_Upcall_Server_Idl.am
-
-BUILT_SOURCES = \
- Triangle_TestC.cpp \
- Triangle_TestC.h \
- Triangle_TestC.inl \
- Triangle_TestS.cpp \
- Triangle_TestS.h \
- Triangle_TestS.inl
-
-CLEANFILES = \
- Triangle_Test-stamp \
- Triangle_TestC.cpp \
- Triangle_TestC.h \
- Triangle_TestC.inl \
- Triangle_TestS.cpp \
- Triangle_TestS.h \
- Triangle_TestS.inl
-
-Triangle_TestC.cpp Triangle_TestC.h Triangle_TestC.inl Triangle_TestS.cpp Triangle_TestS.h Triangle_TestS.inl: Triangle_Test-stamp
-
-Triangle_Test-stamp: $(srcdir)/Triangle_Test.idl $(TAO_IDL_DEP)
- $(TAO_IDL) $(TAO_IDLFLAGS) -Sa -St $(srcdir)/Triangle_Test.idl
- @touch $@
-
-noinst_HEADERS = \
- Triangle_Test.idl
-
-## Makefile.TT_Nested_Upcall_Initiator.am
-
-if BUILD_EXCEPTIONS
-
-noinst_PROGRAMS += initiator
-
-initiator_CPPFLAGS = \
- -I$(ACE_ROOT) \
- -I$(ACE_BUILDDIR) \
- -I$(TAO_ROOT) \
- -I$(TAO_BUILDDIR)
-
-initiator_SOURCES = \
- Initiator_i.cpp \
- Triangle_TestC.cpp \
- Triangle_TestS.cpp \
- initiator.cpp \
- Initiator_i.h \
- initiator.h
-
-initiator_LDADD = \
- $(TAO_BUILDDIR)/tao/libTAO_Utils.la \
- $(TAO_BUILDDIR)/tao/libTAO_PI.la \
- $(TAO_BUILDDIR)/tao/libTAO_CodecFactory.la \
- $(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
- $(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
- $(TAO_BUILDDIR)/tao/libTAO.la \
- $(ACE_BUILDDIR)/ace/libACE.la
-
-endif BUILD_EXCEPTIONS
-
-## Makefile.TT_Nested_Upcall_Server_A.am
-
-if BUILD_EXCEPTIONS
-
-noinst_PROGRAMS += server_A
-
-server_A_CPPFLAGS = \
- -I$(ACE_ROOT) \
- -I$(ACE_BUILDDIR) \
- -I$(TAO_ROOT) \
- -I$(TAO_BUILDDIR)
-
-server_A_SOURCES = \
- Object_A_i.cpp \
- Triangle_TestC.cpp \
- Triangle_TestS.cpp \
- server_A.cpp \
- Object_A_i.h \
- server_A.h
-
-server_A_LDADD = \
- $(TAO_BUILDDIR)/tao/libTAO_Utils.la \
- $(TAO_BUILDDIR)/tao/libTAO_PI.la \
- $(TAO_BUILDDIR)/tao/libTAO_CodecFactory.la \
- $(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
- $(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
- $(TAO_BUILDDIR)/tao/libTAO.la \
- $(ACE_BUILDDIR)/ace/libACE.la
-
-endif BUILD_EXCEPTIONS
-
-## Makefile.TT_Nested_Upcall_Server_B.am
-
-if BUILD_EXCEPTIONS
-
-noinst_PROGRAMS += server_B
-
-server_B_CPPFLAGS = \
- -I$(ACE_ROOT) \
- -I$(ACE_BUILDDIR) \
- -I$(TAO_ROOT) \
- -I$(TAO_BUILDDIR)
-
-server_B_SOURCES = \
- Object_B_i.cpp \
- Triangle_TestC.cpp \
- Triangle_TestS.cpp \
- server_B.cpp \
- Object_B_i.h \
- server_B.h
-
-server_B_LDADD = \
- $(TAO_BUILDDIR)/tao/libTAO_Utils.la \
- $(TAO_BUILDDIR)/tao/libTAO_PI.la \
- $(TAO_BUILDDIR)/tao/libTAO_CodecFactory.la \
- $(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
- $(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
- $(TAO_BUILDDIR)/tao/libTAO.la \
- $(ACE_BUILDDIR)/ace/libACE.la
-
-endif BUILD_EXCEPTIONS
-
-## Clean up template repositories, etc.
-clean-local:
- -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
- -rm -f gcctemp.c gcctemp so_locations *.ics
- -rm -rf cxx_repository ptrepository ti_files
- -rm -rf templateregistry ir.out
- -rm -rf ptrepository SunWS_cache Templates.DB