summaryrefslogtreecommitdiff
path: root/TAO/tests/Smart_Proxies/Collocation/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'TAO/tests/Smart_Proxies/Collocation/Makefile.am')
-rw-r--r--TAO/tests/Smart_Proxies/Collocation/Makefile.am133
1 files changed, 133 insertions, 0 deletions
diff --git a/TAO/tests/Smart_Proxies/Collocation/Makefile.am b/TAO/tests/Smart_Proxies/Collocation/Makefile.am
new file mode 100644
index 00000000000..18920bf27cb
--- /dev/null
+++ b/TAO/tests/Smart_Proxies/Collocation/Makefile.am
@@ -0,0 +1,133 @@
+## Process this file with automake to create Makefile.in
+##
+## $Id$
+##
+## This file was generated by MPC. Any changes made directly to
+## this file will be lost the next time it is generated.
+##
+## MPC Command:
+## ../bin/mwc.pl -type automake -noreldefs TAO.mwc
+
+ACE_BUILDDIR = $(top_builddir)/..
+ACE_ROOT = $(top_srcdir)/..
+TAO_BUILDDIR = $(top_builddir)
+TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
+TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
+TAO_IDLFLAGS = -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
+TAO_ROOT = $(top_srcdir)
+
+noinst_LTLIBRARIES =
+noinst_HEADERS =
+
+## Makefile.SP_Collocation_Idl.am
+
+if BUILD_EXCEPTIONS
+
+BUILT_SOURCES = \
+ DiamondC.cpp \
+ DiamondC.h \
+ DiamondC.inl \
+ DiamondS.cpp \
+ DiamondS.h \
+ DiamondS.inl
+
+CLEANFILES = \
+ Diamond-stamp \
+ DiamondC.cpp \
+ DiamondC.h \
+ DiamondC.inl \
+ DiamondS.cpp \
+ DiamondS.h \
+ DiamondS.inl
+
+DiamondC.cpp DiamondC.h DiamondC.inl DiamondS.cpp DiamondS.h DiamondS.inl: Diamond-stamp
+
+Diamond-stamp: $(srcdir)/Diamond.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -Sa -St -Gsp -Wb,stub_export_macro=MY_Stub_Export -Wb,stub_export_include=stub_export.h -Wb,skel_export_macro=Diamond_Export -Wb,skel_export_include=diamond_export.h -Gd $(srcdir)/Diamond.idl
+ @touch $@
+
+noinst_HEADERS += \
+ Diamond.idl
+
+endif BUILD_EXCEPTIONS
+
+## Makefile.SP_Collocation_TestStubsLib.am
+
+if BUILD_EXCEPTIONS
+
+noinst_LTLIBRARIES += libColl_Test_Stubs.la
+
+libColl_Test_Stubs_la_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR) \
+ -DMY_STUB_BUILD_DLL
+
+libColl_Test_Stubs_la_SOURCES = \
+ DiamondC.cpp \
+ Smart_Proxy_Impl.cpp
+
+noinst_HEADERS += \
+ Smart_Proxy_Impl.h
+
+endif BUILD_EXCEPTIONS
+
+## Makefile.SP_Collocation_DiamondLib.am
+
+if BUILD_EXCEPTIONS
+
+noinst_LTLIBRARIES += libDiamond.la
+
+libDiamond_la_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR) \
+ -DDIAMOND_BUILD_DLL
+
+libDiamond_la_SOURCES = \
+ DiamondS.cpp \
+ Diamond_i.cpp
+
+noinst_HEADERS += \
+ Diamond_i.h
+
+endif BUILD_EXCEPTIONS
+
+## Makefile.SP_Collocation_Test.am
+
+if BUILD_EXCEPTIONS
+
+noinst_PROGRAMS = main
+
+main_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR)
+
+main_SOURCES = \
+ Coll_Tester.cpp \
+ main.cpp \
+ Coll_Tester.h
+
+main_LDADD = \
+ libColl_Test_Stubs.la \
+ libDiamond.la \
+ $(TAO_BUILDDIR)/tao/libTAO_Strategies.la \
+ $(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
+ $(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
+ $(TAO_BUILDDIR)/tao/libTAO_SmartProxies.la \
+ $(TAO_BUILDDIR)/tao/libTAO.la \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+endif BUILD_EXCEPTIONS
+
+## Clean up template repositories, etc.
+clean-local:
+ -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
+ -rm -f gcctemp.c gcctemp so_locations *.ics
+ -rm -rf cxx_repository ptrepository ti_files
+ -rm -rf templateregistry ir.out
+ -rm -rf ptrepository SunWS_cache Templates.DB