summaryrefslogtreecommitdiff
path: root/ace/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ace/Makefile.am')
-rw-r--r--ace/Makefile.am126
1 files changed, 84 insertions, 42 deletions
diff --git a/ace/Makefile.am b/ace/Makefile.am
index 1a418763551..6aa2ec7e49a 100644
--- a/ace/Makefile.am
+++ b/ace/Makefile.am
@@ -2,6 +2,11 @@
##
## $Id$
##
+## This file was generated by MPC. Any changes made directly to
+## this file will be lost the next time it is generated.
+##
+## MPC Command:
+## ./bin/mwc.pl -type automake -noreldefs ACE.mwc
includedir = @includedir@/ace
pkgconfigdir = @libdir@/pkgconfig
@@ -15,10 +20,16 @@ SUBDIRS = \
QoS \
SSL
+CLEANFILES =
+lib_LTLIBRARIES =
+nobase_include_HEADERS =
+pkgconfig_DATA =
## Makefile.ACE.am
-lib_LTLIBRARIES = libACE.la
+if !BUILD_ACE_FOR_TAO
+
+lib_LTLIBRARIES += libACE.la
libACE_la_CPPFLAGS = \
-I$(ACE_ROOT) \
@@ -42,6 +53,7 @@ libACE_la_SOURCES = \
Addr.cpp \
Arg_Shifter.cpp \
Argv_Type_Converter.cpp \
+ Assert.cpp \
Asynch_IO.cpp \
Asynch_IO_Impl.cpp \
Asynch_Pseudo_Task.cpp \
@@ -53,8 +65,8 @@ libACE_la_SOURCES = \
Basic_Stats.cpp \
Basic_Types.cpp \
CDR_Base.cpp \
- CDR_Stream.cpp \
CDR_Size.cpp \
+ CDR_Stream.cpp \
Capabilities.cpp \
Cleanup.cpp \
Codecs.cpp \
@@ -66,7 +78,6 @@ libACE_la_SOURCES = \
Configuration.cpp \
Configuration_Import_Export.cpp \
Connection_Recycling_Strategy.cpp \
- Container_Instantiations.cpp \
Containers.cpp \
Copy_Disabled.cpp \
Countdown_Time.cpp \
@@ -83,6 +94,8 @@ libACE_la_SOURCES = \
Dump.cpp \
Dynamic.cpp \
Dynamic_Service_Base.cpp \
+ Encoding_Converter.cpp \
+ Encoding_Converter_Factory.cpp \
Event.cpp \
Event_Handler.cpp \
FIFO.cpp \
@@ -103,7 +116,6 @@ libACE_la_SOURCES = \
Get_Opt.cpp \
Handle_Ops.cpp \
Handle_Set.cpp \
- Hash_Map_Manager.cpp \
Hashable.cpp \
High_Res_Timer.cpp \
ICMP_Socket.cpp \
@@ -141,13 +153,11 @@ libACE_la_SOURCES = \
MMAP_Memory_Pool.cpp \
Malloc.cpp \
Malloc_Allocator.cpp \
- Malloc_Instantiations.cpp \
Manual_Event.cpp \
Mem_Map.cpp \
Message_Block.cpp \
Message_Queue.cpp \
Method_Request.cpp \
- Metrics_Cache.cpp \
Msg_WFMO_Reactor.cpp \
Multihomed_INET_Addr.cpp \
Mutex.cpp \
@@ -198,7 +208,6 @@ libACE_la_SOURCES = \
Obchunk.cpp \
Object_Manager.cpp \
Object_Manager_Base.cpp \
- Obstack.cpp \
PI_Malloc.cpp \
POSIX_Asynch_IO.cpp \
POSIX_CB_Proactor.cpp \
@@ -257,14 +266,12 @@ libACE_la_SOURCES = \
Sample_History.cpp \
Sbrk_Memory_Pool.cpp \
Sched_Params.cpp \
- Select_Reactor.cpp \
Select_Reactor_Base.cpp \
Semaphore.cpp \
Service_Config.cpp \
Service_Manager.cpp \
Service_Object.cpp \
Service_Repository.cpp \
- Service_Templates.cpp \
Service_Types.cpp \
Shared_Memory.cpp \
Shared_Memory_MM.cpp \
@@ -275,8 +282,7 @@ libACE_la_SOURCES = \
Sock_Connect.cpp \
Stats.cpp \
String_Base_Const.cpp \
- Svc_Conf_Lexer_Guard.cpp \
- Svc_Conf_l.cpp \
+ Svc_Conf_Lexer.cpp \
Svc_Conf_y.cpp \
Synch_Options.cpp \
System_Time.cpp \
@@ -314,6 +320,9 @@ libACE_la_SOURCES = \
UPIPE_Acceptor.cpp \
UPIPE_Connector.cpp \
UPIPE_Stream.cpp \
+ UTF16_Encoding_Converter.cpp \
+ UTF32_Encoding_Converter.cpp \
+ UTF8_Encoding_Converter.cpp \
UUID.cpp \
WFMO_Reactor.cpp \
WIN32_Asynch_IO.cpp \
@@ -325,7 +334,7 @@ libACE_la_SOURCES = \
libACE_la_LDFLAGS = \
-version-number @ACE_MAJOR@:@ACE_MINOR@:@ACE_BETA@
-nobase_include_HEADERS = \
+nobase_include_HEADERS += \
ACE.h \
ACE.inl \
ACE_export.h \
@@ -364,6 +373,7 @@ nobase_include_HEADERS = \
Array_Map.cpp \
Array_Map.h \
Array_Map.inl \
+ Assert.h \
Asynch_Acceptor.cpp \
Asynch_Acceptor.h \
Asynch_Connector.cpp \
@@ -404,10 +414,10 @@ nobase_include_HEADERS = \
Bound_Ptr.inl \
CDR_Base.h \
CDR_Base.inl \
- CDR_Stream.h \
- CDR_Stream.inl \
CDR_Size.h \
CDR_Size.inl \
+ CDR_Stream.h \
+ CDR_Stream.inl \
CORBA_macros.h \
Cache_Map_Manager_T.cpp \
Cache_Map_Manager_T.h \
@@ -475,6 +485,8 @@ nobase_include_HEADERS = \
Dynamic_Service.h \
Dynamic_Service.inl \
Dynamic_Service_Base.h \
+ Encoding_Converter.h \
+ Encoding_Converter_Factory.h \
Env_Value_T.cpp \
Env_Value_T.h \
Env_Value_T.inl \
@@ -552,7 +564,6 @@ nobase_include_HEADERS = \
High_Res_Timer.h \
High_Res_Timer.inl \
ICMP_Socket.h \
- ICMP_Socket.inl \
INET_Addr.h \
INET_Addr.inl \
IOStream.h \
@@ -688,7 +699,6 @@ nobase_include_HEADERS = \
OS_Log_Msg_Attributes.h \
OS_Log_Msg_Attributes.inl \
OS_Memory.h \
- OS_Memory.inl \
OS_NS_Thread.h \
OS_NS_Thread.inl \
OS_NS_arpa_inet.h \
@@ -745,7 +755,6 @@ nobase_include_HEADERS = \
OS_NS_sys_uio.h \
OS_NS_sys_uio.inl \
OS_NS_sys_utsname.h \
- OS_NS_sys_utsname.inl \
OS_NS_sys_wait.h \
OS_NS_sys_wait.inl \
OS_NS_time.h \
@@ -756,7 +765,6 @@ nobase_include_HEADERS = \
OS_NS_wchar.inl \
OS_QoS.h \
OS_String.h \
- OS_String.inl \
OS_TLI.h \
OS_TLI.inl \
OS_Thread_Adapter.h \
@@ -826,9 +834,9 @@ nobase_include_HEADERS = \
Recyclable.inl \
Refcountable.h \
Refcountable.inl \
+ Refcounted_Auto_Ptr.cpp \
Refcounted_Auto_Ptr.h \
Refcounted_Auto_Ptr.inl \
- Refcounted_Auto_Ptr.cpp \
Registry.h \
Registry_Name_Space.h \
Remote_Name_Space.h \
@@ -900,7 +908,6 @@ nobase_include_HEADERS = \
Service_Config.h \
Service_Config.inl \
Service_Manager.h \
- Service_Manager.inl \
Service_Object.h \
Service_Object.inl \
Service_Repository.h \
@@ -939,7 +946,7 @@ nobase_include_HEADERS = \
String_Base.inl \
String_Base_Const.h \
Svc_Conf.h \
- Svc_Conf_Lexer_Guard.h \
+ Svc_Conf_Lexer.h \
Svc_Conf_Tokens.h \
Svc_Handler.cpp \
Svc_Handler.h \
@@ -947,7 +954,6 @@ nobase_include_HEADERS = \
Swap.inl \
Synch.h \
Synch_Options.h \
- Synch_Options.inl \
Synch_T.cpp \
Synch_T.h \
Synch_Traits.h \
@@ -962,7 +968,6 @@ nobase_include_HEADERS = \
TP_Reactor.h \
TP_Reactor.inl \
TSS_Adapter.h \
- TSS_Adapter.inl \
TSS_T.cpp \
TSS_T.h \
TSS_T.inl \
@@ -975,7 +980,6 @@ nobase_include_HEADERS = \
Task_T.cpp \
Task_T.h \
Task_T.inl \
- Template_Instantiations.cpp \
Test_and_Set.cpp \
Test_and_Set.h \
Thread.h \
@@ -1029,6 +1033,7 @@ nobase_include_HEADERS = \
Token_Request_Reply.h \
Token_Request_Reply.inl \
Trace.h \
+ Truncate.h \
Typed_SV_Message.cpp \
Typed_SV_Message.h \
Typed_SV_Message.inl \
@@ -1044,6 +1049,10 @@ nobase_include_HEADERS = \
UPIPE_Connector.inl \
UPIPE_Stream.h \
UPIPE_Stream.inl \
+ UTF16_Encoding_Converter.h \
+ UTF16_Encoding_Converter.inl \
+ UTF32_Encoding_Converter.h \
+ UTF8_Encoding_Converter.h \
UUID.h \
UUID.inl \
Unbounded_Queue.cpp \
@@ -1057,6 +1066,7 @@ nobase_include_HEADERS = \
Vector_T.h \
Vector_T.inl \
Version.h \
+ Versioned_Namespace.h \
WFMO_Reactor.h \
WFMO_Reactor.inl \
WIN32_Asynch_IO.h \
@@ -1070,11 +1080,11 @@ nobase_include_HEADERS = \
config-all.h \
config-borland-common.h \
config-lite.h \
+ config-macros.h \
config-minimal.h \
config-win32-borland.h \
config-win32-common.h \
config-win32-ghs.h \
- config-win32-msvc-6.h \
config-win32-msvc-7.h \
config-win32-msvc.h \
config-win32-visualage.h \
@@ -1159,6 +1169,7 @@ nobase_include_HEADERS = \
os_include/sys/os_socket.h \
os_include/sys/os_stat.h \
os_include/sys/os_statvfs.h \
+ os_include/sys/os_sysctl.h \
os_include/sys/os_time.h \
os_include/sys/os_timeb.h \
os_include/sys/os_times.h \
@@ -1172,11 +1183,17 @@ nobase_include_HEADERS = \
streams.h \
svc_export.h
-pkgconfig_DATA = ACE.pc
+pkgconfig_DATA += \
+ ACE.pc
+
+CLEANFILES += \
+ ACE.pc
ACE.pc: ${top_builddir}/config.status ${srcdir}/ACE.pc.in
${top_builddir}/config.status --file $@:${srcdir}/ACE.pc.in
+endif !BUILD_ACE_FOR_TAO
+
EXTRA_DIST = \
ACE.pc.in \
ace.rc
@@ -1193,22 +1210,28 @@ lib_LTLIBRARIES += libACE_FlReactor.la
libACE_FlReactor_la_CPPFLAGS = \
-I$(ACE_ROOT) \
-I$(ACE_BUILDDIR) \
+ $(ACE_FLTK_CPPFLAGS) \
-DACE_FLREACTOR_BUILD_DLL
libACE_FlReactor_la_SOURCES = \
FlReactor.cpp
libACE_FlReactor_la_LDFLAGS = \
- -version-number @ACE_MAJOR@:@ACE_MINOR@:@ACE_BETA@
+ -version-number @ACE_MAJOR@:@ACE_MINOR@:@ACE_BETA@ $(ACE_FLTK_LDFLAGS)
libACE_FlReactor_la_LIBADD = \
- libACE.la
+ libACE.la \
+ $(ACE_FLTK_LIBS)
nobase_include_HEADERS += \
ACE_FlReactor_export.h \
FlReactor.h
-pkgconfig_DATA += ACE_FlReactor.pc
+pkgconfig_DATA += \
+ ACE_FlReactor.pc
+
+CLEANFILES += \
+ ACE_FlReactor.pc
ACE_FlReactor.pc: ${top_builddir}/config.status ${srcdir}/ACE_FlReactor.pc.in
${top_builddir}/config.status --file $@:${srcdir}/ACE_FlReactor.pc.in
@@ -1228,19 +1251,18 @@ if BUILD_QT
BUILT_SOURCES = \
QtReactor_moc.cpp
-CLEANFILES = \
+CLEANFILES += \
QtReactor_moc.cpp
QtReactor_moc.cpp: $(srcdir)/QtReactor.h
- $(QTDIR)/bin/moc $(srcdir)/QtReactor.h -o QtReactor_moc.cpp
+ $(QTDIR)/bin/moc -o QtReactor_moc.cpp $(srcdir)/QtReactor.h
lib_LTLIBRARIES += libACE_QtReactor.la
libACE_QtReactor_la_CPPFLAGS = \
-I$(ACE_ROOT) \
-I$(ACE_BUILDDIR) \
- -I$(QTDIR)/include \
- -DQT_THREAD_SUPPORT \
+ $(ACE_QT_CPPFLAGS) \
-DACE_QTREACTOR_BUILD_DLL
libACE_QtReactor_la_SOURCES = \
@@ -1248,17 +1270,21 @@ libACE_QtReactor_la_SOURCES = \
QtReactor_moc.cpp
libACE_QtReactor_la_LDFLAGS = \
- -version-number @ACE_MAJOR@:@ACE_MINOR@:@ACE_BETA@
+ -version-number @ACE_MAJOR@:@ACE_MINOR@:@ACE_BETA@ $(ACE_QT_LDFLAGS)
libACE_QtReactor_la_LIBADD = \
libACE.la \
- -lqt-mt
+ $(ACE_QT_LIBS)
nobase_include_HEADERS += \
ACE_QtReactor_export.h \
QtReactor.h
-pkgconfig_DATA += ACE_QtReactor.pc
+pkgconfig_DATA += \
+ ACE_QtReactor.pc
+
+CLEANFILES += \
+ ACE_QtReactor.pc
ACE_QtReactor.pc: ${top_builddir}/config.status ${srcdir}/ACE_QtReactor.pc.in
${top_builddir}/config.status --file $@:${srcdir}/ACE_QtReactor.pc.in
@@ -1278,22 +1304,30 @@ lib_LTLIBRARIES += libACE_TkReactor.la
libACE_TkReactor_la_CPPFLAGS = \
-I$(ACE_ROOT) \
-I$(ACE_BUILDDIR) \
+ $(ACE_TK_CPPFLAGS) \
+ $(ACE_TCL_CPPFLAGS) \
-DACE_TKREACTOR_BUILD_DLL
libACE_TkReactor_la_SOURCES = \
TkReactor.cpp
libACE_TkReactor_la_LDFLAGS = \
- -version-number @ACE_MAJOR@:@ACE_MINOR@:@ACE_BETA@
+ -version-number @ACE_MAJOR@:@ACE_MINOR@:@ACE_BETA@ $(ACE_TK_LDFLAGS) $(ACE_TCL_LDFLAGS)
libACE_TkReactor_la_LIBADD = \
- libACE.la
+ libACE.la \
+ $(ACE_TK_LIBS) \
+ $(ACE_TCL_LIBS)
nobase_include_HEADERS += \
ACE_TkReactor_export.h \
TkReactor.h
-pkgconfig_DATA += ACE_TkReactor.pc
+pkgconfig_DATA += \
+ ACE_TkReactor.pc
+
+CLEANFILES += \
+ ACE_TkReactor.pc
ACE_TkReactor.pc: ${top_builddir}/config.status ${srcdir}/ACE_TkReactor.pc.in
${top_builddir}/config.status --file $@:${srcdir}/ACE_TkReactor.pc.in
@@ -1314,22 +1348,30 @@ lib_LTLIBRARIES += libACE_XtReactor.la
libACE_XtReactor_la_CPPFLAGS = \
-I$(ACE_ROOT) \
-I$(ACE_BUILDDIR) \
+ $(ACE_X11_CPPFLAGS) \
+ $(ACE_XT_CPPFLAGS) \
-DACE_XTREACTOR_BUILD_DLL
libACE_XtReactor_la_SOURCES = \
XtReactor.cpp
libACE_XtReactor_la_LDFLAGS = \
- -version-number @ACE_MAJOR@:@ACE_MINOR@:@ACE_BETA@
+ -version-number @ACE_MAJOR@:@ACE_MINOR@:@ACE_BETA@ $(ACE_X11_LDFLAGS) $(ACE_XT_LDFLAGS)
libACE_XtReactor_la_LIBADD = \
- libACE.la
+ libACE.la \
+ $(ACE_XT_LIBS) \
+ $(ACE_X11_LIBS)
nobase_include_HEADERS += \
ACE_XtReactor_export.h \
XtReactor.h
-pkgconfig_DATA += ACE_XtReactor.pc
+pkgconfig_DATA += \
+ ACE_XtReactor.pc
+
+CLEANFILES += \
+ ACE_XtReactor.pc
ACE_XtReactor.pc: ${top_builddir}/config.status ${srcdir}/ACE_XtReactor.pc.in
${top_builddir}/config.status --file $@:${srcdir}/ACE_XtReactor.pc.in