summaryrefslogtreecommitdiff
path: root/apps/gperf/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'apps/gperf/src/Makefile.am')
-rw-r--r--apps/gperf/src/Makefile.am77
1 files changed, 48 insertions, 29 deletions
diff --git a/apps/gperf/src/Makefile.am b/apps/gperf/src/Makefile.am
index f989809530d..7e0c6584393 100644
--- a/apps/gperf/src/Makefile.am
+++ b/apps/gperf/src/Makefile.am
@@ -1,36 +1,55 @@
-##---------------------------------------------------------------------------
-## $Id$
+## Process this file with automake to create Makefile.in
##
-## Makefile for GPERF release
-##---------------------------------------------------------------------------
-
+## $Id$
##
-## Process this file with automake to create Makefile.in
+## This file was generated by MPC. Any changes made directly to
+## this file will be lost the next time it is generated.
##
+## MPC Command:
+## /acebuilds/ACE_wrappers-repository/bin/mwc.pl -include /acebuilds/MPC/config -include /acebuilds/MPC/templates -feature_file /acebuilds/ACE_wrappers-repository/local.features -noreldefs -type automake -exclude build,Kokyu
+
+ACE_BUILDDIR = $(top_builddir)
+ACE_ROOT = $(top_srcdir)
-AM_CPPFLAGS = -I$(top_builddir) -I$(top_srcdir)
+bin_PROGRAMS =
+## Makefile.gperf.am
-bin_PROGRAMS = gperf
+if !BUILD_USES_WCHAR
+bin_PROGRAMS += gperf
+
+gperf_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR)
gperf_SOURCES = \
- gperf.cpp \
- Bool_Array.cpp \
- Gen_Perf.cpp \
- Hash_Table.cpp \
- Iterator.cpp \
- Key_List.cpp \
- List_Node.cpp \
- Options.cpp \
- Vectors.cpp \
- Version.cpp
-gperf_LDADD = $(top_builddir)/ace/libACE.la
-
-noinst_HEADERS = \
- Bool_Array.h \
- Gen_Perf.h \
- Hash_Table.h \
- Iterator.h \
- Key_List.h \
- List_Node.h \
- Options.h \
- Vectors.h
+ Bool_Array.cpp \
+ Gen_Perf.cpp \
+ Hash_Table.cpp \
+ Iterator.cpp \
+ Key_List.cpp \
+ List_Node.cpp \
+ Options.cpp \
+ Vectors.cpp \
+ Version.cpp \
+ gperf.cpp \
+ Bool_Array.h \
+ Gen_Perf.h \
+ Hash_Table.h \
+ Iterator.h \
+ Key_List.h \
+ List_Node.h \
+ Options.h \
+ Vectors.h
+
+gperf_LDADD = \
+ $(top_builddir)/ace/libACE.la
+
+endif !BUILD_USES_WCHAR
+
+## Clean up template repositories, etc.
+clean-local:
+ -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
+ -rm -f gcctemp.c gcctemp so_locations *.ics
+ -rm -rf cxx_repository ptrepository ti_files
+ -rm -rf templateregistry ir.out
+ -rm -rf ptrepository SunWS_cache Templates.DB