summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 13 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index e40853a79da..561c1d192c6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -135,6 +135,9 @@ AC_LANG([C++])
dnl If we are cross compiling disable certain things in the Makefiles.
AM_CONDITIONAL([ACE_CROSS_COMPILED], [test X$cross_compiling = Xyes])
+dnl If we are cross compiling disable certain things in the Makefiles.
+AM_CONDITIONAL([BUILD_CROSS_COMPILE], [test X$cross_compiling = Xyes])
+
dnl Look for the best awk-style program available.
AC_PROG_AWK
@@ -368,9 +371,6 @@ AC_DISABLE_STATIC
dnl Enable Libtool module support
AC_LIBTOOL_DLOPEN
-dnl Enable support for "clean" DLLs.
-AC_LIBTOOL_WIN32_DLL
-
dnl
dnl ###### Relies on the as of yet unreleased Libtool 1.6 distribuion ###
dnl
@@ -764,7 +764,7 @@ dnl Check if XTI headers define TCP macros that conflict with netinet/tcp.h's
# endif /* ACE_HAS_XTI */
# if !defined (ACE_LACKS_NETINET_TCP_H)
# include /**/ <netinet/tcp.h>
-# endif /* !ACE_LACKS_NETIINET_TCP_H */
+# endif /* !ACE_LACKS_NETINET_TCP_H */
]],[[
int a = 0;
]])],[
@@ -3288,6 +3288,8 @@ ACE_CHECK_LACKS_FUNCS(strtoul)
ACE_FUNC_STRTOULL
+ACE_CHECK_LACKS_FUNCS(floor ceil floorl ceill)
+
# swab() comes in a number of forms:
# swab (const void*, void*, size_t) is POSIX, XPG4, SUS, SUSv2 standard.
# swab (const char*, char*, size_t) is SVID third edition.
@@ -4554,11 +4556,11 @@ if test "$ace_user_enable_reentrant_funcs" = yes; then
#endif
]],
[[
- const char * name;
+ const char * name = 0;
struct passwd * pwent;
- char * buffer;
+ char * buffer = 0;
int buflen;
- struct passwd * result;
+ struct passwd * result = 0;
int status = getpwnam_r (name, pwent, buffer, buflen, &result);
]])],
@@ -4567,10 +4569,11 @@ if test "$ace_user_enable_reentrant_funcs" = yes; then
AC_DEFINE([ACE_HAS_POSIX_GETPWNAM_R])
fi
],
- [
+ [
dnl Nothing to do!
- ])
- ],
+ echo
+ ]),
+ ],,
[AC_DEFINE([ACE_LACKS_PWD_REENTRANT_FUNCTIONS])])
AC_CHECK_FUNC([ctime_r],,)