summaryrefslogtreecommitdiff
path: root/examples/Reactor/Misc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'examples/Reactor/Misc/Makefile.am')
-rw-r--r--examples/Reactor/Misc/Makefile.am124
1 files changed, 124 insertions, 0 deletions
diff --git a/examples/Reactor/Misc/Makefile.am b/examples/Reactor/Misc/Makefile.am
new file mode 100644
index 00000000000..7e86ad5e404
--- /dev/null
+++ b/examples/Reactor/Misc/Makefile.am
@@ -0,0 +1,124 @@
+## Process this file with automake to create Makefile.in
+##
+## $Id$
+##
+## This file was generated by MPC. Any changes made directly to
+## this file will be lost the next time it is generated.
+##
+## MPC Command:
+## /acebuilds/ACE_wrappers-repository/bin/mwc.pl -include /acebuilds/MPC/config -include /acebuilds/MPC/templates -feature_file /acebuilds/ACE_wrappers-repository/local.features -noreldefs -type automake -exclude build,Kokyu
+
+ACE_BUILDDIR = $(top_builddir)
+ACE_ROOT = $(top_srcdir)
+
+## Makefile.Reactor_Misc_Demuxing.am
+noinst_PROGRAMS = demuxing
+
+demuxing_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR)
+
+demuxing_SOURCES = \
+ test_demuxing.cpp
+
+demuxing_LDADD = \
+ $(top_builddir)/ace/libACE.la
+
+## Makefile.Reactor_Misc_Early_Timeouts.am
+noinst_PROGRAMS += early_timeouts
+
+early_timeouts_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR)
+
+early_timeouts_SOURCES = \
+ test_early_timeouts.cpp
+
+early_timeouts_LDADD = \
+ $(top_builddir)/ace/libACE.la
+
+## Makefile.Reactor_Misc_Notification.am
+noinst_PROGRAMS += notification
+
+notification_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR)
+
+notification_SOURCES = \
+ notification.cpp
+
+notification_LDADD = \
+ $(top_builddir)/ace/libACE.la
+
+## Makefile.Reactor_Misc_Pingpong.am
+noinst_PROGRAMS += pingpong
+
+pingpong_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR)
+
+pingpong_SOURCES = \
+ pingpong.cpp
+
+pingpong_LDADD = \
+ $(top_builddir)/ace/libACE.la
+
+## Makefile.Reactor_Misc_Reactors.am
+noinst_PROGRAMS += reactors
+
+reactors_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR)
+
+reactors_SOURCES = \
+ test_reactors.cpp
+
+reactors_LDADD = \
+ $(top_builddir)/ace/libACE.la
+
+## Makefile.Reactor_Misc_Signals_1.am
+noinst_PROGRAMS += signals_1
+
+signals_1_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR)
+
+signals_1_SOURCES = \
+ test_signals_1.cpp
+
+signals_1_LDADD = \
+ $(top_builddir)/ace/libACE.la
+
+## Makefile.Reactor_Misc_Signals_2.am
+noinst_PROGRAMS += signals_2
+
+signals_2_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR)
+
+signals_2_SOURCES = \
+ test_signals_2.cpp
+
+signals_2_LDADD = \
+ $(top_builddir)/ace/libACE.la
+
+## Makefile.Reactor_Misc_Timer_Queue.am
+noinst_PROGRAMS += timer_queue
+
+timer_queue_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR)
+
+timer_queue_SOURCES = \
+ test_timer_queue.cpp
+
+timer_queue_LDADD = \
+ $(top_builddir)/ace/libACE.la
+
+## Clean up template repositories, etc.
+clean-local:
+ -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
+ -rm -f gcctemp.c gcctemp so_locations *.ics
+ -rm -rf cxx_repository ptrepository ti_files
+ -rm -rf templateregistry ir.out
+ -rm -rf ptrepository SunWS_cache Templates.DB