summaryrefslogtreecommitdiff
path: root/tests/FL_Cube/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/FL_Cube/Makefile.am')
-rw-r--r--tests/FL_Cube/Makefile.am169
1 files changed, 0 insertions, 169 deletions
diff --git a/tests/FL_Cube/Makefile.am b/tests/FL_Cube/Makefile.am
deleted file mode 100644
index 8606fc77cde..00000000000
--- a/tests/FL_Cube/Makefile.am
+++ /dev/null
@@ -1,169 +0,0 @@
-## Process this file with automake to create Makefile.in
-##
-## $Id$
-##
-## This file was generated by MPC. Any changes made directly to
-## this file will be lost the next time it is generated.
-##
-## MPC Command:
-## ../bin/mwc.pl -type automake -noreldefs TAO.mwc
-
-ACE_BUILDDIR = $(top_builddir)/..
-ACE_ROOT = $(top_srcdir)/..
-TAO_BUILDDIR = $(top_builddir)
-TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
-TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
-TAO_IDLFLAGS = -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/ace_gperf
-TAO_ROOT = $(top_srcdir)
-
-noinst_PROGRAMS =
-CLEANFILES =
-BUILT_SOURCES =
-
-## Makefile.FL_Cube_Client.am
-
-if BUILD_ACE_FLREACTOR
-if BUILD_EXCEPTIONS
-if BUILD_FL
-if BUILD_GL
-if BUILD_TAO_FLRESOURCE
-if BUILD_X11
-
-BUILT_SOURCES += \
- testC.cpp \
- testC.h \
- testC.inl \
- testS.cpp \
- testS.h \
- testS.inl
-
-CLEANFILES += \
- test-stamp \
- testC.cpp \
- testC.h \
- testC.inl \
- testS.cpp \
- testS.h \
- testS.inl
-
-testC.cpp testC.h testC.inl testS.cpp testS.h testS.inl: test-stamp
-
-test-stamp: $(srcdir)/test.idl $(TAO_IDL_DEP)
- $(TAO_IDL) $(TAO_IDLFLAGS) -Sa -St $(srcdir)/test.idl
- @touch $@
-
-noinst_PROGRAMS += client
-
-client_CPPFLAGS = \
- -I$(ACE_ROOT) \
- -I$(ACE_BUILDDIR) \
- -I$(TAO_ROOT) \
- -I$(TAO_BUILDDIR) \
- $(ACE_FLTK_CPPFLAGS)
-
-client_SOURCES = \
- client.cpp \
- testC.cpp \
- testS.cpp \
- testC.h \
- testC.inl \
- testS.h \
- testS.inl
-
-client_LDFLAGS = \
- $(ACE_FLTK_LDFLAGS)
-
-client_LDADD = \
- $(TAO_BUILDDIR)/tao/libTAO_FlResource.la \
- $(ACE_BUILDDIR)/ace/libACE_FlReactor.la \
- $(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
- $(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
- $(TAO_BUILDDIR)/tao/libTAO.la \
- $(ACE_BUILDDIR)/ace/libACE.la \
- $(ACE_FLTK_LIBS)
-
-endif BUILD_X11
-endif BUILD_TAO_FLRESOURCE
-endif BUILD_GL
-endif BUILD_FL
-endif BUILD_EXCEPTIONS
-endif BUILD_ACE_FLREACTOR
-
-## Makefile.FL_Cube_Server.am
-
-if BUILD_ACE_FLREACTOR
-if BUILD_EXCEPTIONS
-if BUILD_FL
-if BUILD_GL
-if BUILD_TAO_FLRESOURCE
-if BUILD_X11
-
-BUILT_SOURCES += \
- testC.cpp \
- testC.h \
- testC.inl \
- testS.cpp \
- testS.h \
- testS.inl
-
-CLEANFILES += \
- test-stamp \
- testC.cpp \
- testC.h \
- testC.inl \
- testS.cpp \
- testS.h \
- testS.inl
-
-testC.cpp testC.h testC.inl testS.cpp testS.h testS.inl: test-stamp
-
-test-stamp: $(srcdir)/test.idl $(TAO_IDL_DEP)
- $(TAO_IDL) $(TAO_IDLFLAGS) -Sa -St $(srcdir)/test.idl
- @touch $@
-
-noinst_PROGRAMS += server
-
-server_CPPFLAGS = \
- -I$(ACE_ROOT) \
- -I$(ACE_BUILDDIR) \
- -I$(TAO_ROOT) \
- -I$(TAO_BUILDDIR) \
- $(ACE_FLTK_CPPFLAGS)
-
-server_SOURCES = \
- server.cpp \
- testC.cpp \
- testS.cpp \
- test_i.cpp \
- testC.h \
- testC.inl \
- testS.h \
- testS.inl \
- test_i.h
-
-server_LDFLAGS = \
- $(ACE_FLTK_LDFLAGS)
-
-server_LDADD = \
- $(TAO_BUILDDIR)/tao/libTAO_FlResource.la \
- $(ACE_BUILDDIR)/ace/libACE_FlReactor.la \
- $(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
- $(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
- $(TAO_BUILDDIR)/tao/libTAO.la \
- $(ACE_BUILDDIR)/ace/libACE.la \
- $(ACE_FLTK_LIBS)
-
-endif BUILD_X11
-endif BUILD_TAO_FLRESOURCE
-endif BUILD_GL
-endif BUILD_FL
-endif BUILD_EXCEPTIONS
-endif BUILD_ACE_FLREACTOR
-
-## Clean up template repositories, etc.
-clean-local:
- -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
- -rm -f gcctemp.c gcctemp so_locations *.ics
- -rm -rf cxx_repository ptrepository ti_files
- -rm -rf templateregistry ir.out
- -rm -rf ptrepository SunWS_cache Templates.DB