summaryrefslogtreecommitdiff
path: root/tests/ORT/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/ORT/Makefile.am')
-rw-r--r--tests/ORT/Makefile.am149
1 files changed, 0 insertions, 149 deletions
diff --git a/tests/ORT/Makefile.am b/tests/ORT/Makefile.am
deleted file mode 100644
index c801a22a12e..00000000000
--- a/tests/ORT/Makefile.am
+++ /dev/null
@@ -1,149 +0,0 @@
-## Process this file with automake to create Makefile.in
-##
-## $Id$
-##
-## This file was generated by MPC. Any changes made directly to
-## this file will be lost the next time it is generated.
-##
-## MPC Command:
-## ../bin/mwc.pl -type automake -noreldefs TAO.mwc
-
-ACE_BUILDDIR = $(top_builddir)/..
-ACE_ROOT = $(top_srcdir)/..
-TAO_BUILDDIR = $(top_builddir)
-TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
-TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
-TAO_IDLFLAGS = -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/ace_gperf
-TAO_ROOT = $(top_srcdir)
-
-noinst_PROGRAMS =
-
-## Makefile.Test_ORT_IDL.am
-
-BUILT_SOURCES = \
- ORT_testC.cpp \
- ORT_testC.h \
- ORT_testC.inl \
- ORT_testS.cpp \
- ORT_testS.h \
- ORT_testS.inl
-
-CLEANFILES = \
- ORT_test-stamp \
- ORT_testC.cpp \
- ORT_testC.h \
- ORT_testC.inl \
- ORT_testS.cpp \
- ORT_testS.h \
- ORT_testS.inl
-
-ORT_testC.cpp ORT_testC.h ORT_testC.inl ORT_testS.cpp ORT_testS.h ORT_testS.inl: ORT_test-stamp
-
-ORT_test-stamp: $(srcdir)/ORT_test.idl $(TAO_IDL_DEP)
- $(TAO_IDL) $(TAO_IDLFLAGS) -Sa -St $(srcdir)/ORT_test.idl
- @touch $@
-
-BUILT_SOURCES += \
- ObjectReferenceFactoryC.cpp \
- ObjectReferenceFactoryC.h \
- ObjectReferenceFactoryC.inl \
- ObjectReferenceFactoryS.h
-
-CLEANFILES += \
- ObjectReferenceFactory-stamp \
- ObjectReferenceFactoryC.cpp \
- ObjectReferenceFactoryC.h \
- ObjectReferenceFactoryC.inl \
- ObjectReferenceFactoryS.h
-
-ObjectReferenceFactoryC.cpp ObjectReferenceFactoryC.h ObjectReferenceFactoryC.inl ObjectReferenceFactoryS.h: ObjectReferenceFactory-stamp
-
-ObjectReferenceFactory-stamp: $(srcdir)/ObjectReferenceFactory.idl $(TAO_IDL_DEP)
- $(TAO_IDL) $(TAO_IDLFLAGS) -Sa -St -SS $(srcdir)/ObjectReferenceFactory.idl
- @touch $@
-
-noinst_HEADERS = \
- ORT_test.idl \
- ObjectReferenceFactory.idl
-
-## Makefile.Test_ORT_Server.am
-
-if BUILD_EXCEPTIONS
-if BUILD_INTERCEPTORS
-
-noinst_PROGRAMS += server
-
-server_CPPFLAGS = \
- -I$(ACE_ROOT) \
- -I$(ACE_BUILDDIR) \
- -I$(TAO_ROOT) \
- -I$(TAO_BUILDDIR)
-
-server_SOURCES = \
- ORT_testC.cpp \
- ORT_testS.cpp \
- ORT_test_IORInterceptor.cpp \
- ORT_test_i.cpp \
- ObjectReferenceFactory.cpp \
- ObjectReferenceFactoryC.cpp \
- ServerORBInitializer.cpp \
- ServerRequestInterceptor.cpp \
- server.cpp \
- ORT_test_IORInterceptor.h \
- ORT_test_i.h \
- ObjectReferenceFactory.h \
- ServerORBInitializer.h \
- ServerRequestInterceptor.h
-
-server_LDADD = \
- $(TAO_BUILDDIR)/tao/libTAO_PI_Server.la \
- $(TAO_BUILDDIR)/tao/libTAO_IORInterceptor.la \
- $(TAO_BUILDDIR)/tao/libTAO_PI.la \
- $(TAO_BUILDDIR)/tao/libTAO_CodecFactory.la \
- $(TAO_BUILDDIR)/tao/libTAO_ObjRefTemplate.la \
- $(TAO_BUILDDIR)/tao/libTAO_Valuetype.la \
- $(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
- $(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
- $(TAO_BUILDDIR)/tao/libTAO.la \
- $(ACE_BUILDDIR)/ace/libACE.la
-
-endif BUILD_INTERCEPTORS
-endif BUILD_EXCEPTIONS
-
-## Makefile.Test_ORT_Client.am
-
-if BUILD_EXCEPTIONS
-if BUILD_INTERCEPTORS
-
-noinst_PROGRAMS += client
-
-client_CPPFLAGS = \
- -I$(ACE_ROOT) \
- -I$(ACE_BUILDDIR) \
- -I$(TAO_ROOT) \
- -I$(TAO_BUILDDIR)
-
-client_SOURCES = \
- ORT_testC.cpp \
- client.cpp \
- ORT_test_IORInterceptor.h \
- ORT_test_i.h \
- ObjectReferenceFactory.h \
- ServerORBInitializer.h \
- ServerRequestInterceptor.h
-
-client_LDADD = \
- $(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
- $(TAO_BUILDDIR)/tao/libTAO.la \
- $(ACE_BUILDDIR)/ace/libACE.la
-
-endif BUILD_INTERCEPTORS
-endif BUILD_EXCEPTIONS
-
-## Clean up template repositories, etc.
-clean-local:
- -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
- -rm -f gcctemp.c gcctemp so_locations *.ics
- -rm -rf cxx_repository ptrepository ti_files
- -rm -rf templateregistry ir.out
- -rm -rf ptrepository SunWS_cache Templates.DB