summaryrefslogtreecommitdiff
path: root/trunk/TAO/orbsvcs/examples/CosEC/Factory/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'trunk/TAO/orbsvcs/examples/CosEC/Factory/Makefile.am')
-rw-r--r--trunk/TAO/orbsvcs/examples/CosEC/Factory/Makefile.am136
1 files changed, 136 insertions, 0 deletions
diff --git a/trunk/TAO/orbsvcs/examples/CosEC/Factory/Makefile.am b/trunk/TAO/orbsvcs/examples/CosEC/Factory/Makefile.am
new file mode 100644
index 00000000000..0e9793186e5
--- /dev/null
+++ b/trunk/TAO/orbsvcs/examples/CosEC/Factory/Makefile.am
@@ -0,0 +1,136 @@
+## Process this file with automake to create Makefile.in
+##
+## $Id$
+##
+## This file was generated by MPC. Any changes made directly to
+## this file will be lost the next time it is generated.
+##
+## MPC Command:
+## ../bin/mwc.pl -type automake -noreldefs TAO.mwc
+
+ACE_BUILDDIR = $(top_builddir)/..
+ACE_ROOT = $(top_srcdir)/..
+TAO_BUILDDIR = $(top_builddir)
+TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
+TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
+TAO_IDLFLAGS = -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
+TAO_ROOT = $(top_srcdir)
+
+noinst_PROGRAMS =
+
+## Makefile.CosEC_Factory_Idl.am
+
+if BUILD_EXCEPTIONS
+
+BUILT_SOURCES = \
+ CosEventChannelFactoryC.cpp \
+ CosEventChannelFactoryC.h \
+ CosEventChannelFactoryC.inl \
+ CosEventChannelFactoryS.cpp \
+ CosEventChannelFactoryS.h \
+ CosEventChannelFactoryS.inl
+
+CLEANFILES = \
+ CosEventChannelFactory-stamp \
+ CosEventChannelFactoryC.cpp \
+ CosEventChannelFactoryC.h \
+ CosEventChannelFactoryC.inl \
+ CosEventChannelFactoryS.cpp \
+ CosEventChannelFactoryS.h \
+ CosEventChannelFactoryS.inl
+
+CosEventChannelFactoryC.cpp CosEventChannelFactoryC.h CosEventChannelFactoryC.inl CosEventChannelFactoryS.cpp CosEventChannelFactoryS.h CosEventChannelFactoryS.inl: CosEventChannelFactory-stamp
+
+CosEventChannelFactory-stamp: $(srcdir)/CosEventChannelFactory.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -I$(TAO_ROOT)/orbsvcs $(srcdir)/CosEventChannelFactory.idl
+ @touch $@
+
+noinst_HEADERS = \
+ CosEventChannelFactory.idl
+
+endif BUILD_EXCEPTIONS
+
+## Makefile.CosEC_Factory_Client.am
+
+if BUILD_EXCEPTIONS
+
+noinst_PROGRAMS += FactoryClient
+
+FactoryClient_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR) \
+ -I$(TAO_ROOT)/orbsvcs \
+ -I$(TAO_BUILDDIR)/orbsvcs \
+ -DTAO_HAS_TYPED_EVENT_CHANNEL
+
+FactoryClient_SOURCES = \
+ CosEventChannelFactoryC.cpp \
+ FactoryClient.cpp \
+ CosEventChannelFactory_i.h \
+ FactoryDriver.h
+
+FactoryClient_LDADD = \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNaming.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosEvent_Skel.la \
+ $(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosEvent.la \
+ $(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
+ $(TAO_BUILDDIR)/tao/libTAO.la \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+endif BUILD_EXCEPTIONS
+
+## Makefile.CosEC_Factory_Server.am
+
+if BUILD_CORBA_MESSAGING
+if BUILD_EXCEPTIONS
+
+noinst_PROGRAMS += FactoryServer
+
+FactoryServer_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR) \
+ -I$(TAO_ROOT)/orbsvcs \
+ -I$(TAO_BUILDDIR)/orbsvcs \
+ -DTAO_HAS_TYPED_EVENT_CHANNEL
+
+FactoryServer_SOURCES = \
+ CosEventChannelFactoryC.cpp \
+ CosEventChannelFactoryS.cpp \
+ CosEventChannelFactory_i.cpp \
+ FactoryDriver.cpp \
+ main.cpp \
+ CosEventChannelFactory_i.h \
+ FactoryDriver.h
+
+FactoryServer_LDADD = \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosEvent_Serv.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_Svc_Utils.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNaming.la \
+ $(TAO_BUILDDIR)/tao/libTAO_IFR_Client.la \
+ $(TAO_BUILDDIR)/tao/libTAO_DynamicInterface.la \
+ $(TAO_BUILDDIR)/tao/libTAO_Messaging.la \
+ $(TAO_BUILDDIR)/tao/libTAO_PI.la \
+ $(TAO_BUILDDIR)/tao/libTAO_CodecFactory.la \
+ $(TAO_BUILDDIR)/tao/libTAO_Valuetype.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosEvent_Skel.la \
+ $(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosEvent.la \
+ $(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
+ $(TAO_BUILDDIR)/tao/libTAO.la \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+endif BUILD_EXCEPTIONS
+endif BUILD_CORBA_MESSAGING
+
+## Clean up template repositories, etc.
+clean-local:
+ -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
+ -rm -f gcctemp.c gcctemp so_locations *.ics
+ -rm -rf cxx_repository ptrepository ti_files
+ -rm -rf templateregistry ir.out
+ -rm -rf ptrepository SunWS_cache Templates.DB