summaryrefslogtreecommitdiff
path: root/trunk/TAO/orbsvcs/tests/Trading/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'trunk/TAO/orbsvcs/tests/Trading/Makefile.am')
-rw-r--r--trunk/TAO/orbsvcs/tests/Trading/Makefile.am218
1 files changed, 218 insertions, 0 deletions
diff --git a/trunk/TAO/orbsvcs/tests/Trading/Makefile.am b/trunk/TAO/orbsvcs/tests/Trading/Makefile.am
new file mode 100644
index 00000000000..76bf6db8c32
--- /dev/null
+++ b/trunk/TAO/orbsvcs/tests/Trading/Makefile.am
@@ -0,0 +1,218 @@
+## Process this file with automake to create Makefile.in
+##
+## $Id$
+##
+## This file was generated by MPC. Any changes made directly to
+## this file will be lost the next time it is generated.
+##
+## MPC Command:
+## ../bin/mwc.pl -type automake -noreldefs TAO.mwc
+
+ACE_BUILDDIR = $(top_builddir)/..
+ACE_ROOT = $(top_srcdir)/..
+TAO_BUILDDIR = $(top_builddir)
+TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
+TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
+TAO_IDLFLAGS = -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
+TAO_ROOT = $(top_srcdir)
+
+noinst_PROGRAMS =
+
+## Makefile.Trading_Test_Lib.am
+
+if BUILD_EXCEPTIONS
+
+BUILT_SOURCES = \
+ TTestC.cpp \
+ TTestC.h \
+ TTestC.inl \
+ TTestS.cpp \
+ TTestS.h \
+ TTestS.inl
+
+CLEANFILES = \
+ TTest-stamp \
+ TTestC.cpp \
+ TTestC.h \
+ TTestC.inl \
+ TTestS.cpp \
+ TTestS.h \
+ TTestS.inl
+
+TTestC.cpp TTestC.h TTestC.inl TTestS.cpp TTestS.h TTestS.inl: TTest-stamp
+
+TTest-stamp: $(srcdir)/TTest.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -I$(TAO_ROOT)/orbsvcs -I..\..\.. -I..\..\..\orbsvcs -Wb,export_macro=TAO_TTest_Export -Wb,export_include=ttest_export.h $(srcdir)/TTest.idl
+ @touch $@
+
+noinst_LTLIBRARIES = libTTest.la
+
+libTTest_la_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR) \
+ -I$(TAO_ROOT)/orbsvcs \
+ -I$(TAO_BUILDDIR)/orbsvcs \
+ -DTAO_TTEST_BUILD_DLL
+
+libTTest_la_SOURCES = \
+ Offer_Exporter.cpp \
+ Offer_Importer.cpp \
+ Service_Type_Exporter.cpp \
+ Simple_Dynamic.cpp \
+ TT_Info.cpp \
+ TTestC.cpp \
+ TTestS.cpp
+
+noinst_HEADERS = \
+ Offer_Exporter.h \
+ Offer_Importer.h \
+ Service_Type_Exporter.h \
+ Simple_Dynamic.h \
+ TT_Info.h \
+ TTest.idl \
+ TTestC.h \
+ TTestC.inl \
+ TTestS.h \
+ TTestS.inl \
+ ttest_export.h
+
+endif BUILD_EXCEPTIONS
+
+## Makefile.Trading_Colocated_Test.am
+
+if BUILD_EXCEPTIONS
+
+noinst_PROGRAMS += colocated_test
+
+colocated_test_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR) \
+ -I$(TAO_ROOT)/orbsvcs \
+ -I$(TAO_BUILDDIR)/orbsvcs
+
+colocated_test_SOURCES = \
+ colocated_test.cpp \
+ Offer_Exporter.h \
+ Offer_Importer.h \
+ Service_Type_Exporter.h \
+ Simple_Dynamic.h \
+ TT_Info.h \
+ ttest_export.h
+
+colocated_test_LDADD = \
+ libTTest.la \
+ $(TAO_BUILDDIR)/tao/libTAO_Utils.la \
+ $(TAO_BUILDDIR)/tao/libTAO_PI.la \
+ $(TAO_BUILDDIR)/tao/libTAO_CodecFactory.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosTrading_Serv.la \
+ $(TAO_BUILDDIR)/tao/libTAO_IORTable.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_Svc_Utils.la \
+ $(TAO_BUILDDIR)/tao/libTAO_DynamicAny.la \
+ $(TAO_BUILDDIR)/tao/libTAO_Valuetype.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosTrading_Skel.la \
+ $(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosTrading.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNaming.la \
+ $(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
+ $(TAO_BUILDDIR)/tao/libTAO.la \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+endif BUILD_EXCEPTIONS
+
+## Makefile.Trading_Export_Test.am
+
+if BUILD_EXCEPTIONS
+
+noinst_PROGRAMS += export_test
+
+export_test_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR) \
+ -I$(TAO_ROOT)/orbsvcs \
+ -I$(TAO_BUILDDIR)/orbsvcs
+
+export_test_SOURCES = \
+ export_test.cpp \
+ Offer_Exporter.h \
+ Offer_Importer.h \
+ Service_Type_Exporter.h \
+ Simple_Dynamic.h \
+ TT_Info.h \
+ ttest_export.h
+
+export_test_LDADD = \
+ libTTest.la \
+ $(TAO_BUILDDIR)/tao/libTAO_Utils.la \
+ $(TAO_BUILDDIR)/tao/libTAO_PI.la \
+ $(TAO_BUILDDIR)/tao/libTAO_CodecFactory.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosTrading_Serv.la \
+ $(TAO_BUILDDIR)/tao/libTAO_IORTable.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_Svc_Utils.la \
+ $(TAO_BUILDDIR)/tao/libTAO_DynamicAny.la \
+ $(TAO_BUILDDIR)/tao/libTAO_Valuetype.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosTrading_Skel.la \
+ $(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosTrading.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNaming.la \
+ $(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
+ $(TAO_BUILDDIR)/tao/libTAO.la \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+endif BUILD_EXCEPTIONS
+
+## Makefile.Trading_Import_Test.am
+
+if BUILD_EXCEPTIONS
+
+noinst_PROGRAMS += import_test
+
+import_test_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR) \
+ -I$(TAO_ROOT)/orbsvcs \
+ -I$(TAO_BUILDDIR)/orbsvcs
+
+import_test_SOURCES = \
+ import_test.cpp \
+ Offer_Exporter.h \
+ Offer_Importer.h \
+ Service_Type_Exporter.h \
+ Simple_Dynamic.h \
+ TT_Info.h \
+ ttest_export.h
+
+import_test_LDADD = \
+ libTTest.la \
+ $(TAO_BUILDDIR)/tao/libTAO_Utils.la \
+ $(TAO_BUILDDIR)/tao/libTAO_PI.la \
+ $(TAO_BUILDDIR)/tao/libTAO_CodecFactory.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosTrading_Serv.la \
+ $(TAO_BUILDDIR)/tao/libTAO_IORTable.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_Svc_Utils.la \
+ $(TAO_BUILDDIR)/tao/libTAO_DynamicAny.la \
+ $(TAO_BUILDDIR)/tao/libTAO_Valuetype.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosTrading_Skel.la \
+ $(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosTrading.la \
+ $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNaming.la \
+ $(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
+ $(TAO_BUILDDIR)/tao/libTAO.la \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+endif BUILD_EXCEPTIONS
+
+## Clean up template repositories, etc.
+clean-local:
+ -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
+ -rm -f gcctemp.c gcctemp so_locations *.ics
+ -rm -rf cxx_repository ptrepository ti_files
+ -rm -rf templateregistry ir.out
+ -rm -rf ptrepository SunWS_cache Templates.DB