summaryrefslogtreecommitdiff
path: root/trunk/TAO/tests/CSD_Strategy_Tests/TP_Foo_A/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'trunk/TAO/tests/CSD_Strategy_Tests/TP_Foo_A/Makefile.am')
-rw-r--r--trunk/TAO/tests/CSD_Strategy_Tests/TP_Foo_A/Makefile.am88
1 files changed, 88 insertions, 0 deletions
diff --git a/trunk/TAO/tests/CSD_Strategy_Tests/TP_Foo_A/Makefile.am b/trunk/TAO/tests/CSD_Strategy_Tests/TP_Foo_A/Makefile.am
new file mode 100644
index 00000000000..5a848bb8c5e
--- /dev/null
+++ b/trunk/TAO/tests/CSD_Strategy_Tests/TP_Foo_A/Makefile.am
@@ -0,0 +1,88 @@
+## Process this file with automake to create Makefile.in
+##
+## $Id$
+##
+## This file was generated by MPC. Any changes made directly to
+## this file will be lost the next time it is generated.
+##
+## MPC Command:
+## ../bin/mwc.pl -type automake -noreldefs TAO.mwc
+
+ACE_BUILDDIR = $(top_builddir)/..
+ACE_ROOT = $(top_srcdir)/..
+TAO_BUILDDIR = $(top_builddir)
+TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
+TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
+TAO_IDLFLAGS = -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
+TAO_ROOT = $(top_srcdir)
+
+
+## Makefile.csd_tp_foo_a_lib.am
+
+if BUILD_EXCEPTIONS
+if BUILD_THREADS
+
+BUILT_SOURCES = \
+ Foo_AC.cpp \
+ Foo_AC.h \
+ Foo_AC.inl \
+ Foo_AS.cpp \
+ Foo_AS.h \
+ Foo_AS.inl
+
+CLEANFILES = \
+ Foo_A-stamp \
+ Foo_AC.cpp \
+ Foo_AC.h \
+ Foo_AC.inl \
+ Foo_AS.cpp \
+ Foo_AS.h \
+ Foo_AS.inl
+
+Foo_AC.cpp Foo_AC.h Foo_AC.inl Foo_AS.cpp Foo_AS.h Foo_AS.inl: Foo_A-stamp
+
+Foo_A-stamp: $(srcdir)/Foo_A.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -I$(TAO_ROOT)/tests/CSD_Strategy_Tests/TP_Common -Wb,export_macro=CSD_TP_Foo_A_Export -Wb,export_include=CSD_TP_Foo_A_Export.h $(srcdir)/Foo_A.idl
+ @touch $@
+
+noinst_LTLIBRARIES = libCSD_TP_Foo_A.la
+
+libCSD_TP_Foo_A_la_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR) \
+ -I$(TAO_ROOT)/tests/CSD_Strategy_Tests/TP_Common \
+ -I$(TAO_ROOT)/tao \
+ -DCSD_TP_FOO_A_BUILD_DLL
+
+libCSD_TP_Foo_A_la_SOURCES = \
+ Foo_AC.cpp \
+ Foo_AS.cpp \
+ Foo_A_ClientEngine.cpp \
+ Foo_A_Statistics.cpp \
+ Foo_A_i.cpp
+
+libCSD_TP_Foo_A_la_LDFLAGS = \
+ -L$(TAO_ROOT)/tests/CSD_Strategy_Tests/TP_Common
+
+noinst_HEADERS = \
+ Foo_A.idl \
+ Foo_AC.h \
+ Foo_AC.inl \
+ Foo_AS.h \
+ Foo_AS.inl \
+ Foo_A_ClientEngine.h \
+ Foo_A_Statistics.h \
+ Foo_A_i.h
+
+endif BUILD_THREADS
+endif BUILD_EXCEPTIONS
+
+## Clean up template repositories, etc.
+clean-local:
+ -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
+ -rm -f gcctemp.c gcctemp so_locations *.ics
+ -rm -rf cxx_repository ptrepository ti_files
+ -rm -rf templateregistry ir.out
+ -rm -rf ptrepository SunWS_cache Templates.DB