summaryrefslogtreecommitdiff
path: root/trunk/TAO/tests/IOR_Endpoint_Hostnames/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'trunk/TAO/tests/IOR_Endpoint_Hostnames/Makefile.am')
-rw-r--r--trunk/TAO/tests/IOR_Endpoint_Hostnames/Makefile.am96
1 files changed, 96 insertions, 0 deletions
diff --git a/trunk/TAO/tests/IOR_Endpoint_Hostnames/Makefile.am b/trunk/TAO/tests/IOR_Endpoint_Hostnames/Makefile.am
new file mode 100644
index 00000000000..dff8bc9b49b
--- /dev/null
+++ b/trunk/TAO/tests/IOR_Endpoint_Hostnames/Makefile.am
@@ -0,0 +1,96 @@
+## Process this file with automake to create Makefile.in
+##
+## $Id$
+##
+## This file was generated by MPC. Any changes made directly to
+## this file will be lost the next time it is generated.
+##
+## MPC Command:
+## ../bin/mwc.pl -type automake -noreldefs TAO.mwc
+
+ACE_BUILDDIR = $(top_builddir)/..
+ACE_ROOT = $(top_srcdir)/..
+TAO_BUILDDIR = $(top_builddir)
+TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
+TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
+TAO_IDLFLAGS = -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
+TAO_ROOT = $(top_srcdir)
+
+noinst_PROGRAMS =
+
+## Makefile.generate_ior.am
+
+if BUILD_EXCEPTIONS
+
+BUILT_SOURCES = \
+ bogusC.cpp \
+ bogusC.h \
+ bogusC.inl \
+ bogusS.cpp \
+ bogusS.h \
+ bogusS.inl
+
+CLEANFILES = \
+ bogus-stamp \
+ bogusC.cpp \
+ bogusC.h \
+ bogusC.inl \
+ bogusS.cpp \
+ bogusS.h \
+ bogusS.inl
+
+bogusC.cpp bogusC.h bogusC.inl bogusS.cpp bogusS.h bogusS.inl: bogus-stamp
+
+bogus-stamp: $(srcdir)/bogus.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) $(srcdir)/bogus.idl
+ @touch $@
+
+noinst_PROGRAMS += generate_ior
+
+generate_ior_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR)
+
+generate_ior_SOURCES = \
+ bogusC.cpp \
+ bogusS.cpp \
+ bogus_i.cpp \
+ generate_ior.cpp \
+ bogusC.h \
+ bogusC.inl \
+ bogusS.h \
+ bogusS.inl \
+ bogus_i.h
+
+generate_ior_LDADD = \
+ $(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
+ $(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
+ $(TAO_BUILDDIR)/tao/libTAO.la \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+endif BUILD_EXCEPTIONS
+
+## Makefile.list_interfaces.am
+
+noinst_PROGRAMS += list_interfaces
+
+list_interfaces_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR)
+
+list_interfaces_SOURCES = \
+ list_interfaces.cpp \
+ bogus_i.h
+
+list_interfaces_LDADD = \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+## Clean up template repositories, etc.
+clean-local:
+ -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
+ -rm -f gcctemp.c gcctemp so_locations *.ics
+ -rm -rf cxx_repository ptrepository ti_files
+ -rm -rf templateregistry ir.out
+ -rm -rf ptrepository SunWS_cache Templates.DB