summaryrefslogtreecommitdiff
path: root/trunk/TAO/tests/MT_BiDir/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'trunk/TAO/tests/MT_BiDir/Makefile.am')
-rw-r--r--trunk/TAO/tests/MT_BiDir/Makefile.am145
1 files changed, 145 insertions, 0 deletions
diff --git a/trunk/TAO/tests/MT_BiDir/Makefile.am b/trunk/TAO/tests/MT_BiDir/Makefile.am
new file mode 100644
index 00000000000..52dc0f6042e
--- /dev/null
+++ b/trunk/TAO/tests/MT_BiDir/Makefile.am
@@ -0,0 +1,145 @@
+## Process this file with automake to create Makefile.in
+##
+## $Id$
+##
+## This file was generated by MPC. Any changes made directly to
+## this file will be lost the next time it is generated.
+##
+## MPC Command:
+## ../bin/mwc.pl -type automake -noreldefs TAO.mwc
+
+ACE_BUILDDIR = $(top_builddir)/..
+ACE_ROOT = $(top_srcdir)/..
+TAO_BUILDDIR = $(top_builddir)
+TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
+TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
+TAO_IDLFLAGS = -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
+TAO_ROOT = $(top_srcdir)
+
+noinst_PROGRAMS =
+
+## Makefile.MT_BiDir_Idl.am
+
+BUILT_SOURCES = \
+ ReceiverC.cpp \
+ ReceiverC.h \
+ ReceiverC.inl \
+ ReceiverS.cpp \
+ ReceiverS.h \
+ ReceiverS.inl
+
+CLEANFILES = \
+ Receiver-stamp \
+ ReceiverC.cpp \
+ ReceiverC.h \
+ ReceiverC.inl \
+ ReceiverS.cpp \
+ ReceiverS.h \
+ ReceiverS.inl
+
+ReceiverC.cpp ReceiverC.h ReceiverC.inl ReceiverS.cpp ReceiverS.h ReceiverS.inl: Receiver-stamp
+
+Receiver-stamp: $(srcdir)/Receiver.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -Sa -St $(srcdir)/Receiver.idl
+ @touch $@
+
+BUILT_SOURCES += \
+ SenderC.cpp \
+ SenderC.h \
+ SenderC.inl \
+ SenderS.cpp \
+ SenderS.h \
+ SenderS.inl
+
+CLEANFILES += \
+ Sender-stamp \
+ SenderC.cpp \
+ SenderC.h \
+ SenderC.inl \
+ SenderS.cpp \
+ SenderS.h \
+ SenderS.inl
+
+SenderC.cpp SenderC.h SenderC.inl SenderS.cpp SenderS.h SenderS.inl: Sender-stamp
+
+Sender-stamp: $(srcdir)/Sender.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) -Sa -St $(srcdir)/Sender.idl
+ @touch $@
+
+noinst_HEADERS = \
+ Receiver.idl \
+ Sender.idl
+
+## Makefile.MT_BiDir_Client.am
+
+if BUILD_EXCEPTIONS
+
+noinst_PROGRAMS += client
+
+client_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR)
+
+client_SOURCES = \
+ Client_Task.cpp \
+ ReceiverC.cpp \
+ ReceiverS.cpp \
+ Receiver_i.cpp \
+ SenderC.cpp \
+ client.cpp \
+ Client_Task.h \
+ Receiver_i.h
+
+client_LDADD = \
+ $(TAO_BUILDDIR)/tao/libTAO_BiDirGIOP.la \
+ $(TAO_BUILDDIR)/tao/libTAO_PI.la \
+ $(TAO_BUILDDIR)/tao/libTAO_CodecFactory.la \
+ $(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
+ $(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
+ $(TAO_BUILDDIR)/tao/libTAO.la \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+endif BUILD_EXCEPTIONS
+
+## Makefile.MT_BiDir_Server.am
+
+if BUILD_EXCEPTIONS
+
+noinst_PROGRAMS += server
+
+server_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR)
+
+server_SOURCES = \
+ ReceiverC.cpp \
+ SenderC.cpp \
+ SenderS.cpp \
+ Sender_i.cpp \
+ Server_Task.cpp \
+ server.cpp \
+ Sender_i.h \
+ Server_Task.h
+
+server_LDADD = \
+ $(TAO_BUILDDIR)/tao/libTAO_BiDirGIOP.la \
+ $(TAO_BUILDDIR)/tao/libTAO_PI.la \
+ $(TAO_BUILDDIR)/tao/libTAO_CodecFactory.la \
+ $(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
+ $(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
+ $(TAO_BUILDDIR)/tao/libTAO.la \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+endif BUILD_EXCEPTIONS
+
+## Clean up template repositories, etc.
+clean-local:
+ -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
+ -rm -f gcctemp.c gcctemp so_locations *.ics
+ -rm -rf cxx_repository ptrepository ti_files
+ -rm -rf templateregistry ir.out
+ -rm -rf ptrepository SunWS_cache Templates.DB