summaryrefslogtreecommitdiff
path: root/trunk/TAO/tests/ORB_Local_Config/Two_DLL_ORB/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'trunk/TAO/tests/ORB_Local_Config/Two_DLL_ORB/Makefile.am')
-rw-r--r--trunk/TAO/tests/ORB_Local_Config/Two_DLL_ORB/Makefile.am195
1 files changed, 195 insertions, 0 deletions
diff --git a/trunk/TAO/tests/ORB_Local_Config/Two_DLL_ORB/Makefile.am b/trunk/TAO/tests/ORB_Local_Config/Two_DLL_ORB/Makefile.am
new file mode 100644
index 00000000000..03650e6d2d8
--- /dev/null
+++ b/trunk/TAO/tests/ORB_Local_Config/Two_DLL_ORB/Makefile.am
@@ -0,0 +1,195 @@
+## Process this file with automake to create Makefile.in
+##
+## $Id$
+##
+## This file was generated by MPC. Any changes made directly to
+## this file will be lost the next time it is generated.
+##
+## MPC Command:
+## ../bin/mwc.pl -type automake -noreldefs TAO.mwc
+
+ACE_BUILDDIR = $(top_builddir)/..
+ACE_ROOT = $(top_srcdir)/..
+TAO_BUILDDIR = $(top_builddir)
+TAO_IDL = ACE_ROOT=$(ACE_ROOT) TAO_ROOT=$(TAO_ROOT) $(TAO_BUILDDIR)/TAO_IDL/tao_idl
+TAO_IDL_DEP = $(TAO_BUILDDIR)/TAO_IDL/tao_idl
+TAO_IDLFLAGS = -Wb,pre_include=ace/pre.h -Wb,post_include=ace/post.h -I$(TAO_ROOT) -I$(srcdir) -g $(ACE_BUILDDIR)/apps/gperf/src/gperf
+TAO_ROOT = $(top_srcdir)
+
+noinst_LTLIBRARIES =
+noinst_HEADERS =
+CLEANFILES =
+BUILT_SOURCES =
+
+## Makefile.ORB_DLL_Client.am
+
+if BUILD_EXCEPTIONS
+
+BUILT_SOURCES += \
+ TestC.cpp \
+ TestC.h \
+ TestC.inl \
+ TestS.cpp \
+ TestS.h \
+ TestS.inl
+
+CLEANFILES += \
+ Test-stamp \
+ TestC.cpp \
+ TestC.h \
+ TestC.inl \
+ TestS.cpp \
+ TestS.h \
+ TestS.inl
+
+TestC.cpp TestC.h TestC.inl TestS.cpp TestS.h TestS.inl: Test-stamp
+
+Test-stamp: $(srcdir)/Test.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) $(srcdir)/Test.idl
+ @touch $@
+
+noinst_LTLIBRARIES += libORB_DLL_Client.la
+
+libORB_DLL_Client_la_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR) \
+ -DSERVICE_CONFIG_ORB_DLL_BUILD_DLL
+
+libORB_DLL_Client_la_SOURCES = \
+ ORB_DLL.cpp \
+ TestC.cpp \
+ TestS.cpp \
+ Test_i.cpp \
+ client.cpp \
+ server.cpp
+
+noinst_HEADERS += \
+ ORB_DLL.h \
+ ORB_DLL_Export.h \
+ Test.idl \
+ TestC.h \
+ TestC.inl \
+ TestS.h \
+ TestS.inl \
+ Test_i.h
+
+endif BUILD_EXCEPTIONS
+
+## Makefile.ORB_DLL_Server.am
+
+if BUILD_THREADS
+
+BUILT_SOURCES += \
+ TestC.cpp \
+ TestC.h \
+ TestC.inl \
+ TestS.cpp \
+ TestS.h \
+ TestS.inl
+
+CLEANFILES += \
+ Test-stamp \
+ TestC.cpp \
+ TestC.h \
+ TestC.inl \
+ TestS.cpp \
+ TestS.h \
+ TestS.inl
+
+TestC.cpp TestC.h TestC.inl TestS.cpp TestS.h TestS.inl: Test-stamp
+
+Test-stamp: $(srcdir)/Test.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) $(srcdir)/Test.idl
+ @touch $@
+
+noinst_LTLIBRARIES += libORB_DLL_Server.la
+
+libORB_DLL_Server_la_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR) \
+ -DSERVICE_CONFIG_ORB_DLL_BUILD_DLL
+
+libORB_DLL_Server_la_SOURCES = \
+ ORB_DLL.cpp \
+ TestC.cpp \
+ TestS.cpp \
+ Test_i.cpp \
+ client.cpp \
+ server.cpp
+
+noinst_HEADERS += \
+ ORB_DLL.h \
+ ORB_DLL_Export.h \
+ Test.idl \
+ TestC.h \
+ TestC.inl \
+ TestS.h \
+ TestS.inl \
+ Test_i.h
+
+endif BUILD_THREADS
+
+## Makefile.Two_DLL_ORB.am
+
+if BUILD_EXCEPTIONS
+
+BUILT_SOURCES += \
+ TestC.cpp \
+ TestC.h \
+ TestC.inl \
+ TestS.cpp \
+ TestS.h \
+ TestS.inl
+
+CLEANFILES += \
+ Test-stamp \
+ TestC.cpp \
+ TestC.h \
+ TestC.inl \
+ TestS.cpp \
+ TestS.h \
+ TestS.inl
+
+TestC.cpp TestC.h TestC.inl TestS.cpp TestS.h TestS.inl: Test-stamp
+
+Test-stamp: $(srcdir)/Test.idl $(TAO_IDL_DEP)
+ $(TAO_IDL) $(TAO_IDLFLAGS) $(srcdir)/Test.idl
+ @touch $@
+
+noinst_PROGRAMS = Test
+
+Test_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR) \
+ -I$(srcdir)/../lib
+
+Test_SOURCES = \
+ Test.cpp \
+ TestC.cpp \
+ TestS.cpp \
+ TestC.h \
+ TestC.inl \
+ TestS.h \
+ TestS.inl
+
+Test_LDADD = \
+ $(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
+ $(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
+ $(TAO_BUILDDIR)/tao/libTAO.la \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+endif BUILD_EXCEPTIONS
+
+## Clean up template repositories, etc.
+clean-local:
+ -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
+ -rm -f gcctemp.c gcctemp so_locations *.ics
+ -rm -rf cxx_repository ptrepository ti_files
+ -rm -rf templateregistry ir.out
+ -rm -rf ptrepository SunWS_cache Templates.DB