summaryrefslogtreecommitdiff
path: root/trunk/TAO/tests/TransportCurrent/Framework/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'trunk/TAO/tests/TransportCurrent/Framework/Makefile.am')
-rw-r--r--trunk/TAO/tests/TransportCurrent/Framework/Makefile.am98
1 files changed, 98 insertions, 0 deletions
diff --git a/trunk/TAO/tests/TransportCurrent/Framework/Makefile.am b/trunk/TAO/tests/TransportCurrent/Framework/Makefile.am
new file mode 100644
index 00000000000..80849010daf
--- /dev/null
+++ b/trunk/TAO/tests/TransportCurrent/Framework/Makefile.am
@@ -0,0 +1,98 @@
+## Process this file with automake to create Makefile.in
+##
+## $Id$
+##
+## This file was generated by MPC. Any changes made directly to
+## this file will be lost the next time it is generated.
+##
+## MPC Command:
+## ../bin/mwc.pl -type automake -noreldefs TAO.mwc
+
+ACE_BUILDDIR = $(top_builddir)/..
+ACE_ROOT = $(top_srcdir)/..
+TAO_BUILDDIR = $(top_builddir)
+TAO_ROOT = $(top_srcdir)
+
+noinst_PROGRAMS =
+
+## Makefile.Framework_Server.am
+
+if BUILD_EXCEPTIONS
+if BUILD_INTERCEPTORS
+
+noinst_PROGRAMS += server
+
+server_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR) \
+ -I$(srcdir)/../lib \
+ -I../lib
+
+server_SOURCES = \
+ Current_Test_Impl.cpp \
+ Server_Main.cpp \
+ Tester.cpp \
+ server.cpp
+
+server_LDADD = \
+ $(top_builddir)/tests/TransportCurrent/lib/libCurrent_Test_Lib_Client.la \
+ $(top_builddir)/tests/TransportCurrent/lib/libCurrent_Test_Lib_Server.la \
+ $(TAO_BUILDDIR)/tao/libTAO_PI_Server.la \
+ $(TAO_BUILDDIR)/tao/libTAO_TC.la \
+ $(TAO_BUILDDIR)/tao/libTAO_PI.la \
+ $(TAO_BUILDDIR)/tao/libTAO_CodecFactory.la \
+ $(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
+ $(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
+ $(TAO_BUILDDIR)/tao/libTAO.la \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+endif BUILD_INTERCEPTORS
+endif BUILD_EXCEPTIONS
+
+## Makefile.Framework_Client.am
+
+if BUILD_CORBA_MESSAGING
+if BUILD_EXCEPTIONS
+if BUILD_INTERCEPTORS
+
+noinst_PROGRAMS += client
+
+client_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(TAO_ROOT) \
+ -I$(TAO_BUILDDIR) \
+ -I$(srcdir)/../lib \
+ -I../lib
+
+client_SOURCES = \
+ Tester.cpp \
+ client.cpp
+
+client_LDADD = \
+ $(top_builddir)/tests/TransportCurrent/lib/libCurrent_Test_Lib_Client.la \
+ $(top_builddir)/tests/TransportCurrent/lib/libCurrent_Test_Lib_Server.la \
+ $(TAO_BUILDDIR)/tao/libTAO_DynamicInterface.la \
+ $(TAO_BUILDDIR)/tao/libTAO_Messaging.la \
+ $(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
+ $(TAO_BUILDDIR)/tao/libTAO_Valuetype.la \
+ $(TAO_BUILDDIR)/tao/libTAO_TC.la \
+ $(TAO_BUILDDIR)/tao/libTAO_PI.la \
+ $(TAO_BUILDDIR)/tao/libTAO_CodecFactory.la \
+ $(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
+ $(TAO_BUILDDIR)/tao/libTAO.la \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+endif BUILD_INTERCEPTORS
+endif BUILD_EXCEPTIONS
+endif BUILD_CORBA_MESSAGING
+
+## Clean up template repositories, etc.
+clean-local:
+ -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
+ -rm -f gcctemp.c gcctemp so_locations *.ics
+ -rm -rf cxx_repository ptrepository ti_files
+ -rm -rf templateregistry ir.out
+ -rm -rf ptrepository SunWS_cache Templates.DB