summaryrefslogtreecommitdiff
path: root/utils/catior/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'utils/catior/Makefile.am')
-rw-r--r--utils/catior/Makefile.am105
1 files changed, 0 insertions, 105 deletions
diff --git a/utils/catior/Makefile.am b/utils/catior/Makefile.am
deleted file mode 100644
index afad7c7f320..00000000000
--- a/utils/catior/Makefile.am
+++ /dev/null
@@ -1,105 +0,0 @@
-## Process this file with automake to create Makefile.in
-##
-## $Id$
-##
-## This file was generated by MPC. Any changes made directly to
-## this file will be lost the next time it is generated.
-##
-## MPC Command:
-## ../bin/mwc.pl -type automake -noreldefs TAO.mwc
-
-includedir = @includedir@/utils/catior
-
-ACE_BUILDDIR = $(top_builddir)/..
-ACE_ROOT = $(top_srcdir)/..
-TAO_BUILDDIR = $(top_builddir)
-TAO_ROOT = $(top_srcdir)
-
-
-## Makefile.catior_lib.am
-
-if BUILD_CORBA_MESSAGING
-if BUILD_EXCEPTIONS
-if BUILD_RT_CORBA
-
-lib_LTLIBRARIES = libTAO_Catior.la
-
-libTAO_Catior_la_CPPFLAGS = \
- -I$(ACE_ROOT) \
- -I$(ACE_BUILDDIR) \
- -I$(TAO_ROOT) \
- -I$(TAO_BUILDDIR) \
- -DCATIOR_BUILD_DLL
-
-libTAO_Catior_la_SOURCES = \
- Catior_i.cpp
-
-libTAO_Catior_la_LDFLAGS = \
- -version-number @TAO_MAJOR@:@TAO_MINOR@:@TAO_BETA@
-
-libTAO_Catior_la_LIBADD = \
- $(TAO_BUILDDIR)/tao/libTAO_ZIOP.la \
- $(TAO_BUILDDIR)/tao/libTAO_Compression.la \
- $(TAO_BUILDDIR)/tao/libTAO_Messaging.la \
- $(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
- $(TAO_BUILDDIR)/tao/libTAO_Valuetype.la \
- $(TAO_BUILDDIR)/tao/libTAO_RTCORBA.la \
- $(TAO_BUILDDIR)/tao/libTAO_PI.la \
- $(TAO_BUILDDIR)/tao/libTAO_CodecFactory.la \
- $(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
- $(TAO_BUILDDIR)/tao/libTAO.la \
- $(ACE_BUILDDIR)/ace/libACE.la
-
-nobase_include_HEADERS = \
- Catior_i.h \
- catior_export.h
-
-endif BUILD_RT_CORBA
-endif BUILD_EXCEPTIONS
-endif BUILD_CORBA_MESSAGING
-
-## Makefile.catior.am
-
-if BUILD_CORBA_MESSAGING
-if BUILD_EXCEPTIONS
-if BUILD_RT_CORBA
-
-bin_PROGRAMS = tao_catior
-
-tao_catior_CPPFLAGS = \
- -I$(ACE_ROOT) \
- -I$(ACE_BUILDDIR) \
- -I$(TAO_ROOT) \
- -I$(TAO_BUILDDIR) \
- -I$(TAO_ROOT)/orbsvcs \
- -I$(TAO_BUILDDIR)/orbsvcs
-
-tao_catior_SOURCES = \
- catior.cpp
-
-tao_catior_LDADD = \
- libTAO_Catior.la \
- $(TAO_BUILDDIR)/tao/libTAO_ZIOP.la \
- $(TAO_BUILDDIR)/tao/libTAO_Compression.la \
- $(TAO_BUILDDIR)/tao/libTAO_Messaging.la \
- $(TAO_BUILDDIR)/tao/libTAO_PortableServer.la \
- $(TAO_BUILDDIR)/tao/libTAO_Valuetype.la \
- $(TAO_BUILDDIR)/tao/libTAO_RTCORBA.la \
- $(TAO_BUILDDIR)/tao/libTAO_PI.la \
- $(TAO_BUILDDIR)/tao/libTAO_CodecFactory.la \
- $(TAO_BUILDDIR)/orbsvcs/orbsvcs/libTAO_CosNaming.la \
- $(TAO_BUILDDIR)/tao/libTAO_AnyTypeCode.la \
- $(TAO_BUILDDIR)/tao/libTAO.la \
- $(ACE_BUILDDIR)/ace/libACE.la
-
-endif BUILD_RT_CORBA
-endif BUILD_EXCEPTIONS
-endif BUILD_CORBA_MESSAGING
-
-## Clean up template repositories, etc.
-clean-local:
- -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
- -rm -f gcctemp.c gcctemp so_locations *.ics
- -rm -rf cxx_repository ptrepository ti_files
- -rm -rf templateregistry ir.out
- -rm -rf ptrepository SunWS_cache Templates.DB