summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRalphNiemeyer <rniemeyer@de.adit-jv.com>2017-03-23 10:02:50 +0100
committerGitHub <noreply@github.com>2017-03-23 10:02:50 +0100
commit84c35df786d30b5fe7828b8400fe7b0d6c087138 (patch)
treef12e9eed3f87cea332667c5c2825925fd2c5b20c /CMakeLists.txt
parent49d5962d3960eabc989796d4e3236a55c14618e6 (diff)
parentfc91110918e948b006fdd18d9851a95c00fc95c3 (diff)
downloadDLT-daemon-84c35df786d30b5fe7828b8400fe7b0d6c087138.tar.gz
Merge pull request #6 from clipka/devel_fatal_trap
CMake Option: Trigger segmentation fault in case of FATAL log
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f97e491..f05d566 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -79,6 +79,8 @@ option(WITH_DLT_LOGSTORAGE_CTRL_UDEV "PROTOTYPE! Set to ON to build logstorage c
option(WITH_DLT_LOGSTORAGE_CTRL_PROP "PROTOTYPE! Set to ON to build logstorage control application with proprietary support" OFF)
option(WITH_DLT_USE_IPv6 "Set to ON for IPv6 support" ON)
option(WITH_DLT_KPI "Set to ON to build src/kpi binaries" ON)
+option(WITH_DLT_FATAL_LOG_TRAP "Set to ON to enable DLT_LOG_FATAL trap (trigger segv inside dlt-user library)" OFF)
+
# RPM settings
set( GENIVI_RPM_RELEASE "1")#${DLT_REVISION}")
set( LICENSE "Mozilla Public License Version 2.0" )
@@ -194,6 +196,10 @@ if(WITH_DLT_LOGSTORAGE_CTRL_PROP)
add_definitions( -DDLT_LOGSTORAGE_CTRL_PROP)
endif(WITH_DLT_LOGSTORAGE_CTRL_PROP)
+if (WITH_DLT_FATAL_LOG_TRAP)
+ add_definitions( -DDLT_FATAL_LOG_RESET_ENABLE)
+endif(WITH_DLT_FATAL_LOG_TRAP)
+
add_subdirectory( doc )
add_subdirectory( src )
add_subdirectory( include )