summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKHANH LUONG HONG DUY <khanh.luonghongduy@vn.bosch.com>2020-11-06 11:17:08 +0700
committerSaya Sugiura <39760799+ssugiura@users.noreply.github.com>2021-01-06 09:27:28 +0900
commit10944014dead99534c36ecb5aa0ccb3a90b43045 (patch)
tree6d39d414af3856fed5dfc67c470915e6a264e53f /CMakeLists.txt
parentc50f2a7c8edb13e1373515e78193af94d4d8d9c9 (diff)
downloadDLT-daemon-10944014dead99534c36ecb5aa0ccb3a90b43045.tar.gz
CMakeList: implement cpack for debian package
Introduce cpack options to build DLT debian package Signed-off-by: KHANH LUONG HONG DUY <khanh.luonghongduy@vn.bosch.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5a8404d..8bc8152 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -245,6 +245,12 @@ if (WITH_DLT_UNIT_TESTS)
add_subdirectory(tests)
endif()
+SET(CPACK_GENERATOR "DEB")
+SET(CPACK_PACKAGE_NAME "dlt_${DLT_REVISION}")
+SET(CPACK_PACKAGE_VERSION "${PROJECT_VERSION}")
+SET(CPACK_DEBIAN_PACKAGE_MAINTAINER "genivi-diagnostic-log-and-trace@lists.genivi.org")
+INCLUDE(CPack)
+
message(STATUS)
message(STATUS "-------------------------------------------------------------------------------")
message(STATUS "Build for Version ${PROJECT_VERSION} build ${DLT_REVISION} version state ${DLT_VERSION_STATE}")