summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChristoph Lipka <clipka@de.adit-jv.com>2018-12-21 10:31:38 +0100
committerChristoph Lipka <clipka@de.adit-jv.com>2018-12-21 10:31:38 +0100
commit1b3c8b3d10fbc9a8dd9c717a939babd901b0b243 (patch)
treec472bc7c4bf5983b16b444cd054484863091fc6f /CMakeLists.txt
parentdca8ab254aa0a687c32009079d85e4d8f960b213 (diff)
downloadDLT-daemon-1b3c8b3d10fbc9a8dd9c717a939babd901b0b243.tar.gz
CMake: Set default configuration
Signed-off-by: Christoph Lipka <clipka@de.adit-jv.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f57b174..782e50a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -56,17 +56,17 @@ option(WITH_SYSTEMD "Set to ON to create unit files and systemd check
option(WITH_SYSTEMD_WATCHDOG "Set to ON to use the systemd watchdog in dlt-daemon" OFF)
option(WITH_SYSTEMD_JOURNAL "Set to ON to use the systemd journal in dlt-system" OFF)
option(WITH_DOC "Set to ON to build documentation target" OFF )
-option(WITH_MAN "Set to ON to build man pages" ON )
+option(WITH_MAN "Set to ON to build man pages" OFF )
option(WITH_CHECK_CONFIG_FILE "Set to ON to create a configure file of CheckIncludeFiles and CheckFunctionExists " OFF )
option(WITH_TESTSCRIPTS "Set to ON to run CMakeLists.txt in testscripts" OFF )
option(WITH_GPROF "Set -pg to compile flags" OFF )
option(WITH_DLTTEST "Set to ON to build with modifications to test User-Daemon communication with corrupt messages" OFF)
option(WITH_DLT_SHM_ENABLE "EXPERIMENTAL! Set to ON to use shared memory as IPC. EXPERIMENTAL!" OFF )
-option(WITH_DLT_ADAPTOR "Set to ON to build src/adaptor binaries" ON)
+option(WITH_DLT_ADAPTOR "Set to ON to build src/adaptor binaries" OFF)
option(WITH_DLT_CONSOLE "Set to ON to build src/console binaries" ON)
option(WITH_DLT_EXAMPLES "Set to ON to build src/examples binaries" ON)
-option(WITH_DLT_SYSTEM "Set to ON to build src/system binaries" ON)
-option(WITH_DLT_DBUS "Set to ON to build src/dbus binaries" ON)
+option(WITH_DLT_SYSTEM "Set to ON to build src/system binaries" OFF)
+option(WITH_DLT_DBUS "Set to ON to build src/dbus binaries" OFF)
option(WITH_DLT_TESTS "Set to ON to build src/test binaries" ON)
option(WITH_DLT_UNIT_TESTS "Set to ON to build gtest framework and tests/binaries" OFF)
@@ -78,7 +78,7 @@ option(WITH_DLT_COREDUMPHANDLER "EXPERIMENTAL! Set to ON to build src/core_d
option(WITH_DLT_LOGSTORAGE_CTRL_UDEV "PROTOTYPE! Set to ON to build logstorage control application with udev support" OFF)
option(WITH_DLT_LOGSTORAGE_CTRL_PROP "PROTOTYPE! Set to ON to build logstorage control application with proprietary support" OFF)
option(WITH_DLT_USE_IPv6 "Set to ON for IPv6 support" ON)
-option(WITH_DLT_KPI "Set to ON to build src/kpi binaries" ON)
+option(WITH_DLT_KPI "Set to ON to build src/kpi binaries" OFF)
option(WITH_DLT_FATAL_LOG_TRAP "Set to ON to enable DLT_LOG_FATAL trap (trigger segv inside dlt-user library)" OFF)
# RPM settings