summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Muck <christian.muck@bmw.de>2012-06-13 23:21:00 +0200
committerChristian Muck <christian.muck@bmw.de>2012-06-13 23:53:29 +0200
commit2c146c92f571bec04875c2d912871c8ad5d9a2aa (patch)
tree5b47842db82aa67f1228a45391ff0f20a47209a9 /CMakeLists.txt
parent4dcb40918c0e2ea9352d2182898cf335519f65a4 (diff)
downloadDLT-daemon-2c146c92f571bec04875c2d912871c8ad5d9a2aa.tar.gz
Updated doxygen documentation, readme, man pages and release notes
Signed-off-by: Christian Muck <christian.muck@bmw.de>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt24
1 files changed, 12 insertions, 12 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2fc55f6..9b36c8e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -50,21 +50,21 @@ if(NOT CMAKE_BUILD_TYPE)
endif(NOT CMAKE_BUILD_TYPE)
# Set of indiviual options
-option(BUILD_SHARED_LIBS "Set to OFF to build static libraries" ON )
+option(BUILD_SHARED_LIBS "Set to OFF to build static libraries" ON )
option(WITH_SYSTEMD "Set to ON to create unit files and systemd check on dlt-daemon startup" OFF )
-option(WITH_SYSTEMD_WATCHDOG "Set to ON to use the systemd watchdog in dlt-daemon" OFF)
-option(WITH_DOC "Set to ON to build documentation target" OFF )
-option(WITH_MAN "Set to ON to build man pages" ON )
+option(WITH_SYSTEMD_WATCHDOG "Set to ON to use the systemd watchdog in dlt-daemon" OFF)
+option(WITH_DOC "Set to ON to build documentation target" OFF )
+option(WITH_MAN "Set to ON to build man pages" ON )
option(WITH_CHECK_CONFIG_FILE "Set to ON to create a configure file of CheckIncludeFiles and CheckFunctionExists " OFF )
-option(WITH_TESTSCRIPTS "Set to ON to run CMakeLists.txt in testscripts" OFF )
-option(WITH_GPROF "Set -pg to compile flags" OFF )
+option(WITH_TESTSCRIPTS "Set to ON to run CMakeLists.txt in testscripts" OFF )
+option(WITH_GPROF "Set -pg to compile flags" OFF )
option(WITH_DLTTEST "Set to ON to build with modifications to test User-Daemon communication with corrupt messages" OFF)
-option(WITH_DLT_SHM_ENABLE "EXPERIMENTAL! Set to ON to use shared memory as IPC. EXPERIMENTAL!" OFF )
-option(WTIH_DLT_ADAPTOR "Set ton ON to build src/adaptor binaries" ON)
-option(WITH_DLT_CONSOLE "Set ton ON to build src/console binaries" ON)
-option(WITH_DLT_EXAMPLES "Set ton ON to build src/examples binaries" ON)
-option(WITH_DLT_SYSTEM "Set ton ON to build src/system binaries" ON)
-option(WITH_DLT_TESTS "Set ton ON to build src/test binaries" ON)
+option(WITH_DLT_SHM_ENABLE "EXPERIMENTAL! Set to ON to use shared memory as IPC. EXPERIMENTAL!" OFF )
+option(WTIH_DLT_ADAPTOR "Set ton ON to build src/adaptor binaries" ON)
+option(WITH_DLT_CONSOLE "Set ton ON to build src/console binaries" ON)
+option(WITH_DLT_EXAMPLES "Set ton ON to build src/examples binaries" ON)
+option(WITH_DLT_SYSTEM "Set ton ON to build src/system binaries" ON)
+option(WITH_DLT_TESTS "Set ton ON to build src/test binaries" ON)
# RPM settings
set( GENIVI_RPM_RELEASE "1")#${DLT_REVISION}")
set( LICENSE "Mozilla Public License Version 2.0" )