summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSven Hassler <sven_hassler@mentor.com>2015-11-19 14:20:11 +0100
committerLutz Helwing <lutz_helwing@mentor.com>2015-12-16 17:20:39 +0100
commit96439591a8be7e3e10a5de9488dde245777318c8 (patch)
treeeb547483f683e5a202cb58f4e16d511a7cc432eb /CMakeLists.txt
parent472615cfec47da92a14f48417040a561ffdd3649 (diff)
downloadDLT-daemon-96439591a8be7e3e10a5de9488dde245777318c8.tar.gz
First implementation of dlt-procfs
This tool logs the following information to dlt-daemon: - PID, parent's PID, commandline when new processes appear, maked by "NEW" - PID when processes stop, marked by "STP" - PID, CPU-Time (ms), RSS (bytes), CTX-switches, I/O (bytes), I/O-wait (ms) for all processes that consume CPU time, marked as "ACT" - PID, commandline in a regular time-interval, marked as "CHK" - The number of interrupts on each CPU in a regular time interval, marked as "IRQ" A configuration file, called dlt-procfs.conf allows configuring the time intervals of the updated processes, the command-line updates and the interrupts as well as the preferred log level.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 52edb51..28c1b18 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -73,6 +73,7 @@ option(WITH_DLT_COREDUMPHANDLER "EXPERIMENTAL! Set to ON to build src/core_d
option(WITH_DLT_LOGSTORAGE_CTRL_UDEV "PROTOTYPE! Set to ON to build logstorage control application with udev support" OFF)
option(WITH_DLT_LOGSTORAGE_CTRL_PROP "PROTOTYPE! Set to ON to build logstorage control application with proprietary support" OFF)
option(WITH_DLT_USE_IPv6 "Set to ON for IPv6 support" ON)
+option(WITH_DLT_PROCFS "Set to ON to build src/procfs binaries" ON)
# RPM settings
set( GENIVI_RPM_RELEASE "1")#${DLT_REVISION}")
set( LICENSE "Mozilla Public License Version 2.0" )
@@ -206,6 +207,7 @@ message( STATUS "WITH_DLT_SHM_ENABLE = ${WITH_DLT_SHM_ENABLE}" )
message( STATUS "WITH_DLTTEST = ${WITH_DLTTEST}" )
message( STATUS "WITH_DLT_CXX11_EXT = ${WITH_DLT_CXX11_EXT}" )
message( STATUS "WITH_DLT_COREDUMPHANDLER = ${WITH_DLT_COREDUMPHANDLER}" )
+message( STATUS "WITH_DLT_PROCFS = ${WITH_DLT_PROCFS}" )
message( STATUS "WITH_CHECK_CONFIG_FILE = ${WITH_CHECK_CONFIG_FILE}" )
message( STATUS "WITH_TESTSCRIPTS = ${WITH_TESTSCRIPTS}" )
message( STATUS "WITH_GPROF = ${WITH_GPROF}" )