summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLassi Marttala <lassi.lm.marttala@partner.bmw.com>2012-03-02 11:03:16 +0100
committerLassi Marttala <lassi.lm.marttala@partner.bmw.com>2012-03-02 11:03:16 +0100
commitf6754bd20376209bc56047363ff94fcd44f16b51 (patch)
treeaabb5e8a96287292861ca1ad939f4c6f550e512e /CMakeLists.txt
parent5b36dadb143b873cbf4591e8ff4b572aa26c5c3c (diff)
downloadDLT-daemon-f6754bd20376209bc56047363ff94fcd44f16b51.tar.gz
[GDLT-53]
Improve the man page generation. Upgrade the versions within man files. Move man page generation into build/doc dir
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0dce0d6..c9a987f 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -73,6 +73,7 @@ endif(NOT CMAKE_BUILD_TYPE)
option(BUILD_SHARED_LIBS "Set to OFF to build static libraries" ON )
option(WITH_DLT_SHM_ENABLE "Set to OFF to use FIFO as IPC from user to daemon" OFF )
option(WITH_DOC "Set to ON to build documentation target" OFF )
+option(WITH_MAN "Set to OFF to skip building of man pages" ON )
option(WITH_CHECK_CONFIG_FILE "Set to ON to create a configure file of CheckIncludeFiles and CheckFunctionExists " OFF )
option(WITH_TESTSCRIPTS "Set to on to run CMakeLists.txt in testscripts" OFF )
option(WITH_SYSTEMD "Set to on to run CMakeLists.txt in systemd" OFF )