summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNguyen Dinh Thi <Thi.NguyenDinh@vn.bosch.com>2018-11-23 14:19:54 +0100
committerChristoph Lipka <clipka@users.noreply.github.com>2018-12-21 10:16:46 +0100
commitfecd1ccc6da327ae846db9a6feac7917120c99ac (patch)
tree2f45f41aa8dc436abf532282dd6037b1ede38a50 /CMakeLists.txt
parentab105d1671789fc9bd649f7e9ce3e6af22d30f0e (diff)
downloadDLT-daemon-fecd1ccc6da327ae846db9a6feac7917120c99ac.tar.gz
Remove unnecessary reference to zlib in .pc file
Signed-off-by: Nguyen Dinh Thi <Thi.NguyenDinh@vn.bosch.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 225ba17..f57b174 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -88,7 +88,10 @@ set( LICENSE "Mozilla Public License Version 2.0" )
# Build, project and include settings
find_package(Threads REQUIRED)
if(WITH_DLT_SYSTEM)
+ set(ZLIB_LIBRARY "-lz")
find_package(ZLIB REQUIRED)
+else(WITH_DLT_SYSTEM)
+ set(ZLIB_LIBRARY "")
endif(WITH_DLT_SYSTEM)
find_package(PkgConfig)