summaryrefslogtreecommitdiff
path: root/include/dlt/CMakeLists.txt
diff options
context:
space:
mode:
authorSaya Sugiura <ssugiura@jp.adit-jv.com>2021-07-28 10:39:38 +0900
committerSaya Sugiura <ssugiura@jp.adit-jv.com>2021-10-05 11:07:37 +0900
commitcafa943089779bdc79b879898d11abf9c7521fbe (patch)
treec16caaaf25ab0b81555a755b587677098b8698e3 /include/dlt/CMakeLists.txt
parent876575189a199b0a35c3fa0adc37f5e3ca1b3fc8 (diff)
downloadDLT-daemon-cafa943089779bdc79b879898d11abf9c7521fbe.tar.gz
header: Adapt to DLT_DISABLE_MACRO
If dlt.h is included in external application, it needed to include -DDLT_DISABLE_MACRO to make ifdef switch work. This commit adds DLT_DISABLE_MACRO in dlt_user.h so that no additional definition is needed in application. Signed-off-by: Saya Sugiura <ssugiura@jp.adit-jv.com>
Diffstat (limited to 'include/dlt/CMakeLists.txt')
-rw-r--r--include/dlt/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/dlt/CMakeLists.txt b/include/dlt/CMakeLists.txt
index 9362821..ae05cc3 100644
--- a/include/dlt/CMakeLists.txt
+++ b/include/dlt/CMakeLists.txt
@@ -13,6 +13,10 @@
# For further information see http://www.genivi.org/.
#######
+if(WITH_DLT_DISABLE_MACRO)
+ set(DLT_DISABLE_MACRO 1)
+endif()
+
configure_file(dlt_user.h.in dlt_user.h)
set(HEADER_LIST dlt.h dlt_user_macros.h dlt_client.h dlt_protocol.h