summaryrefslogtreecommitdiff
path: root/include/dlt/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Vacek <stefan.vacek@intel.com>2015-08-28 16:59:52 +0200
committerAlexander Wenzel <Alexander.AW.Wenzel@bmw.de>2015-10-07 10:36:13 +0200
commite5ffa017047525ed2e3ee41ea2294546ee64894c (patch)
treea3e431ffc19163ff8a54abae752e6063060789e3 /include/dlt/CMakeLists.txt
parentcd35815e6870df9b8db0da807c4d4db3607539ba (diff)
downloadDLT-daemon-e5ffa017047525ed2e3ee41ea2294546ee64894c.tar.gz
Add C++ extension
- header only implementation, uses variadic templates from C++ 11 - Enable installation and building tests with -DWITH_DLT_CXX11_EXT - allow logging in the form of DLT_LOG_CXX(context, level, param1, param2, param3), e.g. - allow logging of user types (if a function logToDlt for the given user-type is present), e.g. - Added pkg-config file automotive-dlt-c++.pc - Sample code is provided in tests/dlt-test-cpp-extension.cpp Signed-off-by: Stefan Vacek <stefan.vacek@intel.com>
Diffstat (limited to 'include/dlt/CMakeLists.txt')
-rw-r--r--include/dlt/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/include/dlt/CMakeLists.txt b/include/dlt/CMakeLists.txt
index a137206..057af1f 100644
--- a/include/dlt/CMakeLists.txt
+++ b/include/dlt/CMakeLists.txt
@@ -18,3 +18,10 @@
install(FILES dlt.h dlt_user.h dlt_user_macros.h dlt_client.h dlt_protocol.h dlt_common.h dlt_types.h dlt_version.h dlt_shm.h dlt_offline_trace.h dlt_filetransfer.h dlt_common_api.h
DESTINATION include/dlt
COMPONENT devel)
+
+
+if(${WITH_DLT_CXX11_EXT})
+ install(FILES dlt_cpp_extension.hpp
+ DESTINATION include/dlt
+ COMPONENT devel)
+endif() \ No newline at end of file