summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorBui Nguyen Quoc Thanh <49302843+thanhbnq@users.noreply.github.com>2022-05-10 10:23:14 +0700
committerGitHub <noreply@github.com>2022-05-10 10:23:14 +0700
commit0a1c9211af1b0d4f57ff75b4a4832140969722a1 (patch)
treeaacc23d708a7e14ded64e0c29e62f9ef9b8ab232 /src/CMakeLists.txt
parent875b386aeb1d24cfef2b41eb62072c373336645a (diff)
parentfcb676a79de5054803d701362a66962d04902179 (diff)
downloadDLT-daemon-0a1c9211af1b0d4f57ff75b4a4832140969722a1.tar.gz
Merge pull request #364 from alexmohr/make-adaptor-configurable
cmake: Add option to enable each adaptor by itself
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index e4ff133..6255336 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -25,9 +25,9 @@ if( WITH_DLT_EXAMPLES )
add_subdirectory( examples )
endif( WITH_DLT_EXAMPLES )
-if( WITH_DLT_ADAPTOR )
+if( WITH_DLT_ADAPTOR_STDIN OR WITH_DLT_ADAPTOR_UDP OR WITH_DLT_ADAPTOR )
add_subdirectory( adaptor )
-endif( WITH_DLT_ADAPTOR )
+endif( WITH_DLT_ADAPTOR_STDIN OR WITH_DLT_ADAPTOR_UDP OR WITH_DLT_ADAPTOR )
if( WITH_DLT_TESTS )
add_subdirectory( tests )