summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Mohr <alexander.m.mohr@daimler.com>2022-01-24 14:29:55 +0100
committerAlexander Mohr <alexander.m.mohr@mercedes-benz.com>2022-05-09 13:36:10 +0200
commitfcb676a79de5054803d701362a66962d04902179 (patch)
tree9ddfa7fca62932412f40b9bb18a22a509e3f9cab /src/CMakeLists.txt
parent0138c00811c86eab4ff6bff3c6528163885ade19 (diff)
downloadDLT-daemon-fcb676a79de5054803d701362a66962d04902179.tar.gz
Issue-ID: make-adaptor-configurablecmake: Add option to enable each adaptor by itself
This commit adds two options to enable the udp and stdin adaptor indendent from each other. Therefore only the necessary component can be enabled Signed-off-by: Alexander Mohr <alexander.m.mohr@daimler.com>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index e4ff133..6255336 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -25,9 +25,9 @@ if( WITH_DLT_EXAMPLES )
add_subdirectory( examples )
endif( WITH_DLT_EXAMPLES )
-if( WITH_DLT_ADAPTOR )
+if( WITH_DLT_ADAPTOR_STDIN OR WITH_DLT_ADAPTOR_UDP OR WITH_DLT_ADAPTOR )
add_subdirectory( adaptor )
-endif( WITH_DLT_ADAPTOR )
+endif( WITH_DLT_ADAPTOR_STDIN OR WITH_DLT_ADAPTOR_UDP OR WITH_DLT_ADAPTOR )
if( WITH_DLT_TESTS )
add_subdirectory( tests )