summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorSven Hassler <sven_hassler@mentor.com>2015-11-19 14:20:11 +0100
committerLutz Helwing <lutz_helwing@mentor.com>2015-12-16 17:20:39 +0100
commit96439591a8be7e3e10a5de9488dde245777318c8 (patch)
treeeb547483f683e5a202cb58f4e16d511a7cc432eb /src/CMakeLists.txt
parent472615cfec47da92a14f48417040a561ffdd3649 (diff)
downloadDLT-daemon-96439591a8be7e3e10a5de9488dde245777318c8.tar.gz
First implementation of dlt-procfs
This tool logs the following information to dlt-daemon: - PID, parent's PID, commandline when new processes appear, maked by "NEW" - PID when processes stop, marked by "STP" - PID, CPU-Time (ms), RSS (bytes), CTX-switches, I/O (bytes), I/O-wait (ms) for all processes that consume CPU time, marked as "ACT" - PID, commandline in a regular time-interval, marked as "CHK" - The number of interrupts on each CPU in a regular time interval, marked as "IRQ" A configuration file, called dlt-procfs.conf allows configuring the time intervals of the updated processes, the command-line updates and the interrupts as well as the preferred log level.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 6fd8a64..f30932a 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -46,3 +46,7 @@ endif( WITH_DLT_DBUS )
if( WITH_DLT_COREDUMPHANDLER )
add_subdirectory( core_dump_handler )
endif( WITH_DLT_COREDUMPHANDLER )
+
+if( WITH_DLT_PROCFS )
+ add_subdirectory( procfs )
+endif( WITH_DLT_PROCFS )