summaryrefslogtreecommitdiff
path: root/src/core_dump_handler/CMakeLists.txt
diff options
context:
space:
mode:
authorLutz Helwing <lutz_helwing@mentor.com>2015-06-23 18:32:44 +0200
committerAlexander Wenzel <Alexander.AW.Wenzel@bmw.de>2015-10-28 11:38:27 +0100
commitd7cea9b4df048a3b5da68710a5b62efe082fb447 (patch)
treea7e114d2bbf5814b5f221cb0273cc05fbbf52483 /src/core_dump_handler/CMakeLists.txt
parent2355ca4927cffd8307fdb78aaadeb584450bef21 (diff)
downloadDLT-daemon-d7cea9b4df048a3b5da68710a5b62efe082fb447.tar.gz
Added core dump handler code
Fixed author Doxygen tag Added licence headers Moved return value definition to new header Converted all DOS line endings to Unix Solution for CPU dependency by using CMAKE_SYSTEM_PROCESSOR cmake variable CPU specific stuff is implemented in own implementation file for each CPU architecture Added config file for sysctl. Fixed wrong parameters to open call for lockfile Added mechanism to overwrite TARGET_CPU_NAME with command line option Signed-off-by: Alexander Wenzel <Alexander.AW.Wenzel@bmw.de>
Diffstat (limited to 'src/core_dump_handler/CMakeLists.txt')
-rw-r--r--src/core_dump_handler/CMakeLists.txt42
1 files changed, 42 insertions, 0 deletions
diff --git a/src/core_dump_handler/CMakeLists.txt b/src/core_dump_handler/CMakeLists.txt
new file mode 100644
index 0000000..9d1df66
--- /dev/null
+++ b/src/core_dump_handler/CMakeLists.txt
@@ -0,0 +1,42 @@
+#######
+# @licence make begin@
+# SPDX license identifier: MPL-2.0
+#
+# Copyright (C) 2011-2015, BMW AG
+#
+# This file is part of GENIVI Project DLT - Diagnostic Log and Trace.
+#
+# This Source Code Form is subject to the terms of the
+# Mozilla Public License (MPL), v. 2.0.
+# If a copy of the MPL was not distributed with this file,
+# You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# For further information see http://www.genivi.org/.
+# @licence end@
+#######
+
+set( PLATFORM_DIR ${CMAKE_SOURCE_DIR}/src/core_dump_handler/${TARGET_CPU_NAME} )
+set(dlt_cdh_SRCS dlt_cdh.c dlt_cdh_context.c dlt_cdh_coredump.c ${PLATFORM_DIR}/dlt_cdh_cpuinfo.c dlt_cdh_crashid.c dlt_cdh_streamer.c)
+
+#set(COREDUMP_CONF_DIR "/usr/lib/sysctl.d/")
+
+#add_definitions( -fno-strict-aliasing )
+
+if(WITH_CITYHASH)
+ set( CITYHASH_DIR ${CMAKE_SOURCE_DIR}/src/core_dump_handler/cityhash_c )
+ add_definitions( -DHAS_CITYHASH_C )
+ set(dlt_cdh_SRCS ${CITYHASH_DIR}/city_c.c ${dlt_cdh_SRCS} )
+endif(WITH_CITYHASH)
+
+add_executable(dlt-cdh ${dlt_cdh_SRCS})
+target_link_libraries(dlt-cdh z)
+set_target_properties(dlt-cdh PROPERTIES LINKER_LANGUAGE C)
+
+
+install(TARGETS dlt-cdh
+ RUNTIME DESTINATION bin
+ COMPONENT base)
+
+#install(FILES 50-coredump.conf
+# DESTINATION ${COREDUMP_CONF_DIR}
+# COMPONENT base)