summaryrefslogtreecommitdiff
path: root/src/daemon/CMakeLists.txt
diff options
context:
space:
mode:
authorTomasz Kondziola <tkondziola@gmail.com>2015-02-10 08:23:30 +0100
committerAlexander Wenzel <Alexander.AW.Wenzel@bmw.de>2015-03-12 14:34:43 +0100
commit236829d03ab066341e5122cfceaf500dea4f0bfb (patch)
tree499f2958784ca5390acf9dae38934281301e39d1 /src/daemon/CMakeLists.txt
parentf90a5069f569aefa1c768ec7a336d982073f8ee2 (diff)
downloadDLT-daemon-236829d03ab066341e5122cfceaf500dea4f0bfb.tar.gz
resolves BUG-206: Install prefix should be configurable
Signed-off-by: Alexander Wenzel <Alexander.AW.Wenzel@bmw.de>
Diffstat (limited to 'src/daemon/CMakeLists.txt')
-rwxr-xr-xsrc/daemon/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/src/daemon/CMakeLists.txt b/src/daemon/CMakeLists.txt
index 5e2f780..11fb3ff 100755
--- a/src/daemon/CMakeLists.txt
+++ b/src/daemon/CMakeLists.txt
@@ -30,6 +30,8 @@ install(TARGETS dlt-daemon
WORLD_EXECUTE WORLD_READ
COMPONENT base)
-INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/dlt.conf
- DESTINATION /etc
- COMPONENT base)
+if(NOT CMAKE_INSTALL_PREFIX)
+ INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/dlt.conf DESTINATION /etc COMPONENT base)
+else(CMAKE_INSTALL_PREFIX)
+ INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/dlt.conf DESTINATION ${CMAKE_INSTALL_PREFIX}/etc COMPONENT base)
+endif(NOT CMAKE_INSTALL_PREFIX)