summaryrefslogtreecommitdiff
path: root/src/daemon/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Muck <christian.muck@bmw.de>2012-05-30 15:50:56 +0200
committerChristian Muck <christian.muck@bmw.de>2012-06-13 23:52:49 +0200
commitf211c63925ea6d03cc1036b5e11061ec82d92ef8 (patch)
treec657ec5bfe3714206c77e773f792fe146b075eba /src/daemon/CMakeLists.txt
parentbea4e475456745f444e2451415366d0e283f835c (diff)
downloadDLT-daemon-f211c63925ea6d03cc1036b5e11061ec82d92ef8.tar.gz
[GDLT-90] Implemented systemd watchdog concept
Signed-off-by: Christian Muck <christian.muck@bmw.de>
Diffstat (limited to 'src/daemon/CMakeLists.txt')
-rwxr-xr-xsrc/daemon/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/daemon/CMakeLists.txt b/src/daemon/CMakeLists.txt
index b868a0f..08c5767 100755
--- a/src/daemon/CMakeLists.txt
+++ b/src/daemon/CMakeLists.txt
@@ -14,8 +14,13 @@
# @licence end@
########
+
+if(WITH_SYSTEMD_WATCHDOG OR WITH_SYSTEMD)
+ message( STATUS "Added ${systemd_SRCS} to dlt-daemon")
+endif(WITH_SYSTEMD_WATCHDOG OR WITH_SYSTEMD)
+
set(dlt_daemon_SRCS dlt-daemon dlt_daemon_common ${CMAKE_SOURCE_DIR}/src/shared/dlt_user_shared.c ${CMAKE_SOURCE_DIR}/src/shared/dlt_common.c ${CMAKE_SOURCE_DIR}/src/shared/dlt_shm.c ${CMAKE_SOURCE_DIR}/src/shared/dlt_offline_trace.c)
-add_executable(dlt-daemon ${dlt_daemon_SRCS})
+add_executable(dlt-daemon ${dlt_daemon_SRCS} ${systemd_SRCS})
target_link_libraries(dlt-daemon rt ${CMAKE_THREAD_LIBS_INIT})
install(TARGETS dlt-daemon