summaryrefslogtreecommitdiff
path: root/src/daemon/CMakeLists.txt
diff options
context:
space:
mode:
authorSunil-K-S <54260601+Sunil-K-S@users.noreply.github.com>2019-08-23 10:01:08 +0530
committerSaya Sugiura <39760799+ssugiura@users.noreply.github.com>2019-08-23 13:31:08 +0900
commit976746f28e1c4c0a6ee24bf3f94ce66b890b3898 (patch)
tree2c617c4ee6f9a87b32b6e894f05f47361d907121 /src/daemon/CMakeLists.txt
parentd6baeb794e727a9194bfb28bff3c185e6d4fe631 (diff)
downloadDLT-daemon-976746f28e1c4c0a6ee24bf3f94ce66b890b3898.tar.gz
UDP Multicast implementation (#155)
The feature can be enabled by setting WITH_UDP_CONNECTION to ON. Signed-off-by: sunil.s <sunil.s@lge.com>
Diffstat (limited to 'src/daemon/CMakeLists.txt')
-rw-r--r--src/daemon/CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/src/daemon/CMakeLists.txt b/src/daemon/CMakeLists.txt
index b5cca17..adddee3 100644
--- a/src/daemon/CMakeLists.txt
+++ b/src/daemon/CMakeLists.txt
@@ -45,8 +45,6 @@ if(WITH_DLT_SHM_ENABLE)
${PROJECT_SOURCE_DIR}/src/shared/dlt_shm.c)
endif()
-add_executable(dlt-daemon ${dlt_daemon_SRCS} ${systemd_SRCS})
-
if(${CMAKE_SYSTEM_NAME} STREQUAL "Linux")
set(RT_LIBRARY rt)
set(SOCKET_LIBRARY "")
@@ -55,6 +53,13 @@ else()
set(SOCKET_LIBRARY socket)
endif()
+if(WITH_UDP_CONNECTION)
+ include_directories(${PROJECT_SOURCE_DIR}/src/daemon/udp_connection)
+ add_definitions(-DUDP_CONNECTION_SUPPORT)
+ set(dlt_daemon_SRCS ${dlt_daemon_SRCS} ${PROJECT_SOURCE_DIR}/src/daemon/udp_connection/dlt_daemon_udp_socket.c)
+endif(WITH_UDP_CONNECTION)
+
+add_executable(dlt-daemon ${dlt_daemon_SRCS} ${systemd_SRCS})
target_link_libraries(dlt-daemon ${RT_LIBRARY} ${SOCKET_LIBRARY} ${CMAKE_THREAD_LIBS_INIT})
install(TARGETS dlt-daemon