summaryrefslogtreecommitdiff
path: root/src/dbus/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Wenzel <Alexander.AW.Wenzel@bmw.de>2014-06-06 12:44:27 +0200
committerAlexander Wenzel <Alexander.AW.Wenzel@bmw.de>2014-06-11 14:16:57 +0200
commite561fd5d5e2564dcb6d5e4358ac7d3b917016ebb (patch)
treef0388e9af4323f0441c4b578631f68c0a2cc1f80 /src/dbus/CMakeLists.txt
parent9a91fe28c05c54f7428325b0290a29c28966ae56 (diff)
downloadDLT-daemon-e561fd5d5e2564dcb6d5e4358ac7d3b917016ebb.tar.gz
First implementation of DLT DBus adapter.
Signed-off-by: Alexander Wenzel <Alexander.AW.Wenzel@bmw.de>
Diffstat (limited to 'src/dbus/CMakeLists.txt')
-rw-r--r--src/dbus/CMakeLists.txt35
1 files changed, 35 insertions, 0 deletions
diff --git a/src/dbus/CMakeLists.txt b/src/dbus/CMakeLists.txt
new file mode 100644
index 0000000..4d26358
--- /dev/null
+++ b/src/dbus/CMakeLists.txt
@@ -0,0 +1,35 @@
+#######
+# Dlt - Diagnostic Log and Trace
+# @licence make begin@
+#
+# Copyright (C) 2011-2014, BMW AG - Alexander Wenzel <alexander.aw.wenzel@bmw.de>
+#
+# Contributions are licensed to the GENIVI Alliance under one or more
+# Contribution License Agreements.
+#
+# This Source Code Form is subject to the terms of the
+# Mozilla Public License, v. 2.0. If a copy of the MPL was not distributed with
+# this file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# @licence end@
+########
+
+include_directories(
+ ${CMAKE_SOURCE_DIR}/
+ ${CMAKE_SOURCE_DIR}/include/dlt
+ ${DBUS_INCLUDE_DIRS}
+)
+
+set(dlt_dbus_SRCS dlt-dbus.c)
+add_executable(dlt-dbus ${dlt_dbus_SRCS})
+target_link_libraries(dlt-dbus dlt ${DBUS_LIBRARIES})
+
+set_target_properties(dlt-dbus PROPERTIES LINKER_LANGUAGE C)
+
+install(TARGETS dlt-dbus
+ RUNTIME DESTINATION bin
+ COMPONENT base)
+
+INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/dlt-dbus.conf
+ DESTINATION /etc
+ COMPONENT base)