summaryrefslogtreecommitdiff
path: root/src/kpi/CMakeLists.txt
diff options
context:
space:
mode:
authorSven Hassler <sven_hassler@mentor.com>2015-11-25 14:26:06 +0100
committerLutz Helwing <lutz_helwing@mentor.com>2015-12-16 17:20:39 +0100
commit77400754611a8e7982a7ee3c4816ee5f070c0dca (patch)
tree43ddcfdbaeffa1afaa3df6377838c771ed8a837c /src/kpi/CMakeLists.txt
parent96439591a8be7e3e10a5de9488dde245777318c8 (diff)
downloadDLT-daemon-77400754611a8e7982a7ee3c4816ee5f070c0dca.tar.gz
Renamed "procfs" to "kpi", added sync-messages
Diffstat (limited to 'src/kpi/CMakeLists.txt')
-rw-r--r--src/kpi/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/src/kpi/CMakeLists.txt b/src/kpi/CMakeLists.txt
new file mode 100644
index 0000000..721b612
--- /dev/null
+++ b/src/kpi/CMakeLists.txt
@@ -0,0 +1,29 @@
+#######
+# @licence make begin@
+# SPDX license identifier: MPL-2.0
+#
+# Copyright (C) 2011-2015, BMW AG
+#
+# This file is part of GENIVI Project DLT - Diagnostic Log and Trace.
+#
+# This Source Code Form is subject to the terms of the
+# Mozilla Public License (MPL), v. 2.0.
+# If a copy of the MPL was not distributed with this file,
+# You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# For further information see http://www.genivi.org/.
+# @licence end@
+#######
+
+set (dlt_kpi_SRCS dlt-kpi.c dlt-kpi-options.c dlt-kpi-process.c dlt-kpi-process-list.c dlt-kpi-common.c dlt-kpi-interrupt.c)
+add_executable (dlt-kpi ${dlt_kpi_SRCS})
+target_link_libraries (dlt-kpi dlt)
+set_target_properties(dlt-kpi PROPERTIES LINKER_LANGUAGE C)
+
+install(TARGETS dlt-kpi
+ RUNTIME DESTINATION bin
+ COMPONENT base)
+
+INSTALL(FILES dlt-kpi.conf
+ DESTINATION ${CONFIGURATION_FILES_DIR}
+ COMPONENT base)