summaryrefslogtreecommitdiff
path: root/src/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorssugiura <ssugiura@jp.adit-jv.com>2021-01-25 05:22:48 +0000
committerSaya Sugiura <39760799+ssugiura@users.noreply.github.com>2021-10-05 11:19:26 +0900
commitcf79abb110c7ff8b5b75c6f48beeddd9d92dfbd3 (patch)
tree987909a796700d018cddcdf196fd238967616f5a /src/tests/CMakeLists.txt
parentd2200fc25e3ae0c04e349a80b979476ee156d215 (diff)
downloadDLT-daemon-cf79abb110c7ff8b5b75c6f48beeddd9d92dfbd3.tar.gz
Implemention of tests for the dlt-qnx-system module
Following files are added to execute and verify the behavior of dlt-qnx-system module: - dlt-test-qnx-system: A test binary to send log messages to slogger2 with specific number of log messages, delay, and payload length. - start-qnx-system-test: A shell script to invoke the test execution and verify its result from received DLT log. Signed-Off By: Saya Sugiura <ssugiura@jp.adit-jv.com>
Diffstat (limited to 'src/tests/CMakeLists.txt')
-rw-r--r--src/tests/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/tests/CMakeLists.txt b/src/tests/CMakeLists.txt
index 54151ea..9744fc0 100644
--- a/src/tests/CMakeLists.txt
+++ b/src/tests/CMakeLists.txt
@@ -46,5 +46,15 @@ foreach(target
COMPONENT base)
endforeach()
+if(WITH_DLT_QNX_SYSTEM)
+ set(dlt-test-qnx-slogger_SRCS dlt-test-qnx-slogger.c)
+ add_executable(dlt-test-qnx-slogger ${dlt-test-qnx-slogger_SRCS})
+ target_link_libraries(dlt-test-qnx-slogger dlt)
+ set_target_properties(dlt-test-qnx-slogger PROPERTIES LINKER_LANGUAGE C)
+ install(TARGETS dlt-test-qnx-slogger
+ RUNTIME DESTINATION bin
+ COMPONENT base)
+endif()
+
install(FILES dlt-test-filetransfer-file dlt-test-filetransfer-image.png
DESTINATION share/dlt-filetransfer)