summaryrefslogtreecommitdiff
path: root/systemd/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Muck <christian.muck@bmw.de>2012-02-13 21:27:25 +0100
committerChristian Muck <christian.muck@bmw.de>2012-02-13 21:27:25 +0100
commit77c849c2bd9acd95033a7243ed630234a584fc3a (patch)
tree249d595ee307e6731157a933ba03f53970d72b46 /systemd/CMakeLists.txt
parent214aebd2a8f5310c91fb580f93200a0fee364cbd (diff)
downloadDLT-daemon-77c849c2bd9acd95033a7243ed630234a584fc3a.tar.gz
Update project structure
Diffstat (limited to 'systemd/CMakeLists.txt')
-rw-r--r--systemd/CMakeLists.txt45
1 files changed, 45 insertions, 0 deletions
diff --git a/systemd/CMakeLists.txt b/systemd/CMakeLists.txt
new file mode 100644
index 0000000..e071d8a
--- /dev/null
+++ b/systemd/CMakeLists.txt
@@ -0,0 +1,45 @@
+#######
+# Dlt - Diagnostic Log and Trace
+# @licence make begin@
+ #
+ # Copyright (C) 2011, BMW AG - Alexander Wenzel <alexander.wenzel@bmw.de>
+ #
+ # This program is free software; you can redistribute it and/or modify it under the terms of the
+ # GNU Lesser General Public License, version 2.1, as published by the Free Software Foundation.
+ # This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even
+ # the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser General
+ # Public License, version 2.1, for more details.
+ #
+ # You should have received a copy of the GNU Lesser General Public License, version 2.1, along
+ # with this program; if not, see <http://www.gnu.org/licenses/lgpl-2.1.html>.
+ #
+ # Note that the copyright holders assume that the GNU Lesser General Public License, version 2.1, may
+ # also be applicable to programs even in cases in which the program is not a library in the technical sense.
+ #
+ # Linking DLT statically or dynamically with other modules is making a combined work based on DLT. You may
+ # license such other modules under the GNU Lesser General Public License, version 2.1. If you do not want to
+ # license your linked modules under the GNU Lesser General Public License, version 2.1, you
+ # may use the program under the following exception.
+ #
+ # As a special exception, the copyright holders of DLT give you permission to combine DLT
+ # with software programs or libraries that are released under any license unless such a combination is not
+ # permitted by the license of such a software program or library. You may copy and distribute such a
+ # system following the terms of the GNU Lesser General Public License, version 2.1, including this
+ # special exception, for DLT and the licenses of the other code concerned.
+ #
+ # Note that people who make modified versions of DLT are not obligated to grant this special exception
+ # for their modified versions; it is their choice whether to do so. The GNU Lesser General Public License,
+ # version 2.1, gives permission to release a modified version without this exception; this exception
+ # also makes it possible to release a modified version which carries forward this exception.
+ #
+ # @licence end@
+########
+
+if(WITH_SYSTEMD)
+ SET( DLT_SYSLOG_APPID "SYS" )
+ SET( DLT_SYSLOG_CTID "LOG" )
+ SET( DLT_SYSLOG_PORT 4712 )
+
+ CONFIGURE_FILE(${CMAKE_SOURCE_DIR}/systemd/dlt.service.cmake ${PROJECT_BINARY_DIR}/systemd/dlt.service @ONLY)
+ CONFIGURE_FILE(${CMAKE_SOURCE_DIR}/systemd/dlt-syslog.service.cmake ${PROJECT_BINARY_DIR}/systemd/dlt-syslog.service @ONLY)
+endif(WITH_SYSTEMD)