summaryrefslogtreecommitdiff
path: root/systemd/CMakeLists.txt
diff options
context:
space:
mode:
authorNoor <noor_ahsan@mentor.com>2013-06-11 17:05:42 +0500
committerAlexander Wenzel <Alexander.AW.Wenzel@bmw.de>2013-07-25 13:09:18 +0200
commitaa95de479a975a7cbf80a6a4d27deacfbe1b6479 (patch)
tree40bcdd828929665a4e4dc4f8ed5afa9346726453 /systemd/CMakeLists.txt
parent679529ce739a1d729f8c3515820fe9be98d68154 (diff)
downloadDLT-daemon-aa95de479a975a7cbf80a6a4d27deacfbe1b6479.tar.gz
systemd/CMakeLists: Remove SYSTEMD_CONFIGURATIONS_FILES_DIR existance check.
* During cross-compilation on ubuntu 10.04 the if condition checks the exitance of SYSTEMD_CONFIGURATIONS_FILES_DIR on host machine. It should not check host folders during cross-compilation. It results in no service file is installed even systemd is enabled during cross-compilation. Remove that if condition and its corresponding else condition. Signed-off-by: Noor Ahsan <noor_ahsan@mentor.com> Signed-off-by: Alexander Wenzel <Alexander.AW.Wenzel@bmw.de>
Diffstat (limited to 'systemd/CMakeLists.txt')
-rw-r--r--systemd/CMakeLists.txt18
1 files changed, 7 insertions, 11 deletions
diff --git a/systemd/CMakeLists.txt b/systemd/CMakeLists.txt
index d01c1ef..78ccada 100644
--- a/systemd/CMakeLists.txt
+++ b/systemd/CMakeLists.txt
@@ -46,15 +46,11 @@ if(WITH_SYSTEMD)
message(STATUS "DLT adaptor udp configuration: APPID=${DLT_ADAPTOR_UDP_APPID} CTID=${DLT_ADAPTOR_UDP_CTID} PORT=${DLT_ADAPTOR_UDP_PORT}" )
- if(EXISTS ${SYSTEMD_CONFIGURATIONS_FILES_DIR})
- install(FILES ${PROJECT_BINARY_DIR}/systemd/dlt.service DESTINATION ${SYSTEMD_CONFIGURATIONS_FILES_DIR} )
- install(FILES ${PROJECT_BINARY_DIR}/systemd/dlt-system.service DESTINATION ${SYSTEMD_CONFIGURATIONS_FILES_DIR} )
- install(FILES ${PROJECT_BINARY_DIR}/systemd/dlt-receive.service DESTINATION ${SYSTEMD_CONFIGURATIONS_FILES_DIR} )
- install(FILES ${PROJECT_BINARY_DIR}/systemd/dlt-example-user.service DESTINATION ${SYSTEMD_CONFIGURATIONS_FILES_DIR} )
- install(FILES ${PROJECT_BINARY_DIR}/systemd/dlt-adaptor-udp.service DESTINATION ${SYSTEMD_CONFIGURATIONS_FILES_DIR} )
- message(STATUS "Unit files will be installed to ${SYSTEMD_CONFIGURATIONS_FILES_DIR} after make install" )
- else(EXISTS ${SYSTEMD_CONFIGURATIONS_FILES_DIR})
- message(STATUS "Unit files will not be installed to ${SYSTEMD_CONFIGURATIONS_FILES_DIR} after make install")
- endif(EXISTS ${SYSTEMD_CONFIGURATIONS_FILES_DIR})
+ install(FILES ${PROJECT_BINARY_DIR}/systemd/dlt.service DESTINATION ${SYSTEMD_CONFIGURATIONS_FILES_DIR} )
+ install(FILES ${PROJECT_BINARY_DIR}/systemd/dlt-system.service DESTINATION ${SYSTEMD_CONFIGURATIONS_FILES_DIR} )
+ install(FILES ${PROJECT_BINARY_DIR}/systemd/dlt-receive.service DESTINATION ${SYSTEMD_CONFIGURATIONS_FILES_DIR} )
+ install(FILES ${PROJECT_BINARY_DIR}/systemd/dlt-example-user.service DESTINATION ${SYSTEMD_CONFIGURATIONS_FILES_DIR} )
+ install(FILES ${PROJECT_BINARY_DIR}/systemd/dlt-adaptor-udp.service DESTINATION ${SYSTEMD_CONFIGURATIONS_FILES_DIR} )
+ message(STATUS "Unit files will be installed to ${SYSTEMD_CONFIGURATIONS_FILES_DIR} after make install" )
-endif(WITH_SYSTEMD) \ No newline at end of file
+endif(WITH_SYSTEMD)