summaryrefslogtreecommitdiff
path: root/systemd/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Wenzel <Alexander.AW.Wenzel@bmw.de>2013-10-24 09:46:47 +0200
committerAlexander Wenzel <Alexander.AW.Wenzel@bmw.de>2013-10-24 16:30:00 +0200
commite0173d9427ca7fe9745272b623cd5f0b3039d099 (patch)
tree41d0ac5b8ca030d5614fce82c6f22825cc4d35f1 /systemd/CMakeLists.txt
parent6ab10c022d4464628fc2b848b5a56bf1eaafe857 (diff)
downloadDLT-daemon-e0173d9427ca7fe9745272b623cd5f0b3039d099.tar.gz
Fix: Install Example service file only when example enabled
Signed-off-by: Alexander Wenzel <Alexander.AW.Wenzel@bmw.de>
Diffstat (limited to 'systemd/CMakeLists.txt')
-rw-r--r--systemd/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/systemd/CMakeLists.txt b/systemd/CMakeLists.txt
index db25b09..38ab7c2 100644
--- a/systemd/CMakeLists.txt
+++ b/systemd/CMakeLists.txt
@@ -49,7 +49,11 @@ if(WITH_SYSTEMD)
install(FILES ${PROJECT_BINARY_DIR}/systemd/dlt.service DESTINATION ${SYSTEMD_CONFIGURATIONS_FILES_DIR} )
install(FILES ${PROJECT_BINARY_DIR}/systemd/dlt-system.service DESTINATION ${SYSTEMD_CONFIGURATIONS_FILES_DIR} )
install(FILES ${PROJECT_BINARY_DIR}/systemd/dlt-receive.service DESTINATION ${SYSTEMD_CONFIGURATIONS_FILES_DIR} )
- install(FILES ${PROJECT_BINARY_DIR}/systemd/dlt-example-user.service DESTINATION ${SYSTEMD_CONFIGURATIONS_FILES_DIR} )
+
+ if(WITH_DLT_EXAMPLES)
+ install(FILES ${PROJECT_BINARY_DIR}/systemd/dlt-example-user.service DESTINATION ${SYSTEMD_CONFIGURATIONS_FILES_DIR} )
+ endif(WITH_DLT_EXAMPLES)
+
install(FILES ${PROJECT_BINARY_DIR}/systemd/dlt-adaptor-udp.service DESTINATION ${SYSTEMD_CONFIGURATIONS_FILES_DIR} )
message(STATUS "Unit files will be installed to ${SYSTEMD_CONFIGURATIONS_FILES_DIR} after make install" )