summaryrefslogtreecommitdiff
path: root/systemd/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Wenzel <Alexander.AW.Wenzel@bmw.de>2014-06-06 12:44:27 +0200
committerAlexander Wenzel <Alexander.AW.Wenzel@bmw.de>2014-06-11 14:16:57 +0200
commite561fd5d5e2564dcb6d5e4358ac7d3b917016ebb (patch)
treef0388e9af4323f0441c4b578631f68c0a2cc1f80 /systemd/CMakeLists.txt
parent9a91fe28c05c54f7428325b0290a29c28966ae56 (diff)
downloadDLT-daemon-e561fd5d5e2564dcb6d5e4358ac7d3b917016ebb.tar.gz
First implementation of DLT DBus adapter.
Signed-off-by: Alexander Wenzel <Alexander.AW.Wenzel@bmw.de>
Diffstat (limited to 'systemd/CMakeLists.txt')
-rw-r--r--systemd/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/systemd/CMakeLists.txt b/systemd/CMakeLists.txt
index 38ab7c2..a9838e4 100644
--- a/systemd/CMakeLists.txt
+++ b/systemd/CMakeLists.txt
@@ -32,6 +32,11 @@ if(WITH_SYSTEMD)
configure_file(${CMAKE_SOURCE_DIR}/systemd/dlt-system.service.cmake ${PROJECT_BINARY_DIR}/systemd/dlt-system.service)
message( STATUS "Configured systemd unit file:dlt-system.service" )
+ if(WITH_DLT_DBUS)
+ configure_file(${CMAKE_SOURCE_DIR}/systemd/dlt-dbus.service.cmake ${PROJECT_BINARY_DIR}/systemd/dlt-dbus.service)
+ message( STATUS "Configured systemd unit file:dlt-dbus.service" )
+ endif(WITH_DLT_DBUS)
+
configure_file(${CMAKE_SOURCE_DIR}/systemd/dlt-receive.service.cmake ${PROJECT_BINARY_DIR}/systemd/dlt-receive.service)
message( STATUS "Configured systemd unit file:dlt-receive.service" )
@@ -50,6 +55,10 @@ if(WITH_SYSTEMD)
install(FILES ${PROJECT_BINARY_DIR}/systemd/dlt-system.service DESTINATION ${SYSTEMD_CONFIGURATIONS_FILES_DIR} )
install(FILES ${PROJECT_BINARY_DIR}/systemd/dlt-receive.service DESTINATION ${SYSTEMD_CONFIGURATIONS_FILES_DIR} )
+ if(WITH_DLT_DBUS)
+ install(FILES ${PROJECT_BINARY_DIR}/systemd/dlt-dbus.service DESTINATION ${SYSTEMD_CONFIGURATIONS_FILES_DIR} )
+ endif(WITH_DLT_DBUS)
+
if(WITH_DLT_EXAMPLES)
install(FILES ${PROJECT_BINARY_DIR}/systemd/dlt-example-user.service DESTINATION ${SYSTEMD_CONFIGURATIONS_FILES_DIR} )
endif(WITH_DLT_EXAMPLES)