summaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBiastoch, Darian (ADITG/ESM) <dbiastoch@de.adit-jv.com>2021-04-08 06:36:18 +0000
committerSaya Sugiura <39760799+ssugiura@users.noreply.github.com>2021-06-30 10:54:59 +0900
commit57d981f9d765286a85e682f7bee0769d7349e7aa (patch)
tree3fbfef66707cff032da293b1e7ef249131845032 /tests/CMakeLists.txt
parent72dc5bb1fa7bd0823ef17269ab6e5c7dd76f90fd (diff)
downloadDLT-daemon-57d981f9d765286a85e682f7bee0769d7349e7aa.tar.gz
Alternative solutions for json-c dependency
json-c dependency was removed from libdlt ('dlt_common') and shifted into 'dlt-control-common'. By this only the command line tools have a dependency on json-c. dlt-control-common is now built as a static library, so that it can be linked against json-c. Command line tools that included only the .c file of dlt-control-common before, are now linked against this static libarary (see console/CMakeLists.txt). Signed-off-by: dbiastoch <dbiastoch@de.adit-jv.com>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt13
1 files changed, 11 insertions, 2 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 9c1ab86..26edca4 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -2,8 +2,6 @@
add_compile_options(-isystem ${gtest_SOURCE_DIR}/include)
configure_file(${PROJECT_SOURCE_DIR}/tests/testfile.dlt ${PROJECT_BINARY_DIR}/tests COPYONLY)
-configure_file(${PROJECT_SOURCE_DIR}/tests/testfile_extended.dlt ${PROJECT_BINARY_DIR}/tests COPYONLY)
-configure_file(${PROJECT_SOURCE_DIR}/tests/testfilter.json ${PROJECT_BINARY_DIR}/tests COPYONLY)
configure_file(${PROJECT_SOURCE_DIR}/tests/testfilter.txt ${PROJECT_BINARY_DIR}/tests COPYONLY)
configure_file(${PROJECT_SOURCE_DIR}/tests/testfile_filetransfer.txt ${PROJECT_BINARY_DIR}/tests COPYONLY)
@@ -15,6 +13,7 @@ endif()
set(DLT_LIBRARIES ${LIBRARIES} dlt)
set(DLT_DAEMON_LIBRARIES ${LIBRARIES} dlt_daemon)
+set(DLT_CONTROL_LIBRARIES ${LIBRARIES} dlt dlt_control_common_lib)
if(WITH_SYSTEMD OR WITH_SYSTEMD_WATCHDOG OR WITH_SYSTEMD_JOURNAL)
add_definitions( -DSD_EXPORT_SYMBOLS )
@@ -26,6 +25,16 @@ add_test(NAME gtest_dlt_common
COMMAND gtest_dlt_common
WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR})
+if(WITH_EXTENDED_FILTERING)
+ configure_file(${PROJECT_SOURCE_DIR}/tests/testfile_extended.dlt ${PROJECT_BINARY_DIR}/tests COPYONLY)
+ configure_file(${PROJECT_SOURCE_DIR}/tests/testfilter.json ${PROJECT_BINARY_DIR}/tests COPYONLY)
+ add_executable(gtest_dlt_json_filter gtest_dlt_json_filter.cpp)
+ target_link_libraries(gtest_dlt_json_filter ${DLT_CONTROL_LIBRARIES})
+ add_test(NAME gtest_dlt_json_filter
+ COMMAND gtest_dlt_json_filter
+ WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR})
+endif()
+
add_executable(gtest_dlt_user gtest_dlt_user.cpp)
target_link_libraries(gtest_dlt_user ${DLT_LIBRARIES})
add_test(NAME gtest_dlt_user