summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 017d4a2..710cb15 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -96,8 +96,8 @@ endif()
include_directories(
${PROJECT_SOURCE_DIR}
- ${PROJECT_SOURCE_DIR}/include/dlt
${PROJECT_BINARY_DIR}/include/dlt
+ ${PROJECT_SOURCE_DIR}/include/dlt
${PROJECT_SOURCE_DIR}/src/shared
${PROJECT_SOURCE_DIR}/src/core_dump_handler
${PROJECT_SOURCE_DIR}/src/offlinelogstorage
@@ -181,6 +181,7 @@ add_subdirectory(cmake)
if(HAVE_MQUEUE_H AND HAVE_FUNC_MQOPEN AND HAVE_FUNC_MQCLOSE AND
HAVE_FUNC_MQUNLINK AND HAVE_FUNC_MQSEND AND HAVE_FUNC_MQRECEIVE)
add_definitions(-DDLT_NETWORK_TRACE_ENABLE)
+ set(DLT_NETWORK_TRACE_ENABLE 1)
else()
message(STATUS "Disable network trace interface since message queue is not supported")
endif()