summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5a8404d..8bc8152 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -245,6 +245,12 @@ if (WITH_DLT_UNIT_TESTS)
add_subdirectory(tests)
endif()
+SET(CPACK_GENERATOR "DEB")
+SET(CPACK_PACKAGE_NAME "dlt_${DLT_REVISION}")
+SET(CPACK_PACKAGE_VERSION "${PROJECT_VERSION}")
+SET(CPACK_DEBIAN_PACKAGE_MAINTAINER "genivi-diagnostic-log-and-trace@lists.genivi.org")
+INCLUDE(CPack)
+
message(STATUS)
message(STATUS "-------------------------------------------------------------------------------")
message(STATUS "Build for Version ${PROJECT_VERSION} build ${DLT_REVISION} version state ${DLT_VERSION_STATE}")