summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 225ba17..f57b174 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -88,7 +88,10 @@ set( LICENSE "Mozilla Public License Version 2.0" )
# Build, project and include settings
find_package(Threads REQUIRED)
if(WITH_DLT_SYSTEM)
+ set(ZLIB_LIBRARY "-lz")
find_package(ZLIB REQUIRED)
+else(WITH_DLT_SYSTEM)
+ set(ZLIB_LIBRARY "")
endif(WITH_DLT_SYSTEM)
find_package(PkgConfig)