summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt47
1 files changed, 13 insertions, 34 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a5810d0..05677bb 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,38 +1,17 @@
#######
# Dlt - Diagnostic Log and Trace
# @licence make begin@
- #
- # Copyright (C) 2011, BMW AG - Alexander Wenzel <alexander.wenzel@bmw.de>
- #
- # This program is free software; you can redistribute it and/or modify it under the terms of the
- # GNU Lesser General Public License, version 2.1, as published by the Free Software Foundation.
- # This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even
- # the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser General
- # Public License, version 2.1, for more details.
- #
- # You should have received a copy of the GNU Lesser General Public License, version 2.1, along
- # with this program; if not, see <http://www.gnu.org/licenses/lgpl-2.1.html>.
- #
- # Note that the copyright holders assume that the GNU Lesser General Public License, version 2.1, may
- # also be applicable to programs even in cases in which the program is not a library in the technical sense.
- #
- # Linking DLT statically or dynamically with other modules is making a combined work based on DLT. You may
- # license such other modules under the GNU Lesser General Public License, version 2.1. If you do not want to
- # license your linked modules under the GNU Lesser General Public License, version 2.1, you
- # may use the program under the following exception.
- #
- # As a special exception, the copyright holders of DLT give you permission to combine DLT
- # with software programs or libraries that are released under any license unless such a combination is not
- # permitted by the license of such a software program or library. You may copy and distribute such a
- # system following the terms of the GNU Lesser General Public License, version 2.1, including this
- # special exception, for DLT and the licenses of the other code concerned.
- #
- # Note that people who make modified versions of DLT are not obligated to grant this special exception
- # for their modified versions; it is their choice whether to do so. The GNU Lesser General Public License,
- # version 2.1, gives permission to release a modified version without this exception; this exception
- # also makes it possible to release a modified version which carries forward this exception.
- #
- # @licence end@
+#
+# Copyright (C) 2011-2012, BMW AG - Alexander Wenzel <alexander.aw.wenzel@bmw.de>
+#
+# Contributions are licensed to the GENIVI Alliance under one or more
+# Contribution License Agreements.
+#
+# This Source Code Form is subject to the terms of the
+# Mozilla Public License, v. 2.0. If a copy of the MPL was not distributed with
+# this file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# @licence end@
########
cmake_minimum_required( VERSION 2.6 )
@@ -44,7 +23,7 @@ set( CMAKE_ALLOW_LOOSE_LOOP_CONSTRUCTS TRUE )
# Set version parameters
set( DLT_MAJOR_VERSION 2)
set( DLT_MINOR_VERSION 5)
-set( DLT_PATCH_LEVEL 1)
+set( DLT_PATCH_LEVEL 2)
set( DLT_VERSION ${DLT_MAJOR_VERSION}.${DLT_MINOR_VERSION}.${DLT_PATCH_LEVEL})
set( DLT_VERSION_STATE RELEASE )
set( DLT_REVISION "")
@@ -82,7 +61,7 @@ option(WITH_DLTTEST "Set to ON to build with modifications to test Uuser-Dae
# RPM settings
set( GENIVI_RPM_RELEASE "1")#${DLT_REVISION}")
-set( LICENSE "LGPL v2.1 with special exception" )
+set( LICENSE "Mozilla Public License Version 2.0s" )
# Build, project and include settings
find_package(Threads REQUIRED)